]> git.pld-linux.org Git - SPECS.git/blob - python-affinity.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-affinity.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  affinity
6 Summary:        Control processor affinity on linux
7 Name:           python-%{module}
8 Version:        0.1.0
9 Release:        2
10 License:        Python Software Foundation License
11 Group:          Libraries/Python
12 Source0:        https://pypi.python.org/packages/source/a/affinity/%{module}-%{version}.tar.gz
13 # Source0-md5:  cc610cdb05ca675b4089ce2f05796f57
14 URL:            http://cheeseshop.python.org/pypi/affinity
15 BuildRequires:  python-devel
16 BuildRequires:  python-distribute
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 Requires:       python-modules
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 'affinity' provides a simple api for setting the processor affinity
24 by wrapping the specific underlying function calls of each platform.
25
26 %prep
27 %setup -q -n %{module}-%{version}
28
29 %build
30 %py_build
31
32 %{?with_tests:%{__python} setup.py test}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %py_install
37
38 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
39 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
40 %py_postclean
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %dir %{py_sitedir}/affinity
48 %{py_sitedir}/affinity/*.py[co]
49 %attr(755,root,root) %{py_sitedir}/affinity/*.so
50 %{py_sitedir}/affinity-*.egg-info
This page took 0.86683 seconds and 3 git commands to generate.