]> git.pld-linux.org Git - SPECS.git/blob - python-TwistedConch.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-TwistedConch.spec
1 %define         module  TwistedConch
2 %define         major   13.0
3 %define         minor   0
4
5 Summary:        Twisted SSHv2 implementation
6 Summary(pl.UTF-8):      Implementacja SSHv2 dla Twisted
7 Name:           python-%{module}
8 Version:        %{major}.%{minor}
9 Release:        4
10 License:        MIT
11 Group:          Libraries/Python
12 Source0:        http://twistedmatrix.com/Releases/Conch/%{major}/%{module}-%{version}.tar.bz2
13 # Source0-md5:  0d1c4c72302d8af6036cb897438323b7
14 URL:            http://twistedmatrix.com/trac/wiki/TwistedConch
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 BuildRequires:  ZopeInterface
17 BuildRequires:  python-TwistedCore >= 13.0.0
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rpm-pythonprov
20 Requires:       python-TwistedCore >= 13.0.0
21 Requires:       python-TwistedCore-ssl >= 13.0.0
22 Obsoletes:      python-Twisted-conch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Conch is an SSHv2 implementation using the Twisted framework. It
27 includes a server, client, a SFTP client, and a key generator.
28
29 %description -l pl.UTF-8
30 Conch jest implementacją SSHv2 wykorzystującą Twisted. Zawiera serwer,
31 klienta, klienta SFTP i generator kluczy.
32
33 %package doc
34 Summary:        Documentation for TwistedConch
35 Summary(pl.UTF-8):      Dokumentacja do TwistedConch
36 Group:          Libraries/Python
37 Requires:       %{name} = %{version}-%{release}
38
39 %description doc
40 Offline documentation for TwistedConch.
41
42 %description doc -l pl.UTF-8
43 Dokumentacja offline do TwistedConch.
44
45 %package examples
46 Summary:        Example programs for TwistedConch
47 Summary(pl.UTF-8):      Programy przykładowe do TwistedConch
48 Group:          Libraries/Python
49 Requires:       %{name} = %{version}-%{release}
50
51 %description examples
52 This package contains example programs for TwistedConch.
53
54 %description examples -l pl.UTF-8
55 Ten pakiet zawiera przykładowe programy dla TwistedConch.
56
57 %prep
58 %setup -q -n %{module}-%{version}
59
60 %build
61 %py_build
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{py_sitedir}/twisted,%{py_sitescriptdir},%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
66
67 %py_install \
68         --install-purelib=%{py_sitedir} \
69         --root=$RPM_BUILD_ROOT \
70         --optimize=2
71
72 %py_postclean
73
74 install doc/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
75 cp -a doc/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc LICENSE NEWS README
83 %attr(755,root,root) %{_bindir}/*
84 %if "%{py_ver}" > "2.4"
85 %{py_sitedir}/*.egg-info
86 %endif
87 %{py_sitedir}/twisted/conch
88 %{py_sitedir}/twisted/plugins/*
89 %{_mandir}/man1/*.1*
90
91 %files doc
92 %defattr(644,root,root,755)
93 %doc doc/howto
94
95 %files examples
96 %defattr(644,root,root,755)
97 %{_examplesdir}/%{name}-%{version}
This page took 0.232744 seconds and 3 git commands to generate.