]> git.pld-linux.org Git - SPECS.git/blob - python-Soya.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-Soya.spec
1 #
2 %define         module  Soya
3 Summary:        A practical high-level object-oriented 3D engine for Python
4 Summary(pl.UTF-8):      Praktyczny, wysokopoziomowy, zorientowany obiektowo silnik 3D dla Pythona
5 Name:           python-%{module}
6 Version:        0.14
7 Release:        4
8 License:        GPL v2+
9 Group:          Development/Languages/Python
10 Source0:        http://download.gna.org/soya/%{module}-%{version}.tar.bz2
11 # Source0-md5:  9fa56b14d3e9d5fcee073de650b3206f
12 Source1:        http://download.gna.org/soya/SoyaTutorial-%{version}.tar.bz2
13 # Source1-md5:  241d4e56e21cf70487323b3b25f9c37c
14 URL:            http://home.gna.org/oomadness/en/soya3d/
15 BuildRequires:  OpenAL-devel
16 BuildRequires:  OpenGL-devel
17 BuildRequires:  SDL-devel
18 BuildRequires:  cal3d-devel >= 0.10.0
19 BuildRequires:  freetype-devel >= 2.0
20 BuildRequires:  glew-devel
21 BuildRequires:  ncurses-devel
22 BuildRequires:  ode-devel >= 0.7
23 BuildRequires:  python-Pyrex
24 BuildRequires:  python-devel >= 2.4
25 BuildRequires:  python-modules >= 0.9.3
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.710
28 %pyrequires_eq  python
29 Requires:       python-EditObj2
30 Requires:       python-PIL
31 Obsoletes:      Soya
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %description
37 Soya 3D is a high level 3D engine for Python; it aims at being to 3D
38 what Python is to programming: easy and powerful. It is designed with
39 games in mind, focusing both on performance and ease-of-use. It relies
40 on OpenGL, SDL and Cal3D.
41
42 %description -l pl.UTF-8
43 Soya 3D jest wysokopoziomowym silnikiem 3D dla Pythona, zachowującym
44 najlepsze cechy programowania w Pythonie: łatwość i ogromny
45 potencjał. Został zaprojektowany z myślą o grach, skupiając się
46 na wydajności oraz łatwości w użyciu. Opiera się na OpenGL, SDL i
47 Cal3D.
48
49 %package tutorial
50 Summary:        Tutorial for Soya
51 Summary(pl.UTF-8):      Tutorial dla Soya
52 Group:          Development/Languages/Python
53 URL:            http://home.gna.org/oomadness/en/soya3d/tutorials/index.html
54 Requires:       %{name} = %{version}-%{release}
55 Obsoletes:      Soya-tutorial
56
57 %description tutorial
58 Package contains a set of tutorial for Soya.
59
60 %description tutorial -l pl.UTF-8
61 Pakiet zawiera kompletny przewodnik dla Soya.
62
63 %prep
64 %setup -q -n %{module}-%{version} -a1
65
66 %build
67 %py_build
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT%{_mandir}/man1
72
73 %py_install
74
75 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
76 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
77
78 install manpage/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
79
80 %py_postclean
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc AUTHORS CHANGES README*
88 %attr(755,root,root) %{_bindir}/soya_editor
89 %dir %{py_sitedir}/soya
90 %attr(755,root,root) %{py_sitedir}/soya/*.so
91 %{py_sitedir}/soya/*.py[co]
92 %{py_sitedir}/soya/data
93 %dir %{py_sitedir}/soya/blendercal
94 %{py_sitedir}/soya/blendercal/*.py[co]
95 %dir %{py_sitedir}/soya/editor
96 %{py_sitedir}/soya/editor/*.py[co]
97 %dir %{py_sitedir}/soya/gui
98 %{py_sitedir}/soya/gui/*.py[co]
99 %dir %{py_sitedir}/soya/pudding
100 %{py_sitedir}/soya/pudding/*.py[co]
101 %dir %{py_sitedir}/soya/pudding/ext
102 %{py_sitedir}/soya/pudding/ext/*.py[co]
103 %dir %{py_sitedir}/soya/pudding/styles
104 %{py_sitedir}/soya/pudding/styles/*.py[co]
105 %dir %{py_sitedir}/soya/tofu
106 %{py_sitedir}/soya/tofu/*.py[co]
107 %{py_sitedir}/*.egg-info
108 %{_mandir}/man1/soya_editor.*
109
110 %files tutorial
111 %defattr(644,root,root,755)
112 %doc SoyaTutorial-%{version}/{AUTHORS,README,tutorial}
This page took 0.527737 seconds and 3 git commands to generate.