]> git.pld-linux.org Git - SPECS.git/blob - python-RunSnakeRun.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / python-RunSnakeRun.spec
1 %define         module  RunSnakeRun
2 Summary:        GUI Viewer for Python profiling runs
3 Summary(pl.UTF-8):      Interfejs graficzny do wyników profilowania programów Pythonowych
4 Name:           python-%{module}
5 Version:        2.0.4
6 Release:        2
7 License:        BSD
8 Group:          Development/Languages/Python
9 #               http://pypi.python.org/packages/source/R/RunSnakeRun/RunSnakeRun-2.0.2a1.tar.gz
10 Source0:        http://pypi.python.org/packages/source/R/%{module}/%{module}-%{version}.tar.gz
11 # Source0-md5:  3220b5b89994baee70b1c24d7e42a306
12 URL:            http://www.vrplumber.com/programming/runsnakerun/
13 BuildRequires:  python-devel
14 BuildRequires:  python-distribute
15 BuildRequires:  rpm-pythonprov
16 # if py_postclean is used
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python-distribute
19 Requires:       python-SquareMap >= 1.0.1
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 simple program, it doesn't provide all the bells-and-whistles of a
25 program like KCacheGrind, it's intended to allow for profiling your
26 Python programs, and just your Python programs
27
28 %description -l pl.UTF-8
29 Prosty program pozwalający zobaczyć wyniki profiliwoania programów w
30 Pythonie.
31
32 %prep
33 %setup -q -n %{module}-%{version}
34
35 %build
36 %py_build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %py_install
41
42 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
43 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
44 %py_postclean
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
52 %attr(755,root,root) %{_bindir}/runsnake
53 %attr(755,root,root) %{_bindir}/runsnakemem
54 %dir %{py_sitescriptdir}/runsnakerun
55 %{py_sitescriptdir}/runsnakerun/*.py[co]
56 %{py_sitescriptdir}/%{module}*.egg-info
This page took 0.191312 seconds and 3 git commands to generate.