]> git.pld-linux.org Git - packages/python-PyQt4.git/blob - python-PyQt4.spec
- qt4-qmake -> qmake-qt4
[packages/python-PyQt4.git] / python-PyQt4.spec
1 %define         module  PyQt4
2 %define         sipver  2:4.7.1
3
4 Summary:        Python bindings for the Qt4 toolkit
5 Summary(pl.UTF-8):      Dowiązania do toolkitu Qt4 dla Pythona
6 Name:           python-%{module}
7 Version:        4.3.3
8 Release:        1       
9 License:        GPL v2
10 Group:          Libraries/Python
11 Source0:        http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/PyQt-x11-gpl-%{version}.tar.gz
12 # Source0-md5:  a2ead359f57d84c24bdd10de387e80b4
13 URL:            http://www.riverbankcomputing.co.uk/pyqt/index.php
14 BuildRequires:  QtAssistant-devel
15 BuildRequires:  QtGui-devel
16 BuildRequires:  QtNetwork-devel
17 BuildRequires:  QtOpenGL-devel
18 BuildRequires:  QtScript-devel
19 BuildRequires:  QtSql-devel
20 BuildRequires:  QtSvg-devel
21 BuildRequires:  QtXml-devel
22 BuildRequires:  QtTest-devel
23 BuildRequires:  python-sip-devel >= %{sipver}
24 BuildRequires:  qt4-build >= 4.3.3-3
25 BuildRequires:  qt4-qmake >= 4.3.3-3
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 BuildRequires:  sed >= 4.0
29 %pyrequires_eq  python-libs
30 Requires:       python-sip >= %{sipver}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
34 %define         _sipfilesdir    %{_datadir}/sip
35
36 %description
37 PyQt4 is a set of Python bindings for the Qt4 toolkit. The bindings
38 are implemented as a set of Python modules: QtAssistant, QtCore,
39 QtGui, QtNetwork, QtOpenGL, QtSql, QtSvg and QtXml.
40
41 %description -l pl.UTF-8
42 PyQt4 to zbiór dowiązań do Qt4 dla Pythona. Dowiązania zostały
43 zaimplementowane jako moduły Pythona: QtAssistant, QtCore, QtGui,
44 QtNetwork, QtOpenGL, QtSql, QtSvg i QtXml.
45
46 %package devel
47 Summary:        Files needed to build other bindings based on Qt4
48 Summary(pl.UTF-8):      Pliki potrzebne do budowania innych dowiązań bazowanych na Qt4
49 Group:          Development/Languages/Python
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       python-sip-devel
52
53 %description devel
54 Files needed to build other bindings for C++ classes that inherit from
55 any of the Qt4 classes (e.g. KDE or your own).
56
57 %description devel -l pl.UTF-8
58 Pliki potrzebne do budowania innych dowiązań do klas C++
59 dziedziczących z dowolnej klasy Qt4 (np. KDE lub własnych).
60
61 %package examples
62 Summary:        Examples for PyQt4
63 Summary(pl.UTF-8):      Przykłady do PyQt4
64 Group:          Libraries/Python
65 Requires:       %{name} = %{version}-%{release}
66
67 %description examples
68 Examples code demonstrating how to use the Python bindings for Qt4.
69
70 %description examples -l pl.UTF-8
71 Przykładowy kod demonstrujący jak używać PyQt4.
72
73 %prep
74 %setup -q -n PyQt-x11-gpl-%{version}
75 %{__sed} -i 's,pyuic.py,pyuic.pyc,' configure.py
76
77 %build
78 echo 'yes' | python configure.py \
79         -c -j 3 \
80         -b %{_bindir} \
81         -d %{py_sitedir} \
82         -q "%{_bindir}/qmake-qt4" \
83         -v %{_sipfilesdir}/%{module} \
84         LIBDIR_QT="%{_libdir}"
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
96 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
97 %py_postclean
98
99 cp -R examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ChangeLog NEWS README THANKS
107 %attr(755,root,root) %{_bindir}/*
108 %dir %{py_sitedir}/PyQt4
109 %attr(755,root,root) %{py_sitedir}/PyQt4/*.so*
110 %{py_sitedir}/PyQt4/*.py[co]
111 %{py_sitedir}/PyQt4/uic
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_sipfilesdir}/PyQt4
116
117 %files examples
118 %defattr(644,root,root,755)
119 %{_examplesdir}/%{name}-%{version}
This page took 0.03733 seconds and 3 git commands to generate.