]> git.pld-linux.org Git - packages/python-PyQt4.git/blob - python-PyQt4.spec
- x32 rebuild
[packages/python-PyQt4.git] / python-PyQt4.spec
1 # TODO: __pycache__ for python3-PyQt4-uic
2 #
3 # Conditional build:
4 %bcond_without  python2 # CPython 2.x modules
5 %bcond_without  python3 # CPython 3.x modules
6
7 %define         module  PyQt4
8 # minimal required sip version
9 %define         sip_ver 2:4.16.4
10 # last qt version covered by these bindings (minimal required is currently 4.1.0)
11 %define         qt_ver  4.8.6
12
13 Summary:        Python 2 bindings for the Qt4 toolkit
14 Summary(pl.UTF-8):      Wiązania Pythona 2 do toolkitu Qt4
15 Name:           python-%{module}
16 Version:        4.11.3
17 Release:        4
18 License:        GPL v2 or GPL v3 with FLOSS exception
19 Group:          Libraries/Python
20 Source0:        http://downloads.sourceforge.net/pyqt/PyQt-x11-gpl-%{version}.tar.gz
21 # Source0-md5:  997c3e443165a89a559e0d96b061bf70
22 Patch0:         %{name}-dbuspath.patch
23 Patch1:         %{name}-64bit.patch
24 URL:            http://www.riverbankcomputing.com/software/pyqt/
25 # most of BR comes from configure.py
26 BuildRequires:  QtAssistant-compat-devel >= 4.6.3
27 BuildRequires:  QtCore-devel >= %{qt_ver}
28 BuildRequires:  QtDBus-devel >= %{qt_ver}
29 BuildRequires:  QtDeclarative-devel >= %{qt_ver}
30 BuildRequires:  QtDesigner-devel >= %{qt_ver}
31 BuildRequires:  QtGui-devel >= %{qt_ver}
32 BuildRequires:  QtHelp-devel >= %{qt_ver}
33 BuildRequires:  QtMultimedia-devel >= %{qt_ver}
34 BuildRequires:  QtNetwork-devel >= %{qt_ver}
35 BuildRequires:  QtOpenGL-devel >= %{qt_ver}
36 BuildRequires:  QtScript-devel >= %{qt_ver}
37 BuildRequires:  QtScriptTools-devel >= %{qt_ver}
38 BuildRequires:  QtSql-devel >= %{qt_ver}
39 BuildRequires:  QtSvg-devel >= %{qt_ver}
40 BuildRequires:  QtTest-devel >= %{qt_ver}
41 BuildRequires:  QtWebKit-devel >= %{qt_ver}
42 BuildRequires:  QtXml-devel >= %{qt_ver}
43 BuildRequires:  QtXmlPatterns-devel >= %{qt_ver}
44 BuildRequires:  phonon-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  python-dbus-devel >= 0.80
47 %if %{with python2}
48 BuildRequires:  python-dbus >= 0.80
49 BuildRequires:  python-sip-devel >= %{sip_ver}
50 %endif
51 %if %{with python3}
52 BuildRequires:  python3-dbus >= 0.80
53 BuildRequires:  python3-sip-devel >= %{sip_ver}
54 %endif
55 BuildRequires:  qt4-build >= 4.3.3-3
56 BuildRequires:  qt4-qmake >= 4.3.3-3
57 BuildRequires:  rpm-pythonprov
58 BuildRequires:  rpmbuild(macros) >= 1.219
59 Requires:       python-libs
60 Requires:       python-dbus >= 0.80
61 Requires:       python-sip >= %{sip_ver}
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _sipfilesdir    %{_datadir}/sip
65
66 %description
67 PyQt4 is a set of Python bindings for the Qt4 toolkit. The bindings
68 are implemented as a set of Python modules: QtCore, QtDeclarative,
69 QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
70 QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
71 QtXmlPatterns and phonon.
72
73 This package contains Python 2 bindings.
74
75 %description -l pl.UTF-8
76 PyQt4 to zbiór wiązań Qt4 dla Pythona. Dowiązania zostały
77 zaimplementowane jako moduły Pythona: QtCore, QtDeclarative,
78 QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
79 QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
80 QtXmlPatterns oraz phonon.
81
82 Ten pakiet zawiera wiązania Pythona 2.
83
84 %package uic
85 Summary:        pyuic4 development tool for Python 2
86 Summary(pl.UTF-8):      Narzędzie programistyczne pyuic4 dla Pythona 2
87 Group:          Development/Tools
88 Requires:       %{name} = %{version}-%{release}
89
90 %description uic
91 pyuic4 development tool for Python 2.
92
93 %description uic -l pl.UTF-8
94 Narzędzie programistyczne pyuic4 dla Pythona 2.
95
96 %package -n python3-PyQt4
97 Summary:        Python 2 bindings for the Qt4 toolkit
98 Summary(pl.UTF-8):      Wiązania Pythona 2 do toolkitu Qt4
99 Group:          Libraries/Python
100 Requires:       python3-libs
101 Requires:       python3-dbus >= 0.80
102 Requires:       python3-sip >= %{sip_ver}
103
104 %description -n python3-PyQt4
105 PyQt4 is a set of Python bindings for the Qt4 toolkit. The bindings
106 are implemented as a set of Python modules: QtCore, QtDeclarative,
107 QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
108 QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
109 QtXmlPatterns and phonon.
110
111 This package contains Python 3 bindings.
112
113 %description -n python3-PyQt4 -l pl.UTF-8
114 PyQt4 to zbiór wiązań Qt4 dla Pythona. Dowiązania zostały
115 zaimplementowane jako moduły Pythona: QtCore, QtDeclarative,
116 QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
117 QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
118 QtXmlPatterns oraz phonon.
119
120 Ten pakiet zawiera wiązania Pythona 3.
121
122 %package -n python3-PyQt4-uic
123 Summary:        pyuic4 development tool for Python 3
124 Summary(pl.UTF-8):      Narzędzie programistyczne pyuic4 dla Pythona 3
125 Group:          Development/Tools
126 Requires:       python3-PyQt4 = %{version}-%{release}
127
128 %description -n python3-PyQt4-uic
129 pyuic4 development tool for Python 3.
130
131 %description -n python3-PyQt4-uic -l pl.UTF-8
132 Narzędzie programistyczne pyuic4 dla Pythona 3.
133
134 %package devel-tools
135 Summary:        PyQt4 development tools
136 Summary(pl.UTF-8):      Narzędzia programistyczne PyQt4
137 Group:          Development/Tools
138 Requires:       QtCore >= %{qt_ver}
139 Requires:       QtXml >= %{qt_ver}
140
141 %description devel-tools
142 PyQt4 development tools: pylupdate4, pyrcc4.
143
144 Note: this package doesn't depend on Python version.
145
146 %description devel-tools -l pl.UTF-8
147 Narzędzia programistyczne PyQt4: pylupdate4, pyrcc4.
148
149 Uwaga: ten pakiet nie jest zależny od wersji Pythona.
150
151 %package examples
152 Summary:        Examples for PyQt4
153 Summary(pl.UTF-8):      Przykłady do PyQt4
154 Group:          Libraries/Python
155 Requires:       %{name} = %{version}-%{release}
156
157 %description examples
158 Examples code demonstrating how to use the Python bindings for Qt4.
159
160 %description examples -l pl.UTF-8
161 Przykładowy kod demonstrujący jak używać PyQt4.
162
163 %package -n sip-PyQt4
164 Summary:        SIP files needed to build other bindings based on Qt4
165 Summary(pl.UTF-8):      Pliki SIP potrzebne do budowania innych wiązań opartych na Qt4
166 Group:          Development/Languages/Python
167 Requires:       sip >= %{sip_ver}
168 Obsoletes:      python-PyQt4-devel < 4.11.3-2
169
170 %description -n sip-PyQt4
171 SIP files needed to build other bindings for C++ classes that inherit
172 from any of the Qt4 classes (e.g. KDE or your own).
173
174 %description -n sip-PyQt4 -l pl.UTF-8
175 Pliki SIP potrzebne do budowania innych wiązań do klas C++
176 dziedziczących z dowolnej klasy Qt4 (np. KDE lub własnych).
177
178 %package -n QtDesigner-plugin-pyqt4
179 Summary:        Qt Designer plugin for Python plugins with widgets
180 Summary(pl.UTF-8):      Wtyczka Qt Designera dla wtyczek Pythona zawierających widgety
181 # can build only for one python version
182 %if %{with python2}
183 Requires:       %{name} = %{version}-%{release}
184 %else
185 Requires:       python3-PyQt4 = %{version}-%{release}
186 %endif
187
188 %description -n QtDesigner-plugin-pyqt4
189 This is the Qt Designer plugin that collects all the Python plugins it
190 can find as a widget collection to Designer.
191
192 %description -n QtDesigner-plugin-pyqt4 -l pl.UTF-8
193 Ten pakiet zawiera wtyczkę Qt Designera zbierającą wszystkie wtyczki
194 Pythona, które jest w stanie znaleźć, jako zestaw widgetów dla
195 Designera.
196
197 %package -n qscintilla2-%{module}-api
198 Summary:        PyQt4 API file for QScintilla
199 Summary(pl.UTF-8):      Plik API PyQt4 dla QScintilli
200 Group:          Libraries/Python
201 Requires:       qscintilla2-qt4 >= 2.8.4
202
203 %description -n qscintilla2-%{module}-api
204 PyQt4 API file can be used by the QScintilla editor component to
205 enable the use of auto-completion and call tips when editing PyQt4
206 code.
207
208 %description -n qscintilla2-%{module}-api -l pl.UTF-8
209 Plik API PyQt4 może być używany przez komponent edytora QScintilla aby
210 umożliwić automatyczne dopełnianie i podpowiedzi przy modyfikowaniu
211 kodu wykorzystującego PyQt4.
212
213 %prep
214 %setup -q -n PyQt-x11-gpl-%{version}
215 %{__sed} -i 's,pyuic.py,pyuic.pyc,' configure.py
216 # small hack to build for shared libs - symbol QT_SHARED not defined anymore?
217 %{__sed} -i 's/qt_shared = lines\[.*\]/qt_shared = "y"/' configure.py
218 %{__sed} -i 's/resp = sys.stdin.readline.*/resp = "yes"/' configure.py
219 %patch0 -p1
220 %patch1 -p1
221
222 %build
223 %if %{with python2}
224 install -d build-py2
225 cd build-py2
226 %{__python} ../configure.py \
227         --confirm-license \
228         -c -j 3 \
229         -a \
230         -b %{_bindir} \
231         -d %{py_sitedir} \
232         -q "%{_bindir}/qmake-qt4" \
233         -v %{_sipfilesdir}/%{module} \
234         --dbus-path="%{py_sitedir}/dbus/mainloop" \
235         LIBDIR_QT="%{_libdir}" \
236         CC="%{__cc}" \
237         CXX="%{__cxx}"
238
239 %{__make}
240 cd ..
241 %endif
242
243 %if %{with python3}
244 install -d build-py3
245 cd build-py3
246 %{__python3} ../configure.py \
247         --confirm-license \
248         -c -j 3 \
249         -a \
250         -b %{_bindir} \
251         -d %{py3_sitedir} \
252         -q "%{_bindir}/qmake-qt4" \
253         -v %{_sipfilesdir}/%{module} \
254         --dbus-path="%{py3_sitedir}/dbus/mainloop" \
255         LIBDIR_QT="%{_libdir}" \
256         CC="%{__cc}" \
257         CXX="%{__cxx}"
258
259 %{__make}
260 cd ..
261 %endif
262
263 %install
264 rm -rf $RPM_BUILD_ROOT
265 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
266
267 %if %{with python3}
268 %{__make} -C build-py3 install \
269         DESTDIR=$RPM_BUILD_ROOT \
270         INSTALL_ROOT=$RPM_BUILD_ROOT
271
272 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pyuic4{,-3}
273 %endif
274
275 %if %{with python2}
276 %{__make} -C build-py2 install \
277         DESTDIR=$RPM_BUILD_ROOT \
278         INSTALL_ROOT=$RPM_BUILD_ROOT
279
280 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
281 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
282
283 # don't use py_postclean, leave *.py in %{py_sitedir}/PyQt4/uic/widget-plugins
284 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/*.py
285 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/*.py
286 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/Compiler/*.py
287 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/Loader/*.py
288 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/port_v2/*.py
289 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/port_v3/*.py
290 %endif
291
292 cp -R examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
293
294 %clean
295 rm -rf $RPM_BUILD_ROOT
296
297 %if %{with python2}
298 %files
299 %defattr(644,root,root,755)
300 %doc GPL_EXCEPTION.TXT NEWS OPENSOURCE-NOTICE.TXT README THANKS
301 %dir %{py_sitedir}/PyQt4
302 %attr(755,root,root) %{py_sitedir}/PyQt4/Qt.so
303 %attr(755,root,root) %{py_sitedir}/PyQt4/QtAssistant.so
304 %attr(755,root,root) %{py_sitedir}/PyQt4/QtCore.so
305 %attr(755,root,root) %{py_sitedir}/PyQt4/QtDBus.so
306 %attr(755,root,root) %{py_sitedir}/PyQt4/QtDeclarative.so
307 %attr(755,root,root) %{py_sitedir}/PyQt4/QtDesigner.so
308 %attr(755,root,root) %{py_sitedir}/PyQt4/QtGui.so
309 %attr(755,root,root) %{py_sitedir}/PyQt4/QtHelp.so
310 %attr(755,root,root) %{py_sitedir}/PyQt4/QtMultimedia.so
311 %attr(755,root,root) %{py_sitedir}/PyQt4/QtNetwork.so
312 %attr(755,root,root) %{py_sitedir}/PyQt4/QtOpenGL.so
313 %attr(755,root,root) %{py_sitedir}/PyQt4/QtScript.so
314 %attr(755,root,root) %{py_sitedir}/PyQt4/QtScriptTools.so
315 %attr(755,root,root) %{py_sitedir}/PyQt4/QtSql.so
316 %attr(755,root,root) %{py_sitedir}/PyQt4/QtSvg.so
317 %attr(755,root,root) %{py_sitedir}/PyQt4/QtTest.so
318 %attr(755,root,root) %{py_sitedir}/PyQt4/QtWebKit.so
319 %attr(755,root,root) %{py_sitedir}/PyQt4/QtXml.so
320 %attr(755,root,root) %{py_sitedir}/PyQt4/QtXmlPatterns.so
321 %attr(755,root,root) %{py_sitedir}/PyQt4/phonon.so
322 %{py_sitedir}/PyQt4/__init__.py[co]
323 %{py_sitedir}/PyQt4/pyqtconfig.py[co]
324 %attr(755,root,root) %{py_sitedir}/dbus/mainloop/qt.so
325
326 %files uic
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_bindir}/pyuic4
329 %{py_sitedir}/PyQt4/uic
330 %endif
331
332 %if %{with python3}
333 %files -n python3-PyQt4
334 %defattr(644,root,root,755)
335 %doc GPL_EXCEPTION.TXT NEWS OPENSOURCE-NOTICE.TXT README THANKS
336 %dir %{py3_sitedir}/PyQt4
337 %attr(755,root,root) %{py3_sitedir}/PyQt4/Qt.so
338 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtAssistant.so
339 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtCore.so
340 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtDBus.so
341 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtDeclarative.so
342 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtDesigner.so
343 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtGui.so
344 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtHelp.so
345 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtMultimedia.so
346 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtNetwork.so
347 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtOpenGL.so
348 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtScript.so
349 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtScriptTools.so
350 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtSql.so
351 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtSvg.so
352 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtTest.so
353 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtWebKit.so
354 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtXml.so
355 %attr(755,root,root) %{py3_sitedir}/PyQt4/QtXmlPatterns.so
356 %attr(755,root,root) %{py3_sitedir}/PyQt4/phonon.so
357 %{py3_sitedir}/PyQt4/__init__.py
358 %{py3_sitedir}/PyQt4/pyqtconfig.py
359 %attr(755,root,root) %{py3_sitedir}/dbus/mainloop/qt.so
360
361 %files -n python3-PyQt4-uic
362 %defattr(644,root,root,755)
363 %attr(755,root,root) %{_bindir}/pyuic4-3
364 %{py3_sitedir}/PyQt4/uic
365 %endif
366
367 %files devel-tools
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_bindir}/pylupdate4
370 %attr(755,root,root) %{_bindir}/pyrcc4
371
372 %files examples
373 %defattr(644,root,root,755)
374 %{_examplesdir}/%{name}-%{version}
375
376 %files -n sip-PyQt4
377 %defattr(644,root,root,755)
378 %{_sipfilesdir}/PyQt4
379
380 %files -n QtDesigner-plugin-pyqt4
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libpyqt4.so
383
384 %files -n qscintilla2-%{module}-api
385 %defattr(644,root,root,755)
386 %{_datadir}/qt4/qsci/api/python/PyQt4.api
This page took 0.096523 seconds and 3 git commands to generate.