]> git.pld-linux.org Git - packages/python-PyQt4.git/blob - python-PyQt4.spec
- some files added
[packages/python-PyQt4.git] / python-PyQt4.spec
1 # TODO: package /usr/lib/qt4/plugins/designer/* ?
2
3 %define         module  PyQt4
4 %define         sipver  2:4.7.5
5
6 Summary:        Python bindings for the Qt4 toolkit
7 Summary(pl.UTF-8):      Dowiązania do toolkitu Qt4 dla Pythona
8 Name:           python-%{module}
9 Version:        4.4.2
10 Release:        1
11 License:        GPL v2
12 Group:          Libraries/Python
13 Source0:        http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
14 # Source0-md5:  a3f1e828fe74242441f17020c10ba06b
15 URL:            http://www.riverbankcomputing.com/software/pyqt/
16 BuildRequires:  QtAssistant-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtOpenGL-devel
20 BuildRequires:  QtScript-devel
21 BuildRequires:  QtSql-devel
22 BuildRequires:  QtSvg-devel
23 BuildRequires:  QtTest-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  python-dbus-devel >= 0.80
26 BuildRequires:  python-sip-devel >= %{sipver}
27 BuildRequires:  qt4-build >= 4.3.3-3
28 BuildRequires:  qt4-qmake >= 4.3.3-3
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.219
31 BuildRequires:  sed >= 4.0
32 %pyrequires_eq  python-libs
33 Requires:       python-sip >= %{sipver}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37 %define         _sipfilesdir    %{_datadir}/sip
38
39 %description
40 PyQt4 is a set of Python bindings for the Qt4 toolkit. The bindings
41 are implemented as a set of Python modules: QtAssistant, QtCore,
42 QtGui, QtNetwork, QtOpenGL, QtSql, QtSvg and QtXml.
43
44 %description -l pl.UTF-8
45 PyQt4 to zbiór dowiązań do Qt4 dla Pythona. Dowiązania zostały
46 zaimplementowane jako moduły Pythona: QtAssistant, QtCore, QtGui,
47 QtNetwork, QtOpenGL, QtSql, QtSvg i QtXml.
48
49 %package devel
50 Summary:        Files needed to build other bindings based on Qt4
51 Summary(pl.UTF-8):      Pliki potrzebne do budowania innych dowiązań bazowanych na Qt4
52 Group:          Development/Languages/Python
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       python-sip-devel
55
56 %description devel
57 Files needed to build other bindings for C++ classes that inherit from
58 any of the Qt4 classes (e.g. KDE or your own).
59
60 %description devel -l pl.UTF-8
61 Pliki potrzebne do budowania innych dowiązań do klas C++
62 dziedziczących z dowolnej klasy Qt4 (np. KDE lub własnych).
63
64 %package examples
65 Summary:        Examples for PyQt4
66 Summary(pl.UTF-8):      Przykłady do PyQt4
67 Group:          Libraries/Python
68 Requires:       %{name} = %{version}-%{release}
69
70 %description examples
71 Examples code demonstrating how to use the Python bindings for Qt4.
72
73 %description examples -l pl.UTF-8
74 Przykładowy kod demonstrujący jak używać PyQt4.
75
76 %prep
77 %setup -q -n PyQt-x11-gpl-%{version}
78 %{__sed} -i 's,pyuic.py,pyuic.pyc,' configure.py
79
80 %build
81 echo 'yes' | python configure.py \
82         -c -j 3 \
83         -b %{_bindir} \
84         -d %{py_sitedir} \
85         -q "%{_bindir}/qmake-qt4" \
86         -v %{_sipfilesdir}/%{module} \
87         LIBDIR_QT="%{_libdir}" \
88         CC="%{__cc}" \
89         CXX="%{__cxx}"
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
99
100 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
101 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
102 %py_postclean
103
104 cp -R examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ChangeLog NEWS README THANKS
112 %attr(755,root,root) %{_bindir}/*
113 %dir %{py_sitedir}/PyQt4
114 %attr(755,root,root) %{py_sitedir}/PyQt4/*.so*
115 %attr(755,root,root) %{py_sitescriptdir}/dbus/mainloop/qt.so
116 %attr(755,root,root) %{_libdir}/qt4/plugins/designer/libpythonplugin.so
117 %{py_sitedir}/PyQt4/*.py[co]
118 %{py_sitedir}/PyQt4/uic
119 %{_datadir}/qt4/qsci/api/python/PyQt4.api
120
121 %files devel
122 %defattr(644,root,root,755)
123 %{_sipfilesdir}/PyQt4
124
125 %files examples
126 %defattr(644,root,root,755)
127 %{_examplesdir}/%{name}-%{version}
This page took 0.031835 seconds and 3 git commands to generate.