]> git.pld-linux.org Git - SPECS.git/blob - python-Numeric.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / python-Numeric.spec
1 %define         module  Numeric
2 Summary:        Python numerical facilities
3 Summary(pl.UTF-8):      Moduły do obliczeń numerycznych dla języka Python
4 Name:           python-%{module}
5 Version:        24.2
6 Release:        9
7 License:        distributable
8 Group:          Libraries/Python
9 Source0:        http://downloads.sourceforge.net/numpy/%{module}-%{version}.tar.gz
10 # Source0-md5:  2ae672656e06716a149acb048cca3093
11 URL:            http://sourceforge.net/projects/numpy/
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  python-devel >= 1:2.3
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 Requires:       python-libs
17 Obsoletes:      python-numpy <= 0:24.2
18 # dropped some time ago
19 Obsoletes:      python-numpy-Properties
20 # dropped some time ago, should have been "released as separate package", but finally wasn't
21 Obsoletes:      python-numpy-kinds <= 0:24.2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 NumPy is a collection of extension modules to provide high-performance
26 multidimensional numeric arrays to the Python programming language.
27
28 %description -l pl.UTF-8
29 Pakiet umożliwia wydajne obliczenia numeryczne na macierzach
30 wielowymiarowych.
31
32 %package devel
33 Summary:        C header files for numerical modules
34 Summary(pl.UTF-8):      Pliki nagłówkowe języka C modułów numerycznych
35 Group:          Development/Languages/Python
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       python-devel
38 Obsoletes:      python-numpy-devel <= 0:24.2
39
40 %description devel
41 C header files for numerical modules.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe języka C modułów numerycznych.
45
46 %package FFT
47 Summary:        Interface to the FFTPACK FORTRAN library
48 Summary(pl.UTF-8):      Interfejs do biblioteki FFTPACK języka Fortran
49 Group:          Libraries/Python
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       python-libs
52 Obsoletes:      python-numpy-FFT <= 0:24.2
53
54 %description FFT
55 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
56 library, which is a powerful standard library for doing fast Fourier
57 transforms of real and complex data sets.
58
59 %description FFT -l pl.UTF-8
60 Moduł FFT zawiera prosty interfejs do biblioteki FFTPACK języka
61 Fortran. Ta biblioteka o wysokich możliwościach jest standardowo
62 używana do prowadzenia obliczeń za pomocą dyskretnej transformaty
63 Fouriera na liczba rzeczywistych i zespolonych.
64
65 %package MA
66 Summary:        MA - a facility for dealing with masked arrays
67 Summary(pl.UTF-8):      Moduł do obsługi macierzy niepełnych
68 Group:          Libraries/Python
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       python-libs
71 Obsoletes:      python-numpy-MA <= 0:24.2
72
73 %description MA
74 Masked arrays are arrays that may have missing or invalid entries.
75 Module MA provides a work-alike replacement for Numeric that supports
76 data arrays with masks.
77
78 %description MA -l pl.UTF-8
79 Macierze niepełne są to macierze, którym może brakować lub mogą
80 zawierać niepoprawne wartości. Moduł MA zawiera odpowiednie narzędzia
81 do operowania na tego typu macierzach.
82
83 %package RNG
84 Summary:        Random Number Generator Object for NumPy
85 Summary(pl.UTF-8):      Obiekt generatora liczb losowych dla modułu NumPy
86 Group:          Libraries/Python
87 Requires:       %{name} = %{version}-%{release}
88 Requires:       python-libs
89 Obsoletes:      python-numpy-RNG <= 0:24.2
90
91 %description RNG
92 RNG provides a random number object to Numerical Python.
93
94 %description RNG -l pl.UTF-8
95 Moduł ten zawiera implementację obiektu generatora liczb losowych dla
96 języka Python.
97
98 %prep
99 %setup -q -n %{module}-%{version}
100
101 %build
102 %py_build
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 %py_install
107
108 %py_postclean
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %{py_sitedir}/%{module}.pth
116 %dir %{py_sitedir}/%{module}
117 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
118 %dir %{py_sitedir}/%{module}/Numeric_headers
119 %{py_sitedir}/%{module}/Numeric_headers/*.py[co]
120 %{py_sitedir}/%{module}/*.py[co]
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{py_incdir}/%{module}
125
126 %files FFT
127 %defattr(644,root,root,755)
128 %dir %{py_sitedir}/%{module}/FFT
129 %attr(755,root,root) %{py_sitedir}/%{module}/FFT/*.so
130 %{py_sitedir}/%{module}/FFT/*.py[co]
131
132 %if 0
133 %files kinds
134 %defattr(644,root,root,755)
135 %dir %{py_sitedir}/%{module}/kinds
136 %attr(755,root,root) %{py_sitedir}/%{module}/kinds/*.so
137 %{py_sitedir}/%{module}/kinds/*.py[co]
138 %endif
139
140 %files MA
141 %defattr(644,root,root,755)
142 %dir %{py_sitedir}/%{module}/MA
143 %{py_sitedir}/%{module}/MA/*.py[co]
144
145 %if 0
146 %files Properties
147 %defattr(644,root,root,755)
148 %dir %{py_sitedir}/%{module}/PropertiedClasses
149 %{py_sitedir}/%{module}/PropertiedClasses/*.py[co]
150 %endif
151
152 %files RNG
153 %defattr(644,root,root,755)
154 %dir %{py_sitedir}/%{module}/RNG
155 %attr(755,root,root) %{py_sitedir}/%{module}/RNG/*.so
156 %{py_sitedir}/%{module}/RNG/*.py[co]
This page took 0.420932 seconds and 3 git commands to generate.