]> git.pld-linux.org Git - packages/python-HTMLgen.git/blob - python-HTMLgen.spec
- massive attack: source-md5
[packages/python-HTMLgen.git] / python-HTMLgen.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module HTMLgen
4
5 Summary:        Class library to create HTML documents from within Python
6 Summary(pl):    Modu³ do tworzenia dokumentów w HTML przy u¿yciu Pythona
7 Name:           python-%{module}
8 Version:        2.2.2
9 Release:        5
10 License:        distributable
11 Group:          Development/Languages/Python
12 Source0:        http://starship.python.net/crew/friedrich/%{module}.tgz
13 # Source0-md5:  cd20f8b63d3215e57289ddbf56c97f48
14 Patch0:         %{name}-fixpaths.patch
15 URL:            http://starship.python.net/crew/friedrich/HTMLgen/html/main.html
16 BuildRequires:  python-devel >= 2.2.1
17 %pyrequires_eq  python
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 HTMLgen is a class library for the generation of HTML documents with
23 Python scripts. It's used when you want to create HTML pages
24 containing information which changes from time to time. For example
25 you might want to have a page which provides an overall system summary
26 of data collected nightly. Or maybe you have a catalog of data and
27 images that you would like formed into a spiffy set of web pages for
28 the world to browse. Python is a great scripting language for these
29 tasks and with HTMLgen it's very straightforward to construct objects
30 which are rendered out into consistently structured web pages. Of
31 course, CGI scripts written in Python can take advantage of these
32 classes as well.
33
34 This software should work on both Unix and Macintosh and Win32
35 platforms running Python 1.3 or greater. (HTMLcalendar.py requires
36 1.4) If you are running 1.5 the new re and string module enhancements
37 are used for performance.
38
39 %description -l pl
40 HTMLGen jest modu³em do tworzenia dokumentów w HTML-u za pomoc±
41 skryptów w Pythonie. Jest przydatny do generowania stron WWW
42 zawieraj±cych okresowo zmieniaj±ce sie informacje. Na przyk³ad stronê
43 zawieraj±c± dzienne podsumowania statystyki wykorzystania serwera.
44 Innym typowym zastosowaniem jest przygotowywanie strony zawieraj±cej
45 opis i odnosniki do rysunków znajduj±cych sie w okreslonym katalogu,
46 tak aby mo¿na je by³o ³atwo ogl±daæ przez WWW. Python jest dobrym
47 jêzykiem do programowania takich zadañ, a wykorzystanie biblioteki
48 HTMLgen znacznie u³atwia konstruowanie obiektów, które po
49 przetworzeniu przez tê bibliotekê utworz± spójn± stronê WWW.
50 Oczywi¶cie sktypty CGI pisane w Pythonie równie¿ mog± robiæ u¿ytek z
51 tej bilioteki.
52
53 %prep
54 %setup -q -n HTMLgen
55 %patch -p0
56
57 %build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/HTMLgen
62
63 mv -f *.py $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/HTMLgen
64 echo %{module} > $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/%{module}.pth
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README ChangeLog data html image *.rc
72 %{py_sitedir}/site-packages/HTMLgen
73 %{py_sitedir}/site-packages/HTMLgen.pth
This page took 0.067076 seconds and 4 git commands to generate.