]> git.pld-linux.org Git - packages/python-HTMLgen.git/blob - python-HTMLgen.spec
fc2b51c982cabb91fe9b763db597da25cd3177db
[packages/python-HTMLgen.git] / python-HTMLgen.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module HTMLgen
4
5 Summary:        Class library to create HTML documents from within Python
6 Summary(pl):    Modu³ do tworzenia dokumentów w HTML przy u¿yciu Pythona
7 Name:           python-%{module}
8 Version:        2.2.2
9 Release:        5
10 License:        distributable
11 Group:          Development/Languages/Python
12 Source0:        http://starship.python.net/crew/friedrich/%{module}.tgz
13 Patch0:         %{name}-fixpaths.patch
14 URL:            http://starship.python.net/crew/friedrich/HTMLgen/html/main.html
15 BuildRequires:  python-devel >= 2.2.1
16 %pyrequires_eq  python
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 HTMLgen is a class library for the generation of HTML documents with
22 Python scripts. It's used when you want to create HTML pages
23 containing information which changes from time to time. For example
24 you might want to have a page which provides an overall system summary
25 of data collected nightly. Or maybe you have a catalog of data and
26 images that you would like formed into a spiffy set of web pages for
27 the world to browse. Python is a great scripting language for these
28 tasks and with HTMLgen it's very straightforward to construct objects
29 which are rendered out into consistently structured web pages. Of
30 course, CGI scripts written in Python can take advantage of these
31 classes as well.
32
33 This software should work on both Unix and Macintosh and Win32
34 platforms running Python 1.3 or greater. (HTMLcalendar.py requires
35 1.4) If you are running 1.5 the new re and string module enhancements
36 are used for performance.
37
38 %description -l pl
39 HTMLGen jest modu³em do tworzenia dokumentów w HTML-u za pomoc±
40 skryptów w Pythonie. Jest przydatny do generowania stron WWW
41 zawieraj±cych okresowo zmieniaj±ce sie informacje. Na przyk³ad stronê
42 zawieraj±c± dzienne podsumowania statystyki wykorzystania serwera.
43 Innym typowym zastosowaniem jest przygotowywanie strony zawieraj±cej
44 opis i odnosniki do rysunków znajduj±cych sie w okreslonym katalogu,
45 tak aby mo¿na je by³o ³atwo ogl±daæ przez WWW. Python jest dobrym
46 jêzykiem do programowania takich zadañ, a wykorzystanie biblioteki
47 HTMLgen znacznie u³atwia konstruowanie obiektów, które po
48 przetworzeniu przez tê bibliotekê utworz± spójn± stronê WWW.
49 Oczywi¶cie sktypty CGI pisane w Pythonie równie¿ mog± robiæ u¿ytek z
50 tej bilioteki.
51
52 %prep
53 %setup -q -n HTMLgen
54 %patch -p0
55
56 %build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/HTMLgen
61
62 mv -f *.py $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/HTMLgen
63 echo %{module} > $RPM_BUILD_ROOT%{_libdir}/python1.5/site-packages/%{module}.pth
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc README ChangeLog data html image *.rc
71 %{py_sitedir}/site-packages/HTMLgen
72 %{py_sitedir}/site-packages/HTMLgen.pth
This page took 0.050488 seconds and 2 git commands to generate.