]> git.pld-linux.org Git - packages/python-CDDB.git/blob - python-CDDB.spec
- converted to UTF-8
[packages/python-CDDB.git] / python-CDDB.spec
1 %define         module  CDDB
2
3 Summary:        Module for accessing CDDB and FreeDB
4 Summary(pl.UTF-8):   Moduł do łączenia z bazami CDDB i FreeDB
5 Name:           python-%{module}
6 Version:        1.4
7 Release:        5
8 License:        GPL
9 Group:          Development/Languages/Python
10 Source0:        http://cddb-py.sourceforge.net/%{module}-%{version}.tar.gz
11 # Source0-md5:  254698082bafe3030d07d88fb7e13fe2
12 URL:            http://cddb-py.sourceforge.net/
13 BuildRequires:  python >= 1:2.5
14 BuildRequires:  python-devel >= 1:2.5
15 %pyrequires_eq  python-modules
16 BuildRequires:  rpm-pythonprov
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is a set of three modules to access the CDDB and FreeDB online
21 databases of audio CD track titles and information. It includes a C
22 extension module to fetch track lengths under Linux, FreeBSD, OpenBSD,
23 Mac OS X, Solaris, and Win32, which is easily ported to other
24 operating systems.
25
26 %description -l pl.UTF-8
27 Jest to zestaw trzech modułów umożliwiających połączenie z bazami CDDB
28 i FreeDB w celu pobierania tytułów i informacji o ścieżkach płyt CD.
29 Pakiet zawiera też moduł w C do wyciągania długości ścieżek działający
30 pod Linuksem, FreeBSD, OpenBSD, MacOS X, Solarisem i Win32.
31
32 %prep
33 %setup -q -n %{module}-%{version}
34
35 %build
36 CFLAGS="%{rpmcflags}"
37 export CFLAGS
38 python setup.py build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
43
44 python setup.py install \
45         --root=$RPM_BUILD_ROOT \
46         --optimize=2
47
48 install cddb-info.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README CHANGES
58 %{py_sitedir}/*.py[co]
59 %{py_sitedir}/CDDB-*.egg-info
60 %attr(755,root,root) %{py_sitedir}/cdrom.so
61 %{_examplesdir}/%{name}-%{version}
This page took 0.104947 seconds and 3 git commands to generate.