]> git.pld-linux.org Git - packages/python-CDDB.git/blob - python-CDDB.spec
- fixed License, .so perms, don't include Yet Another Copy of GPL text
[packages/python-CDDB.git] / python-CDDB.spec
1 %define         module CDDB
2
3 Summary:        Module for accessing CDDB and FreeDB
4 Summary(pl):    Modu³ do ³±czenia z bazami CDDB i FreeDB
5 Name:           python-%{module}
6 Version:        1.4
7 Release:        1
8 License:        GPL
9 Group:          Development/Languages/Python
10 Source0:        http://cddb-py.sourceforge.net/%{module}-%{version}.tar.gz
11 # Source0-md5:  254698082bafe3030d07d88fb7e13fe2
12 URL:            http://cddb-py.sourceforge.net/
13 %pyrequires_eq  python-modules
14 BuildRequires:  python-devel >= 2.3
15 BuildRequires:  rpm-pythonprov
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is a set of three modules to access the CDDB and FreeDB online
20 databases of audio CD track titles and information. It includes a C
21 extension module to fetch track lengths under Linux, FreeBSD, OpenBSD,
22 Mac OS X, Solaris, and Win32, which is easily ported to other
23 operating systems.
24
25 %description -l pl
26 Jest to zestaw trzech modu³ów umo¿liwiaj±cych po³±czenie z bazami CDDB
27 i FreeDB w celu pobierania tytu³ów i informacji o ¶cie¿kach p³yt CD.
28 Pakiet zawiera te¿ modu³ w C do wyci±gania d³ugo¶ci ¶cie¿ek dzia³aj±cy
29 pod Linuksem, FreeBSD, OpenBSD, MacOS X, Solarisem i Win32.
30
31 %prep
32 %setup -q -n %{module}-%{version}
33
34 %build
35 CFLAGS="%{rpmcflags}"
36 export CLFAGS
37 python setup.py build
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version}}
42
43 python setup.py install \
44         --root=$RPM_BUILD_ROOT \
45         --optimize=2
46
47 install cddb-info.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README CHANGES
57 %{py_sitedir}/*.py[co]
58 %attr(755,root,root) %{py_sitedir}/cdrom.so
59 %{_examplesdir}/%{name}-%{version}
This page took 0.035966 seconds and 3 git commands to generate.