]> git.pld-linux.org Git - SPECS.git/blob - python-BeautifulSoup.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / python-BeautifulSoup.spec
1
2 %define         _module         BeautifulSoup
3
4 Summary:        A BeautifulSoup library for Python
5 Summary(pl.UTF-8):      Biblioteka BeautifulSoup dla Pythona
6 Name:           python-%{_module}
7 Version:        3.2.1
8 Release:        3
9 License:        Python
10 Group:          Development/Languages/Python
11 Source0:        http://www.crummy.com/software/%{_module}/download/3.x/%{_module}-%{version}.tar.gz
12 # Source0-md5:  5ad1a8550a19bfc945baac23eb8293ed
13 URL:            http://www.crummy.com/software/BeautifulSoup/
14 BuildRequires:  python-devel >= 2.2
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 %pyrequires_eq  python-modules
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Beautiful Soup parses arbitrarily invalid SGML and provides a variety
23 of methods and Pythonic idioms for iterating and searching the parse
24 tree.
25
26 %description -l pl.UTF-8
27 Beautiful Soup parsuje, także wadliwy SGML i dostarcza różnorodne
28 metody i idiomy pythonowe do iterowania oraz przeszukiwania drzewa
29 wyniku parsowania.
30
31 %prep
32 %setup -q -n %{_module}-%{version}
33
34 %build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
39 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
40
41 %py_install
42
43 install BeautifulSoupTests.py \
44         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45 %py_postclean
46 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/BeautifulSoupTests.py[co]
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %dir %{_examplesdir}/%{name}-%{version}
54 %{_examplesdir}/%{name}-%{version}/BeautifulSoupTests.py
55 %{py_sitescriptdir}/BeautifulSoup.py[co]
56 %{py_sitescriptdir}/BeautifulSoup-%{version}-*.egg-info
This page took 0.850921 seconds and 3 git commands to generate.