]> git.pld-linux.org Git - SPECS.git/blob - pyslide.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / pyslide.spec
1 Summary:        A tiny program to make presentations
2 Summary(pl.UTF-8):      Malutki program do robienia prezentacji
3 Name:           pyslide
4 Version:        0.4
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 Source0:        http://www.hispalinux.es/~setepo/pyslide/%{name}-%{version}.tar.gz
9 # Source0-md5:  68b158ad104cd24dc2cb7cc1f65f27f1
10 URL:            http://www.hispalinux.es/~setepo/pyslide/
11 Patch0:         %{name}-locale.patch
12 BuildRequires:  python-modules >= 2.3
13 BuildRequires:  python-pygame-devel
14 Requires:       python-pygame
15 Requires:       python-PyXML
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Pyslide is a tiny program to make presentations. It uses SDL (through
20 pygame) to create interesting effects. The presentations are created
21 in an XML file. You can compile it into Python code. At this moment,
22 there is no exhaustive document about the language, but you can read a
23 brief description in the README file. The vocabulary is very easy, and
24 there are examples in the distribution where all of the features are
25 shown.
26
27 %description -l pl.UTF-8
28 Pyslide jest małym programem do robienia prezentacji. Używa SDL
29 (poprzez pygame) w celu uzyskania ciekawych efektów graficznych.
30 Prezentacje są tworzone w plikach XML. Mogą one być kompilowane do
31 kodu Pythona. Na tą chwilę nie ma dokumentu dokładnie opisującego
32 składnię opisu prezentacji. Krótki opis znajduje się w pliku README -
33 składnia jest bardzo prosta. Załączone przykłady pokazują wszystkie
34 możliwości pyslide.
35
36 %prep
37 %setup -q -n %{name}-%{version}.orig
38 %patch0 -p1
39
40 %build
41 CFLAGS="%{rpmcflags}"
42 export CFLAGS
43 BUILD_EXT=1 python setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_examplesdir}/%{name}-%{version},%{_mandir}/man1}
49 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
51
52 BUILD_EXT=1 python setup.py install \
53         --root=$RPM_BUILD_ROOT \
54         --optimize=2 \
55         --install-lib=%{py_sitescriptdir}
56
57 find $RPM_BUILD_ROOT%{py_sitescriptdir} -type f -name "*.py" | xargs rm
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README
65 %attr(755,root,root) %{_bindir}/*
66 %{_mandir}/man1/%{name}.1*
67 %dir %{_examplesdir}/%{name}-%{version}
68 %{_examplesdir}/%{name}-%{version}/*
69 %{py_sitescriptdir}/Pyslide
This page took 0.054086 seconds and 3 git commands to generate.