]> git.pld-linux.org Git - SPECS.git/blob - pyotherside.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / pyotherside.spec
1 # TODO: build also Qt6 module
2 #
3 # Conditional build:
4 %bcond_without  doc     # API documentation
5
6 Summary:        Asynchronous Python 3 Bindings for Qt 5 and Qt 6
7 Summary(pl.UTF-8):      Asynchroniczne wiązania Pythona 3 dla Qt 5 i Qt 6
8 Name:           pyotherside
9 Version:        1.6.0
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/thp/pyotherside/tags
14 Source0:        https://github.com/thp/pyotherside/archive/%{version}/pyotherside-%{version}.tar.gz
15 # Source0-md5:  240fa11fbb774538a3e6f875f1f6d638
16 URL:            https://github.com/thp/pyotherside/
17 BuildRequires:  Qt5Core-devel >= 5.1.0
18 BuildRequires:  Qt5Gui-devel >= 5.1.0
19 BuildRequires:  Qt5Qml-devel >= 5.1.0
20 BuildRequires:  Qt5Quick-devel >= 5.1.0
21 BuildRequires:  python3-devel >= 1:3.3
22 BuildRequires:  qt5-qmake >= 5.1.0
23 BuildRequires:  rpm-build >= 4.6
24 %if %{with doc}
25 BuildRequires:  sphinx-pdg-3
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 A Qt QML Plugin that provides access to a Python 3 interpreter from
31 QML.
32
33 %description -l pl.UTF-8
34 Wtyczka Qt Qml zapewniająca dostęp do interpretera Pythona 3 z
35 poziomu QML.
36
37 %package -n Qt5Qml-module-pyotherside
38 Summary:        Asynchronous Python 3 Bindings for Qt 5
39 Summary(pl.UTF-8):      Asynchroniczne wiązania Pythona 3 dla Qt 5
40 Group:          Libraries
41 Requires:       Qt5Qml >= 5.1.0
42
43 %description -n Qt5Qml-module-pyotherside
44 A Qt 5 QML Plugin that provides access to a Python 3 interpreter from
45 QML.
46
47 %description -n Qt5Qml-module-pyotherside -l pl.UTF-8
48 Wtyczka Qt 5 Qml zapewniająca dostęp do interpretera Pythona 3 z
49 poziomu QML.
50
51 %package apidocs
52 Summary:        API documentation for Python pyotherside module
53 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona pyotherside
54 Group:          Documentation
55 BuildArch:      noarch
56
57 %description apidocs
58 API documentation for Python pyotherside module.
59
60 %description apidocs -l pl.UTF-8
61 Dokumentacja API modułu Pythona pyotherside.
62
63 %prep
64 %setup -q -n pyotherside-%{version}
65
66 %build
67 qmake-qt5
68
69 %{__make}
70
71 %if %{with doc}
72 %{__make} -C docs html \
73         SPHINXBUILD=sphinx-build-3
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         INSTALL_ROOT=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files -n Qt5Qml-module-pyotherside
86 %defattr(644,root,root,755)
87 %doc LICENSE README.md
88 %dir %{_libdir}/qt5/qml/io
89 %dir %{_libdir}/qt5/qml/io/thp
90 %dir %{_libdir}/qt5/qml/io/thp/pyotherside
91 %attr(755,root,root) %{_libdir}/qt5/qml/io/thp/pyotherside/libpyothersideplugin.so
92 %{_libdir}/qt5/qml/io/thp/pyotherside/pyotherside.qmltypes
93 %{_libdir}/qt5/qml/io/thp/pyotherside/qmldir
94
95 %if %{with doc}
96 %files apidocs
97 %defattr(644,root,root,755)
98 %doc docs/_build/html/{_images,_static,*.html,*.js}
99 %endif
This page took 0.611458 seconds and 3 git commands to generate.