]> git.pld-linux.org Git - SPECS.git/blob - pyhoca-cli.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / pyhoca-cli.spec
1 Summary:        Command line X2Go client written in Python
2 Name:           pyhoca-cli
3 Version:        0.5.0.2
4 Release:        1
5 License:        AGPLv3+
6 Group:          Applications/Communications
7 Source0:        http://code.x2go.org/releases/source/pyhoca-cli/%{name}-%{version}.tar.gz
8 # Source0-md5:  fe00e243dddd20f5fdb68a521fd92a54
9 URL:            http://www.x2go.org/
10 BuildRequires:  python-setuptools
11 BuildRequires:  rpm-pythonprov
12 Requires:       python-argparse
13 Requires:       python-setproctitle
14 Requires:       python-x2go
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 X2Go is a server based computing environment with:
20 - session resuming
21 - low bandwidth support
22 - LDAP support
23 - client side mass storage mounting support
24 - client side printing support
25 - audio support
26 - authentication by smartcard and USB stick
27
28 PyHoca-CLI provides a simple and flexible command line client written
29 in Python that allows you to control X2Go client sessions on desktops
30 and thin clients.
31
32 %prep
33 %setup -q
34
35 %build
36 %{__python} setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 %{__python} setup.py install --skip-build \
41         --optimize=2 \
42         --root=$RPM_BUILD_ROOT
43
44 %py_postclean
45
46 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}}
47 cp -p %{name} $RPM_BUILD_ROOT%{_bindir}
48 cp -a man/* $RPM_BUILD_ROOT%{_mandir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc COPYING README TODO
56 %attr(755,root,root) %{_bindir}/%{name}
57 %dir %{py_sitescriptdir}/pyhoca
58 %dir %{py_sitescriptdir}/pyhoca/cli
59 %{py_sitescriptdir}/pyhoca/cli/*.py[co]
60 %{py_sitescriptdir}/PyHoca_CLI-%{version}-py*.egg-info
61 %{py_sitescriptdir}/PyHoca_CLI-%{version}-py*-nspkg.pth
62 %{_mandir}/man1/%{name}.1*
This page took 0.755773 seconds and 3 git commands to generate.