]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- 2.6.92, needs libnscd now
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 %bcond_without  selinux         # build without SELinux support
5 #
6 Summary:        Utilities to manage the passwd and shadow user information
7 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
8 Name:           pwdutils
9 Version:        2.6.92
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/System
13 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
14 # Source0-md5:  59c677ac55d2d8406224eb9b2470a3c0
15 Source1:        %{name}.useradd
16 Source2:        %{name}.rpasswdd.init
17 Source3:        %{name}.login.defs
18 Source4:        chage.pamd
19 Source5:        chfn.pamd
20 Source6:        chsh.pamd
21 Source7:        passwd.pamd
22 Source8:        useradd.pamd
23 Source9:        userdb.pamd
24 Patch0:         %{name}-f-option.patch
25 URL:            http://www.thkukuk.de/pam/pwdutils/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  gcc >= 5:3.2
29 BuildRequires:  gettext-devel
30 BuildRequires:  libnscd-devel
31 %{?with_selinux:BuildRequires:  libselinux-devel}
32 %{?with_ldap:BuildRequires:     openldap-devel}
33 BuildRequires:  openssl-devel >= 0.9.7d
34 BuildRequires:  openslp-devel
35 BuildRequires:  pam-devel
36 BuildRequires:  sed >= 4.0
37 Provides:       shadow = 2:%{version}-%{release}
38 Provides:       shadow-extras = 2:%{version}-%{release}
39 Obsoletes:      shadow
40 Obsoletes:      shadow-extras
41 Obsoletes:      shadow-utils
42 Conflicts:      util-linux < 2.12-10
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 # for pam module in /%{_lib}/security
46 %define         _libdir         /%{_lib}
47
48 %description
49 pwdutils is a collection of utilities to manage the passwd and shadow
50 user information. The difference to the shadow suite is that these
51 utilities can also modify the information stored in NIS, NIS+, or
52 LDAP. PAM is used for user authentication and changing the pasword. It
53 contains passwd, chage, chfn, chsh, and a daemon for changing the
54 password on a remote machine over a secure SSL connection. The daemon
55 also uses PAM so that it can change passwords independent of where
56 they are stored.
57
58 %description -l pl
59 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
60 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
61 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
62 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
63 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
64 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
65 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
66 has³a niezale¿nie od tego, gdzie s± przechowywane.
67
68 %package -n rpasswdd
69 Summary:        Remote password update daemon
70 Summary(pl):    Demon do zdalnego uaktualniania hase³
71 Group:          Applications/System
72 PreReq:         rc-scripts
73 Requires(post,preun):   /sbin/chkconfig
74
75 %description -n rpasswdd
76 rpasswdd is a daemon that lets users change their passwords in the
77 presence of a directory service like NIS, NIS+ or LDAP over a secure
78 SSL connection. rpasswdd behaves like the normal passwd(1) program and
79 uses PAM for authentication and changing the password, so it can be
80 configured very flexibel for the local requirements.
81
82 %description -n rpasswdd -l pl
83 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
84 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
85 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
86 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
87 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
88
89 %package -n pam-pam_rpasswd
90 Summary:        pam_rpasswd - PAM module to change remote password
91 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
92 Group:          Base
93 # rpasswd.conf is in base
94 Requires:       %{name} = %{version}-%{release}
95
96 %description -n pam-pam_rpasswd
97 The pam_rpasswd PAM module is for changing the password of user
98 accounts on a remote server over a secure SSL connection. It only
99 provides functionality for one PAM management group: password
100 changing.
101
102 %description -n pam-pam_rpasswd -l pl
103 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
104 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
105 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
113 %{__gettextize}
114 %{__aclocal}
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --enable-pam_rpasswd \
120         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
121         --enable-slp \
122         --enable-ssl \
123         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
124         --enable-nls \
125         --disable-rpath
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,skel}
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
137 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
138 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
139
140 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
141 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
142 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
143 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
144 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
145 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
146
147 :> $RPM_BUILD_ROOT/etc/shadow
148
149 %find_lang %{name}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 if [ ! -f /etc/shadow ]; then
156         %{_sbindir}/pwconv
157 fi
158
159 %post -n rpasswdd
160 /sbin/chkconfig --add rpasswdd
161 if [ -f /var/lock/subsys/rpasswdd ]; then
162         /etc/rc.d/init.d/rpasswdd restart 1>&2
163 else
164         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
165 fi
166
167 %preun -n rpasswdd
168 if [ "$1" = "0" ]; then
169         if [ -f /var/lock/subsys/rpasswdd ]; then
170                 /etc/rc.d/init.d/rpasswdd stop 1>&2
171         fi
172         /sbin/chkconfig --del rpasswdd
173 fi
174
175 %files -f %{name}.lang
176 %defattr(644,root,root,755)
177 %doc ChangeLog NEWS README THANKS TODO
178 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
179 %attr(750,root,root) %dir %{_sysconfdir}/default
180 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
181 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
182 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
183 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
184 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
185 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
186 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
187 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
188 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
189 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
190 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
191 %dir /etc/skel
192 %attr(755,root,root) %{_bindir}/chage
193 %attr(4755,root,root) %{_bindir}/chfn
194 %attr(4755,root,root) %{_bindir}/chsh
195 %attr(4755,root,root) %{_bindir}/expiry
196 %attr(4755,root,root) %{_bindir}/gpasswd
197 %attr(755,root,root) %{_bindir}/newgrp
198 %attr(4755,root,root) %{_bindir}/passwd
199 %attr(755,root,root) %{_bindir}/rpasswd
200 %attr(755,root,root) %{_bindir}/sg
201 %attr(755,root,root) %{_sbindir}/chpasswd
202 %attr(755,root,root) %{_sbindir}/groupadd
203 %attr(755,root,root) %{_sbindir}/groupdel
204 %attr(755,root,root) %{_sbindir}/groupmod
205 %attr(755,root,root) %{_sbindir}/grpconv
206 %attr(755,root,root) %{_sbindir}/grpck
207 %attr(755,root,root) %{_sbindir}/grpunconv
208 %attr(755,root,root) %{_sbindir}/pwconv
209 %attr(755,root,root) %{_sbindir}/pwck
210 %attr(755,root,root) %{_sbindir}/pwunconv
211 %attr(755,root,root) %{_sbindir}/rpasswdd
212 %attr(755,root,root) %{_sbindir}/useradd
213 %attr(755,root,root) %{_sbindir}/userdel
214 %attr(755,root,root) %{_sbindir}/usermod
215 %attr(755,root,root) %{_sbindir}/vigr
216 %attr(755,root,root) %{_sbindir}/vipw
217 %{_mandir}/man?/*
218 %exclude %{_mandir}/man8/rpasswdd*
219 %exclude %{_mandir}/man8/pam_rpasswd.8*
220
221 %files -n rpasswdd
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_sbindir}/rpasswdd
224 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
225 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
226 %{_mandir}/man8/rpasswdd*
227
228 %files -n pam-pam_rpasswd
229 %defattr(644,root,root,755)
230 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
231 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.069007 seconds and 4 git commands to generate.