]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- rel. 2 to rebuild with new openldap on nest builders
[packages/pwdutils.git] / pwdutils.spec
1 Summary:        Utilities to manage the passwd and shadow user information
2 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
3 Name:           pwdutils
4 Version:        2.5.97
5 Release:        2
6 License:        GPL
7 Group:          Applications/System
8 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
9 # Source0-md5:  e221330372be7931bd80542082bafe4b
10 Source1:        %{name}.useradd
11 Source2:        %{name}.rpasswdd.init
12 Source3:        %{name}.login.defs
13 Source4:        chage.pamd
14 Source5:        chfn.pamd
15 Source6:        chsh.pamd
16 Source7:        passwd.pamd
17 Source8:        useradd.pamd
18 Source9:        userdb.pamd
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gcc >= 5:3.2
22 BuildRequires:  gettext-devel
23 BuildRequires:  libselinux-devel
24 BuildRequires:  openldap-devel
25 BuildRequires:  openssl-devel
26 BuildRequires:  pam-devel
27 BuildRequires:  sed >= 4.0
28 Provides:       shadow = 2:%{version}-%{release}
29 Provides:       shadow-extras = 2:%{version}-%{release}
30 Obsoletes:      shadow
31 Obsoletes:      shadow-extras
32 Conflicts:      util-linux < 2.12-10
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 pwdutils is a collection of utilities to manage the passwd and shadow
37 user information. The difference to the shadow suite is that these
38 utilities can also modify the information stored in NIS, NIS+, or
39 LDAP. PAM is used for user authentication and changing the pasword. It
40 contains passwd, chage, chfn, chsh, and a daemon for changing the
41 password on a remote machine over a secure SSL connection. The daemon
42 also uses PAM so that it can change passwords independent of where
43 they are stored.
44
45 %description -l pl
46 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
47 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
48 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
49 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
50 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
51 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
52 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
53 has³a niezale¿nie od tego, gdzie s± przechowywane.
54
55 %package -n rpasswdd
56 Summary:        Remote password update daemon
57 Summary(pl):    Demon do zdalnego uaktualniania hase³
58 Group:          Applications/System
59
60 %description -n rpasswdd
61 rpasswdd is a daemon that lets users change their passwords in the
62 presence of a directory service like NIS, NIS+ or LDAP over a secure
63 SSL connection. rpasswdd behaves like the normal passwd(1) program and
64 uses PAM for authentication and changing the password, so it can be
65 configured very flexibel for the local requirements.
66
67 %description -n rpasswdd -l pl
68 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
69 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
70 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
71 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
72 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
73
74 %prep
75 %setup -q
76
77 %build
78 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
79 %{__gettextize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --enable-selinux \
86         --disable-rpath
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
97 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
98 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
99 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
100
101 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
102 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
103 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
104 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
105 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
106 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
107
108 :> $RPM_BUILD_ROOT/etc/shadow
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 if [ ! -f /etc/shadow ]; then
117         %{_sbindir}/pwconv
118 fi
119
120 %post -n rpasswdd
121 /sbin/chkconfig --add rpasswdd
122 if [ -f /var/lock/subsys/rpasswdd ]; then
123         /etc/rc.d/init.d/rpasswdd restart 1>&2
124 else
125         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
126 fi
127
128 %preun -n rpasswdd
129 if [ "$1" = "0" ]; then
130         if [ -f /var/lock/subsys/rpasswdd ]; then
131                 /etc/rc.d/init.d/rpasswdd stop 1>&2
132         fi
133         /sbin/chkconfig --del rpasswdd
134 fi
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc ChangeLog NEWS README THANKS TODO
139 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
140 %attr(750,root,root) %dir %{_sysconfdir}/default
141 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
142 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
143 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
144 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
145 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
146 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
147 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
148 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
149 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/shadow
150 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
151 %dir /etc/skel
152 %attr(755,root,root) %{_bindir}/chage
153 %attr(4755,root,root) %{_bindir}/chfn
154 %attr(4755,root,root) %{_bindir}/chsh
155 %attr(4755,root,root) %{_bindir}/expiry
156 %attr(4755,root,root) %{_bindir}/gpasswd
157 %attr(755,root,root) %{_bindir}/newgrp
158 %attr(4755,root,root) %{_bindir}/passwd
159 %attr(755,root,root) %{_bindir}/rpasswd
160 %attr(755,root,root) %{_sbindir}/chpasswd
161 %attr(755,root,root) %{_sbindir}/groupadd
162 %attr(755,root,root) %{_sbindir}/groupdel
163 %attr(755,root,root) %{_sbindir}/groupmod
164 %attr(755,root,root) %{_sbindir}/grpconv
165 %attr(755,root,root) %{_sbindir}/grpck
166 %attr(755,root,root) %{_sbindir}/grpunconv
167 %attr(755,root,root) %{_sbindir}/pwconv
168 %attr(755,root,root) %{_sbindir}/pwck
169 %attr(755,root,root) %{_sbindir}/pwunconv
170 %attr(755,root,root) %{_sbindir}/rpasswdd
171 %attr(755,root,root) %{_sbindir}/useradd
172 %attr(755,root,root) %{_sbindir}/userdel
173 %attr(755,root,root) %{_sbindir}/usermod
174 %attr(755,root,root) %{_sbindir}/vigr
175 %attr(755,root,root) %{_sbindir}/vipw
176 %{_mandir}/man?/*
177 %exclude %{_mandir}/man8/rpasswdd*
178
179 %files -n rpasswdd
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_sbindir}/rpasswdd
182 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
183 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
184 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/rpasswd.conf
185 %{_mandir}/man8/rpasswdd*
This page took 0.053305 seconds and 4 git commands to generate.