]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- automake epoch
[packages/pwdutils.git] / pwdutils.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # build without LDAP support
4 %bcond_without  selinux         # build without SELinux support
5 #
6 Summary:        Utilities to manage the passwd and shadow user information
7 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
8 Name:           pwdutils
9 Version:        2.6.94
10 Release:        0.1
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
14 # Source0-md5:  e28822a9c81c381aceb47879694a6a99
15 Source1:        %{name}.useradd
16 Source2:        %{name}.rpasswdd.init
17 Source3:        %{name}.login.defs
18 Source4:        chage.pamd
19 Source5:        chfn.pamd
20 Source6:        chsh.pamd
21 Source7:        passwd.pamd
22 Source8:        useradd.pamd
23 Source9:        userdb.pamd
24 Source10:       %{name}-pl.po
25 Patch0:         %{name}-f-option.patch
26 URL:            http://www.thkukuk.de/pam/pwdutils/
27 BuildRequires:  autoconf
28 BuildRequires:  automake >= 1:1.7
29 BuildRequires:  gcc >= 5:3.2
30 BuildRequires:  gettext-devel
31 BuildRequires:  libnscd-devel
32 %{?with_selinux:BuildRequires:  libselinux-devel}
33 %{?with_ldap:BuildRequires:     openldap-devel}
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  openslp-devel
36 BuildRequires:  pam-devel
37 BuildRequires:  sed >= 4.0
38 Provides:       shadow = 2:%{version}-%{release}
39 Provides:       shadow-extras = 2:%{version}-%{release}
40 Obsoletes:      shadow
41 Obsoletes:      shadow-extras
42 Obsoletes:      shadow-utils
43 Conflicts:      util-linux < 2.12-10
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # for pam module in /%{_lib}/security
47 %define         _libdir         /%{_lib}
48
49 %description
50 pwdutils is a collection of utilities to manage the passwd and shadow
51 user information. The difference to the shadow suite is that these
52 utilities can also modify the information stored in NIS, NIS+, or
53 LDAP. PAM is used for user authentication and changing the pasword. It
54 contains passwd, chage, chfn, chsh, and a daemon for changing the
55 password on a remote machine over a secure SSL connection. The daemon
56 also uses PAM so that it can change passwords independent of where
57 they are stored.
58
59 %description -l pl
60 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
61 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
62 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
63 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
64 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
65 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
66 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
67 has³a niezale¿nie od tego, gdzie s± przechowywane.
68
69 %package -n rpasswdd
70 Summary:        Remote password update daemon
71 Summary(pl):    Demon do zdalnego uaktualniania hase³
72 Group:          Applications/System
73 PreReq:         rc-scripts
74 Requires(post,preun):   /sbin/chkconfig
75
76 %description -n rpasswdd
77 rpasswdd is a daemon that lets users change their passwords in the
78 presence of a directory service like NIS, NIS+ or LDAP over a secure
79 SSL connection. rpasswdd behaves like the normal passwd(1) program and
80 uses PAM for authentication and changing the password, so it can be
81 configured very flexibel for the local requirements.
82
83 %description -n rpasswdd -l pl
84 rpasswdd to demon pozwalaj±cy u¿ytkownikom zmieniaæ has³a w obecno¶ci
85 us³ug katalogowych takich jak NIS, NIS+ czy LDAP po bezpiecznym
86 po³±czeniu SSL. rpasswdd zachowuje siê tak, jak normalny program
87 passwd(1) i u¿ywam PAM do uwierzytelniania i zmiany hase³, wiêc mo¿e
88 byæ bardzo elastycznie konfigurowany dla lokalnych wymagañ.
89
90 %package -n pam-pam_rpasswd
91 Summary:        pam_rpasswd - PAM module to change remote password
92 Summary(pl):    pam_rpasswd - modu³ PAM do zdalnej zmiany has³a
93 Group:          Base
94 # rpasswd.conf is in base
95 Requires:       %{name} = %{version}-%{release}
96
97 %description -n pam-pam_rpasswd
98 The pam_rpasswd PAM module is for changing the password of user
99 accounts on a remote server over a secure SSL connection. It only
100 provides functionality for one PAM management group: password
101 changing.
102
103 %description -n pam-pam_rpasswd -l pl
104 Modu³ PAM pam_rpasswd s³u¿y do zmiany hase³ dla kont u¿ytkowników na
105 zdalnym serwerze po bezpiecznym po³±czeniu SSL. Udostêpnia
106 funkcjonalno¶æ tylko dla jednej grupy zarz±dzania PAM: zmiany hase³.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 cp %{SOURCE10} po/pl.po
113 sed -i -e 's/\(ALL_LINGUAS\)="de"/\1="de pl"/' configure.in
114 rm -f po/stamp-po
115
116 sed -i -e 's#EXTRA_CFLAGS=.*#EXTRA_CFLAGS="-W -Wall"#g' configure.in
117
118 %build
119 %{__gettextize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --enable-pam_rpasswd \
126         --%{?with_selinux:en}%{!?with_selinux:dis}able-selinux \
127         --enable-slp \
128         --enable-ssl \
129         --%{?with_ldap:en}%{!?with_ldap:dis}able-ldap \
130         --enable-nls \
131         --disable-rpath
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pwdutils,security,skel}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 mv -f $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
143 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
144 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
145
146 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
147 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
148 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
149 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
150 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
151 install %{SOURCE9} $RPM_BUILD_ROOT/etc/pam.d/shadow
152
153 rm -f $RPM_BUILD_ROOT%{_libdir}/pwdutils/*.{la,a}
154
155 :> $RPM_BUILD_ROOT%{_sysconfdir}/shadow
156 :> $RPM_BUILD_ROOT/etc/security/chfn.allow
157 :> $RPM_BUILD_ROOT/etc/security/chsh.allow
158
159 %find_lang %{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 if [ ! -f /etc/shadow ]; then
166         %{_sbindir}/pwconv
167 fi
168
169 %post -n rpasswdd
170 /sbin/chkconfig --add rpasswdd
171 if [ -f /var/lock/subsys/rpasswdd ]; then
172         /etc/rc.d/init.d/rpasswdd restart 1>&2
173 else
174         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
175 fi
176
177 %preun -n rpasswdd
178 if [ "$1" = "0" ]; then
179         if [ -f /var/lock/subsys/rpasswdd ]; then
180                 /etc/rc.d/init.d/rpasswdd stop 1>&2
181         fi
182         /sbin/chkconfig --del rpasswdd
183 fi
184
185 %files -f %{name}.lang
186 %defattr(644,root,root,755)
187 %doc ChangeLog NEWS README THANKS TODO
188 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %ghost %{_sysconfdir}/shadow
189 %attr(750,root,root) %dir %{_sysconfdir}/default
190 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/default/*
191 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
192 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.local
193 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chage
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chfn
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/chsh
196 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/passwd
197 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/useradd
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/shadow
199 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/rpasswd.conf
201 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chfn.allow
202 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/chsh.allow
203 %dir /etc/skel
204 %attr(755,root,root) %{_bindir}/chage
205 %attr(4755,root,root) %{_bindir}/chfn
206 %attr(4755,root,root) %{_bindir}/chsh
207 %attr(4755,root,root) %{_bindir}/expiry
208 %attr(4755,root,root) %{_bindir}/gpasswd
209 %attr(755,root,root) %{_bindir}/newgrp
210 %attr(4755,root,root) %{_bindir}/passwd
211 %attr(755,root,root) %{_bindir}/rpasswd
212 %attr(755,root,root) %{_bindir}/sg
213 %attr(755,root,root) %{_sbindir}/chpasswd
214 %attr(755,root,root) %{_sbindir}/groupadd
215 %attr(755,root,root) %{_sbindir}/groupdel
216 %attr(755,root,root) %{_sbindir}/groupmod
217 %attr(755,root,root) %{_sbindir}/grpconv
218 %attr(755,root,root) %{_sbindir}/grpck
219 %attr(755,root,root) %{_sbindir}/grpunconv
220 %attr(755,root,root) %{_sbindir}/pwconv
221 %attr(755,root,root) %{_sbindir}/pwck
222 %attr(755,root,root) %{_sbindir}/pwunconv
223 %attr(755,root,root) %{_sbindir}/rpasswdd
224 %attr(755,root,root) %{_sbindir}/useradd
225 %attr(755,root,root) %{_sbindir}/userdel
226 %attr(755,root,root) %{_sbindir}/usermod
227 %attr(755,root,root) %{_sbindir}/vigr
228 %attr(755,root,root) %{_sbindir}/vipw
229 %dir %{_libdir}/pwdutils
230 %attr(755,root,root) %{_libdir}/pwdutils/liblog_syslog.so*
231 %{_mandir}/man?/*
232 %exclude %{_mandir}/man8/rpasswdd.8*
233 %exclude %{_mandir}/man8/pam_rpasswd.8*
234
235 %files -n rpasswdd
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_sbindir}/rpasswdd
238 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/rpasswd
240 %{_mandir}/man8/rpasswdd.8*
241
242 %files -n pam-pam_rpasswd
243 %defattr(644,root,root,755)
244 %attr(755,root,root) /%{_lib}/security/pam_rpasswd.so
245 %{_mandir}/man8/pam_rpasswd.8*
This page took 0.043312 seconds and 4 git commands to generate.