]> git.pld-linux.org Git - SPECS.git/blob - pth.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / pth.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform "make test"
4 %bcond_with     pthread # build pthread library (POSIX.1c threading API of GNU Pth)
5 #
6 Summary:        The GNU portable threads
7 Summary(pl.UTF-8):      Przenośne wątki GNU
8 Name:           pth
9 Version:        2.0.7
10 Release:        6
11 Epoch:          1
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://ftp.gnu.org/gnu/pth/%{name}-%{version}.tar.gz
15 # Source0-md5:  9cb4a25331a4c4db866a31cbe507c793
16 Patch0:         %{name}-nolibs.patch
17 URL:            http://www.gnu.org/software/pth/
18 BuildRequires:  autoconf >= 2.52
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # -fno-strict-aliasing" because mainly pth_mctx.c contains important
24 # and correct pointer casting constructs which are not acceptable
25 # in "strict aliasing" for GCC.
26 %define         specflags       -fno-strict-aliasing
27
28 %description
29 Pth is a very portable POSIX/ANSI-C based library for Unix platforms
30 which provides non-preemptive priority-based scheduling for multiple
31 threads of execution (aka `multithreading') inside event-driven
32 applications. All threads run in the same address space of the server
33 application, but each thread has its own individual program-counter,
34 run-time stack, signal mask and errno variable.
35
36 %description -l pl.UTF-8
37 pth jest bardzo przenośną biblioteką bazującą na POSIX/ANSI-C dla
38 platform uniksowych, bazujące na priorytetach dzielenie czasu bez
39 wywłaszczenia dla wielu wątków (czyli wielowątkowość) wewnątrz
40 aplikacji sterowanych zdarzeniami. Wszystkie wątki działają w tej
41 samej przestrzeni adresowej aplikacji serwera, ale każdy ma swój
42 własny licznik instrukcji, stos, maski sygnałów i zmienną errno.
43
44 %package devel
45 Summary:        Header files and development documentation for pth
46 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do pth
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description devel
51 Header files and development documentation for pth.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe i dokumentacja programisty do pth.
55
56 %package static
57 Summary:        Static version of the GNU portable threads library
58 Summary(pl.UTF-8):      Statyczna wersja biblioteki pth
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
61
62 %description static
63 Static version of the GNU portable threads library.
64
65 %description static -l pl.UTF-8
66 Statyczna wersja biblioteki przenośnych wątków GNU.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 # no aclocal call: aclocal.m4 contains only local macros, libtool.m4 is included from configure.in
72 cp -f /usr/share/automake/config.* /usr/share/aclocal/libtool.m4 .
73 mv aclocal.m4 local.m4
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I.
78 %{__autoheader}
79 %{__autoconf}
80 %configure \
81         %{?with_pthread:--enable-pthread} \
82         --enable-optimize
83
84 %{__make} pth_p.h
85 %{__make}
86 %{?with_tests:%{__make} test}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} -j1 install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 # COPYING contains not only LGPL text
103 %doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS README SUPPORT TESTS THANKS USERS
104 %attr(755,root,root) %{_libdir}/libpth.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libpth.so.20
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc HACKING
110 %attr(755,root,root) %{_bindir}/*
111 %attr(755,root,root) %{_libdir}/libpth.so
112 %{_libdir}/lib*.la
113 %{_aclocaldir}/pth.m4
114 %{_includedir}/*.h
115 %{_mandir}/man3/*
116 %{_mandir}/man1/*
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib*.a
This page took 0.580294 seconds and 3 git commands to generate.