]> git.pld-linux.org Git - packages/protobuf.git/blob - protobuf.spec
- initial revision
[packages/protobuf.git] / protobuf.spec
1 #
2 # TODO:
3 #       - add bindings for java and python
4 #       - add vim syntax package
5 #
6 Summary:        Protocol Buffers - Google's data interchange format
7 Summary(pl.UTF-8):      Protocol Buffers - format wymiany danych Google
8 Name:           protobuf
9 Version:        2.0.2
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
14 # Source0-md5:  6674270b1d63c2c4b292644f48fede4e
15 URL:            http://code.google.com/p/protobuf/
16 Requires:       %{name}-libs = %{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Protocol buffers are a flexible, efficient, automated mechanism
21 for serializing structured data - similar to XML, but smaller,
22 faster, and simpler. You define how you want your data to be
23 structured once, then you can use special generated source code
24 to easily write and read your structured data to and from
25 a variety of data streams and using a variety of languages.
26 You can even update your data structure without breaking deployed
27 programs that are compiled against the "old" format.
28
29 Google uses Protocol Buffers for almost all of its internal RPC
30 protocols and file formats. 
31
32 #%description -l pl.UTF-8
33
34 %package libs
35 Summary:        protobuf libraries
36 Summary(pl.UTF-8):      Biblioteki protobuf
37 Group:          Libraries
38
39 %description libs
40 protobuf libraries.
41
42 %description libs -l pl.UTF-8
43 Biblioteki protobuf.
44
45 %package devel
46 Summary:        Header files for protobuf libraries
47 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek protobuf
48 Group:          Development/Libraries
49 Requires:       %{name}-libs = %{version}-%{release}
50
51 %description devel
52 Header files for protobuf libraries.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe bibliotek protobuf.
56
57 %package static
58 Summary:        Static protobuf libraries
59 Summary(pl.UTF-8):      Statyczne biblioteki protobuf
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static protobuf libraries.
65
66 %description static -l pl.UTF-8
67 Statyczne biblioteki protobuf.
68
69 %prep
70 %setup -q
71
72 %build
73 %configure
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   libs -p /sbin/ldconfig
89 %postun libs -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc CHANGES.txt CONTRIBUTORS.txt README.txt
94 %attr(755,root,root) %{_bindir}/protoc
95
96 %files libs
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libproto*.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.2
100 %attr(755,root,root) %ghost %{_libdir}/libprotoc.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/google
105 %attr(755,root,root) %{_libdir}/libproto*.la
106 %attr(755,root,root) %{_libdir}/libproto*.so
107 %{_examplesdir}/%{name}-%{version}
108
109 %files static
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libproto*.a
This page took 0.090874 seconds and 4 git commands to generate.