]> git.pld-linux.org Git - packages/protobuf.git/blob - protobuf.spec
- up to 2.4.1
[packages/protobuf.git] / protobuf.spec
1 #
2 # TODO:
3 #       - add bindings for java and python
4 #       - add vim syntax package
5 #
6 Summary:        Protocol Buffers - Google's data interchange format
7 Summary(pl.UTF-8):      Protocol Buffers - format wymiany danych Google
8 Name:           protobuf
9 Version:        2.4.1
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ed436802019c9e1f40cc750eaf78f318
15 URL:            http://code.google.com/p/protobuf/
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  rpm-pythonprov
18 Requires:       %{name}-libs = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Protocol buffers are a flexible, efficient, automated mechanism
23 for serializing structured data - similar to XML, but smaller,
24 faster, and simpler. You define how you want your data to be
25 structured once, then you can use special generated source code
26 to easily write and read your structured data to and from
27 a variety of data streams and using a variety of languages.
28 You can even update your data structure without breaking deployed
29 programs that are compiled against the "old" format.
30
31 Google uses Protocol Buffers for almost all of its internal RPC
32 protocols and file formats.
33
34 %description -l pl.UTF-8
35 Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
36 serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
37 szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
38 a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
39 zapisu i odczytu danych strukturalnych do i z różnych strumieni
40 danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
41 danych bez psucia programów skompilowanych w oparciu o "stary" format.
42
43 Google używa buforów protokołowych (Protocol Buffers) do prawie
44 wszystkich wewnętrznych protokołów RPC i formatów plików.
45
46 %package libs
47 Summary:        protobuf libraries
48 Summary(pl.UTF-8):      Biblioteki protobuf
49 Group:          Libraries
50
51 %description libs
52 protobuf libraries.
53
54 %description libs -l pl.UTF-8
55 Biblioteki protobuf.
56
57 %package devel
58 Summary:        Header files for protobuf libraries
59 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek protobuf
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       libstdc++-devel
63
64 %description devel
65 Header files for protobuf libraries.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe bibliotek protobuf.
69
70 %package static
71 Summary:        Static protobuf libraries
72 Summary(pl.UTF-8):      Statyczne biblioteki protobuf
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static protobuf libraries.
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki protobuf.
81
82 %prep
83 %setup -q
84
85 %build
86 %configure
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   libs -p /sbin/ldconfig
102 %postun libs -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc CHANGES.txt CONTRIBUTORS.txt README.txt
107 %attr(755,root,root) %{_bindir}/protoc
108
109 %files libs
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libprotobuf-lite.so.7
113 %attr(755,root,root) %{_libdir}/libprotobuf.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.7
115 %attr(755,root,root) %{_libdir}/libprotoc.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libprotoc.so.7
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libprotobuf-lite.so
121 %attr(755,root,root) %{_libdir}/libprotobuf.so
122 %attr(755,root,root) %{_libdir}/libprotoc.so
123 %{_libdir}/libprotobuf-lite.la
124 %{_libdir}/libprotobuf.la
125 %{_libdir}/libprotoc.la
126 %{_includedir}/google
127 %{_examplesdir}/%{name}-%{version}
128 %{_pkgconfigdir}/protobuf-lite.pc
129 %{_pkgconfigdir}/protobuf.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libprotobuf-lite.a
134 %{_libdir}/libprotobuf.a
135 %{_libdir}/libprotoc.a
This page took 0.129862 seconds and 3 git commands to generate.