]> git.pld-linux.org Git - packages/protobuf.git/blob - protobuf.spec
- pl desc
[packages/protobuf.git] / protobuf.spec
1 #
2 # TODO:
3 #       - add bindings for java and python
4 #       - add vim syntax package
5 #
6 Summary:        Protocol Buffers - Google's data interchange format
7 Summary(pl.UTF-8):      Protocol Buffers - format wymiany danych Google
8 Name:           protobuf
9 Version:        2.0.3
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
14 # Source0-md5:  37e6e4d63434672c70bd977be9c372cb
15 URL:            http://code.google.com/p/protobuf/
16 Requires:       %{name}-libs = %{version}-%{release}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Protocol buffers are a flexible, efficient, automated mechanism
21 for serializing structured data - similar to XML, but smaller,
22 faster, and simpler. You define how you want your data to be
23 structured once, then you can use special generated source code
24 to easily write and read your structured data to and from
25 a variety of data streams and using a variety of languages.
26 You can even update your data structure without breaking deployed
27 programs that are compiled against the "old" format.
28
29 Google uses Protocol Buffers for almost all of its internal RPC
30 protocols and file formats. 
31
32 %description -l pl.UTF-8
33 Bufory protokołowe to elastyczny, wydajny i zautomatyzowany sposób
34 serializacji danych strukturalnych - podobny do XML-a, ale mniejszy,
35 szybszy i prostszy. Definiuje się raz, jaką strukturę mają mieć dane,
36 a następnie używa specjalnie wygenerowanego kodu źródłowego do łatwego
37 zapisu i odczytu danych strukturalnych do i z różnych strumieni
38 danych, z poziomu różnych języków. Można nawet uaktualniać strukturę
39 danych bez psucia programów skompilowanych w oparciu o "stary" format.
40
41 Google używa buforów protokołowych (Protocol Buffers) do prawie
42 wszystkich wewnętrznych protokołów RPC i formatów plików.
43
44 %package libs
45 Summary:        protobuf libraries
46 Summary(pl.UTF-8):      Biblioteki protobuf
47 Group:          Libraries
48
49 %description libs
50 protobuf libraries.
51
52 %description libs -l pl.UTF-8
53 Biblioteki protobuf.
54
55 %package devel
56 Summary:        Header files for protobuf libraries
57 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek protobuf
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{version}-%{release}
60
61 %description devel
62 Header files for protobuf libraries.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe bibliotek protobuf.
66
67 %package static
68 Summary:        Static protobuf libraries
69 Summary(pl.UTF-8):      Statyczne biblioteki protobuf
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static protobuf libraries.
75
76 %description static -l pl.UTF-8
77 Statyczne biblioteki protobuf.
78
79 %prep
80 %setup -q
81
82 %build
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   libs -p /sbin/ldconfig
99 %postun libs -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc CHANGES.txt CONTRIBUTORS.txt README.txt
104 %attr(755,root,root) %{_bindir}/protoc
105
106 %files libs
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libproto*.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libprotobuf.so.3
110 %attr(755,root,root) %ghost %{_libdir}/libprotoc.so.3
111
112 %files devel
113 %defattr(644,root,root,755)
114 %{_includedir}/google
115 %attr(755,root,root) %{_libdir}/libproto*.la
116 %attr(755,root,root) %{_libdir}/libproto*.so
117 %{_examplesdir}/%{name}-%{version}
118
119 %files static
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libproto*.a
This page took 0.037842 seconds and 3 git commands to generate.