]> git.pld-linux.org Git - packages/privoxy.git/blob - privoxy.spec
--specfile taken from sf.net
[packages/privoxy.git] / privoxy.spec
1
2 %define veryoldname junkbust
3 %define oldname junkbuster
4 %define privoxyconf %{_sysconfdir}/%{name}
5 %define privoxy_uid 73
6 %define privoxy_gid 73
7
8 Name:           privoxy
9 Version:        3.0.0
10 Release:        1
11 Summary:        Privoxy - privacy enhancing proxy
12 License:        GPL
13 Source0:        http://www.waldherr.org/%{name}/%{name}-%{version}.tar.gz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 Group:          Networking/Daemons
16 URL:            http://www.privoxy.org/
17 Obsoletes:      junkbuster-raw junkbuster-blank junkbuster
18 # Prereq: /usr/sbin/useradd , /sbin/chkconfig , /sbin/service
19 Prereq:         shadow-utils, chkconfig, initscripts, sh-utils
20 BuildRequires:  perl gzip sed libtool autoconf lynx
21 Conflicts:      junkbuster-raw junkbuster-blank junkbuster
22
23 %description
24 Privoxy is a web proxy with advanced filtering capabilities for
25 protecting privacy, filtering web page content, managing cookies,
26 controlling access, and removing ads, banners, pop-ups and other
27 obnoxious Internet junk. Privoxy has a very flexible configuration and
28 can be customized to suit individual needs and tastes. Privoxy has
29 application for both stand-alone systems and multi-user networks.
30
31 Privoxy is based on the Internet Junkbuster.
32
33 %prep
34 %setup -q -c
35
36 %build
37
38 autoheader
39 autoconf
40 %configure --disable-dynamic-pcre
41 %{__make}
42
43 #strip %{name}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
49 install -d %{buildroot}%{_sbindir} \
50          %{buildroot}%{_mandir}/man1 \
51          %{buildroot}%{_localstatedir}/log/%{name} \
52          %{buildroot}%{privoxyconf}/templates \
53          %{buildroot}%{_sysconfdir}/logrotate.d \
54          %{buildroot}%{_sysconfdir}/rc.d/init.d
55
56 install -s -m 744 %{name} %{buildroot}%{_sbindir}/%{name}
57
58 # Using sed to "convert" from DOS format to UNIX
59 # This is important behaviour, and should not be removed without some
60 # other assurance that these files don't get packed in the the
61 # wrong format
62 for i in `ls *.action`
63 do
64        cat $i | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/$i
65 done
66 cat default.filter | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/default.filter
67 cat trust | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/trust
68 (
69 cd templates
70 for i in `ls`
71 do
72         cat $i | sed -e 's/[[:cntrl:]]*$//' > %{buildroot}%{privoxyconf}/templates/$i
73 done
74 )
75
76 cp -f %{name}.1 %{buildroot}%{_mandir}/man1/%{name}.1
77 cp -f %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
78 install -m 755 %{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
79 install -m 711 -d %{buildroot}%{_localstatedir}/log/%{name}
80
81 # verify all file locations, etc. in the config file
82 # don't start with ^ or commented lines are not replaced
83 ## Changing the sed paramter delimiter to @, so we don't have to
84 ## escape the slashes
85 cat config | \
86     sed 's@^confdir.*@confdir %{privoxyconf}@g' | \
87 #    sed 's/^permissionsfile.*/permissionsfile \/etc\/%{name}\/permissionsfile/g' | \
88 #    sed 's/^filterfile.*/default.filter \/etc\/%{name}\/default.filter/g' | \
89 #    sed 's/^logfile.*/logfile \%{_localstatedir}\/log\/%{name}\/logfile/g' | \
90 #    sed 's/^jarfile.*/jarfile \%{_localstatedir}\/log\/%{name}\/jarfile/g' | \
91 #    sed 's/^forward.*/forward \/etc\/%{name}\/forward/g' | \
92 #    sed 's/^aclfile.*/aclfile \/etc\/%{name}\/aclfile/g' > \
93     sed 's@^logdir.*@logdir %{_localstatedir}/log/%{name}@g' | \
94     sed -e 's/[[:cntrl:]]*$//' > \
95     %{buildroot}%{privoxyconf}/config
96 perl -pe 's/{-no-cookies}/{-no-cookies}\n\.redhat.com/' default.action >\
97     %{buildroot}%{privoxyconf}/default.action
98
99
100 ## Macros are expanded even on commentaries. So, we have to use %%
101 ## -- morcego
102 #%%makeinstall
103
104 %pre
105 # This is where we handle old usernames (junkbust and junkbuster)
106 # I'm not sure we should do that, but this is the way we have been
107 # doing it for some time now -- morcego
108 # We should do it for the group as well -- morcego
109 # Doing it by brute force. Much cleaner (no more Mr. Nice Guy) -- morcego
110
111 # Same for username
112 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{oldname} > /dev/null 2>&1 || :
113 usermod -u %{privoxy_uid} -g %{privoxy_gid} -l %{name} -d %{_sysconfdir}/%{name} -s "" %{veryoldname} > /dev/null 2>&1 || :
114 userdel %{oldname} > /dev/null 2>&1 ||:
115 userdel %{veryoldname} > /dev/null 2>&1 ||:
116
117 # Change the group name. Remove anything left behind.
118 groupmod -g %{privoxy_gid} -n %{name} %{oldname} > /dev/null 2>&1 ||:
119 groupmod -g %{privoxy_gid} -n %{name} %{veryoldname} > /dev/null 2>&1 ||:
120 groupdel %{oldname} > /dev/null 2>&1 ||:
121 groupdel %{veryoldname} > /dev/null 2>&1 ||:
122
123 # Doublecheck to see if the group exist, and that it has the correct gid
124 /bin/grep -E '^%{name}:' %{_sysconfdir}/group > /dev/null 2>&1
125 if [ $? -eq 1 ]; then
126         # Looks like it does not exist. Create it
127         groupadd -g %{privoxy_gid} %{name} > /dev/null 2>&1
128 else
129         /bin/grep -E '^%{name}:[^:]*:%{privoxy_gid}:' %{_sysconfdir}/group > /dev/null 2>&1
130         if [ $? -eq 1 ]; then
131                 # The group exists, but does not have the correct gid
132                 groupmod -g %{privoxy_gid} %{name} > /dev/null 2>&1
133         fi
134 fi
135
136 # Check to see if everything is okey. Create user if it still does not
137 # exist
138 id %{name} > /dev/null 2>&1
139 if [ $? -eq 1 ]; then
140         %{_sbindir}/useradd -u %{privoxy_uid} -g %{privoxy_gid} -d %{_sysconfdir}/%{name} -r -s "" %{name} > /dev/null 2>&1
141 fi
142
143 # Double check that the group has the correct uid
144 P_UID=`id -u %{name} 2>/dev/null`
145 if [ $P_UID -ne %{privoxy_uid} ]; then
146         %{_sbindir}/usermod -u %{privoxy_uid} %{name}
147 fi
148
149 # The same for the gid
150 P_GID=`id -g %{name} 2>/dev/null`
151 if [ $P_GID -ne %{privoxy_gid} ]; then
152         %{_sbindir}/usermod -g %{privoxy_gid} %{name}
153 fi
154
155 %post
156 # for upgrade from 2.0.x
157 [ -f %{_localstatedir}/log/%{oldname}/logfile ] && {
158   mv -f %{_localstatedir}/log/%{oldname}/logfile %{_localstatedir}/log/%{name}/logfile ||: ;
159   chown -R %{name}:%{name} %{_localstatedir}/log/%{name} 2>/dev/null ||: ;
160 }
161 [ -f %{_localstatedir}/log/%{name}/%{name} ] && {
162   mv -f %{_localstatedir}/log/%{name}/%{name} %{_localstatedir}/log/%{name}/logfile ||: ;
163   chown -R %{name}:%{name} %{_sysconfdir}/%{name} 2>/dev/null ||: ;
164 }
165 /sbin/chkconfig --add privoxy
166 if [ "$1" = "1" ]; then
167         /sbin/service %{name} condrestart > /dev/null 2>&1 ||:
168 fi
169
170 %preun
171 /sbin/service %{veryoldname} stop > /dev/null 2>&1 ||:
172 /sbin/service %{oldname} stop > /dev/null 2>&1 ||:
173
174 if [ "$1" = "0" ]; then
175         /sbin/service %{name} stop > /dev/null 2>&1 ||:
176         /sbin/chkconfig --del privoxy
177 fi
178
179 %postun
180 #if [ "$1" -ge "1" ]; then
181 #       /sbin/service %{name} condrestart > /dev/null 2>&1
182 #fi
183 # We only remove it we this is not an upgrade
184 if [ "$1" = "0" ]; then
185         id privoxy > /dev/null 2>&1 && %{_sbindir}/userdel privoxy || /bin/true
186         /bin/grep -E '^%{name}:' %{_sysconfdir}/group > /dev/null && %{_sbindir}/groupdel %{name} || /bin/true
187 fi
188
189 %clean
190 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
191
192 %files
193 %defattr(644,root,root,755)
194 %doc README AUTHORS ChangeLog LICENSE
195 %doc doc/text/developer-manual.txt doc/text/user-manual.txt doc/text/faq.txt
196 %doc doc/webserver/developer-manual
197 %doc doc/webserver/user-manual
198 %doc doc/webserver/faq
199 %doc doc/webserver/p_doc.css doc/webserver/p_web.css doc/webserver/privoxy-index.html
200 %doc doc/webserver/images
201 %doc doc/webserver/man-page
202
203 # ATTENTION FOR defattr change here !
204 %defattr(0644,%{name},%{name},0755)
205
206 %dir %{privoxyconf}
207 %dir %{privoxyconf}/templates
208 %dir %{_localstatedir}/log/%{name}
209
210 %attr(0744,%{name},%{name})%{_sbindir}/%{name}
211
212 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
213 # We should not use wildchars here. This could mask missing files problems
214 # -- morcego
215 # WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING ! WARNING !
216 %config(noreplace) %{privoxyconf}/config
217 %config %{privoxyconf}/standard.action
218 %config(noreplace) %{privoxyconf}/user.action
219 %config %{privoxyconf}/default.action
220 %config %{privoxyconf}/default.filter
221 %config %{privoxyconf}/trust
222
223 # Please keep these alphabetized so its easier to find one that
224 # is not included.
225 %config %{privoxyconf}/templates/blocked
226 %config %{privoxyconf}/templates/cgi-error-404
227 %config %{privoxyconf}/templates/cgi-error-bad-param
228 %config %{privoxyconf}/templates/cgi-error-disabled
229 %config %{privoxyconf}/templates/cgi-error-file
230 %config %{privoxyconf}/templates/cgi-error-file-read-only
231 %config %{privoxyconf}/templates/cgi-error-modified
232 %config %{privoxyconf}/templates/cgi-error-parse
233 %config %{privoxyconf}/templates/cgi-style.css
234 %config %{privoxyconf}/templates/connect-failed
235 %config %{privoxyconf}/templates/default
236 %config %{privoxyconf}/templates/edit-actions-add-url-form
237 %config %{privoxyconf}/templates/edit-actions-for-url
238 %config %{privoxyconf}/templates/edit-actions-for-url-filter
239 %config %{privoxyconf}/templates/edit-actions-list
240 %config %{privoxyconf}/templates/edit-actions-list-button
241 %config %{privoxyconf}/templates/edit-actions-list-section
242 %config %{privoxyconf}/templates/edit-actions-list-url
243 %config %{privoxyconf}/templates/edit-actions-remove-url-form
244 %config %{privoxyconf}/templates/edit-actions-url-form
245 %config %{privoxyconf}/templates/mod-local-help
246 %config %{privoxyconf}/templates/mod-support-and-service
247 %config %{privoxyconf}/templates/mod-title
248 %config %{privoxyconf}/templates/mod-unstable-warning
249 %config %{privoxyconf}/templates/no-such-domain
250 %config %{privoxyconf}/templates/show-request
251 %config %{privoxyconf}/templates/show-status
252 %config %{privoxyconf}/templates/show-status-file
253 %config %{privoxyconf}/templates/show-url-info
254 %config %{privoxyconf}/templates/show-version
255 %config %{privoxyconf}/templates/toggle
256 %config %{privoxyconf}/templates/toggle-mini
257 %config %{privoxyconf}/templates/untrusted
258
259 # Attention, new defattr change here !
260 %defattr(0644,root,root,0755)
261
262 %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
263 %config(noreplace) %attr(0755,root,root) %{_sysconfdir}/rc.d/init.d/%{name}
264
265 %{_mandir}/man1/%{name}.*
266
267 # $Log: privoxy.spec,v $
268 # Revision 1.1  2002-11-11 20:17:55  hunter
269 # --specfile taken from sf.net
270 #
271 # Revision 1.33.2.19  2002/08/25 23:36:03  hal9
272 # Bump version for 3.0.0.
273 #
274 # Revision 1.33.2.18  2002/08/10 11:28:50  oes
275 # Bumped version
276 #
277 # Revision 1.33.2.17  2002/08/07 01:08:49  hal9
278 # Bumped version to 2.9.18.
279 #
280 # Revision 1.33.2.16  2002/08/05 08:42:13  kick_
281 # same permissions, same runlevels as all the other initscripts
282 #
283 # Revision 1.33.2.15  2002/07/30 21:51:19  hal9
284 # Bump version to 2.9.17.
285 #
286 # Revision 1.33.2.14  2002/07/27 21:58:16  kick_
287 # bump version
288 #
289 # Revision 1.33.2.13  2002/07/27 21:39:41  kick_
290 # condrestart raised an error during an fresh install when privoxy wasn't already running
291 #
292 # Revision 1.33.2.12  2002/07/27 15:47:10  hal9
293 # Reset version and release for 2.9.16.
294 #
295 # Revision 1.33.2.11  2002/07/25 09:47:57  kick_
296 # this caused some errors during a fresh installation. It's unnecessary to call an extra program (/bin/true) to set the error code to 0
297 #
298 # Revision 1.33.2.10  2002/07/12 09:14:26  kick_
299 # don't use ghost files for rcX.d/*, chkconfig is available to do this job. Enable translation of error messge
300 #
301 # Revision 1.33.2.9  2002/07/05 17:16:19  morcego
302 # - Changing delete order for groups and users (users should be first)
303 #
304 # Revision 1.33.2.8  2002/07/03 20:46:24  morcego
305 # - Changing sed expression that removed CR from the end of the lines. This
306 #   new one removes any control caracter, and should work with older versions
307 #   of sed
308 #
309 # Revision 1.33.2.7  2002/07/02 18:16:48  morcego
310 # - Fixing defattr values. File and directory modes where swapped
311 #
312 # Revision 1.33.2.6  2002/07/02 17:38:10  morcego
313 # Bumping Release number
314 #
315 # Revision 1.33.2.5  2002/07/02 11:43:20  hal9
316 # Fix typo in templates creation.
317 #
318 # Revision 1.33.2.4  2002/06/26 17:32:45  morcego
319 # Integrating fixed from the main branch.
320 #
321 # Revision 1.33.2.3  2002/06/24 12:13:34  kick_
322 # shut up rpmlint. btw: The vendor tag should be set in you .rpmmacros file, not in the spec file!
323 #
324 # Revision 1.33.2.2  2002/05/28 02:39:38  hal9
325 # Replace index.html with privoxy-index.html for docs.
326 #
327 # Revision 1.33.2.1  2002/05/26 17:20:23  hal9
328 # Add images to doc dirs.
329 #
330 # Revision 1.33  2002/05/25 02:08:23  hal9
331 # Add doc/images directory.
332 # Redhat: alphabetized list of templates (and I think added one in the process)
333 #
334 # Revision 1.32  2002/05/16 01:37:29  hal9
335 # Add new template file so CGI stuff works :)
336 #
337 # Revision 1.31  2002/05/03 17:14:35  morcego
338 # *.spec: Version bump to 2.9.15
339 # -rh.spec: noreplace for %%{privoxyconf}/config
340 #           Will interrupt the build if versions from configure.in and
341 #               specfile do not match
342 #
343 # Revision 1.30  2002/04/26 15:51:05  morcego
344 # Changing Vendor value to Privoxy.Org
345 #
346 # Revision 1.29  2002/04/24 03:13:51  hal9
347 # New actions files changes.
348 #
349 # Revision 1.28  2002/04/22 18:51:33  morcego
350 # user and group now get removed on rh too.
351 #
352 # Revision 1.27  2002/04/22 16:32:31  morcego
353 # configure.in, *.spec: Bumping release to 2 (2.9.14-2)
354 # -rh.spec: uid and gid are now macros
355 # -suse.spec: Changing the header Copyright to License (Copyright is
356 #             deprecable)
357 #
358 # Revision 1.26  2002/04/22 16:24:36  morcego
359 # - Changes to fixate the uid and gid values as (both) 73. This is a
360 #   value we hope to standarize for all distributions. RedHat already
361 #   uses it, and Conectiva should start as soon as I find where the heck
362 #   I left my cluebat :-)
363 # - Only remove the user and group on uninstall if this is not redhat, once
364 #   redhat likes to have the values allocated even if the package is not
365 #   installed
366 #
367 # Revision 1.25  2002/04/17 01:59:12  hal9
368 # Add --disable-dynamic-pcre.
369 #
370 # Revision 1.24  2002/04/11 10:09:20  oes
371 # Version 2.9.14
372 #
373 # Revision 1.23  2002/04/10 18:14:45  morcego
374 # - (privoxy-rh.spec only) Relisting template files on the %%files section
375 # - (configure.in, privoxy-rh.spec) Bumped package release to 5
376 #
377 # Revision 1.22  2002/04/09 22:06:12  hal9
378 # Remove 'make dok'.
379 #
380 # Revision 1.21  2002/04/09 02:52:26  hal9
381 # - Add templates/cgi-style.css, faq.txt, p_web.css, LICENSE
382 # - Remove templates/blocked-compact.
383 # - Add more docbook stuff to Buildrequires.
384 #
385 # Revision 1.20  2002/04/08 20:27:45  swa
386 # fixed JB spelling
387 #
388 # Revision 1.19  2002/03/27 22:44:59  sarantis
389 # Include correct documentation file.
390 #
391 # Revision 1.18  2002/03/27 22:10:14  sarantis
392 # bumped Hal's last commit 1 day to the future to make rpm build again.
393 #
394 # Revision 1.17  2002/03/27 00:48:23  hal9
395 # Fix up descrition.
396 #
397 # Revision 1.16  2002/03/26 22:29:55  swa
398 # we have a new homepage!
399 #
400 # Revision 1.15  2002/03/26 17:39:54  morcego
401 # Adding comment on the specfile to remember the packager to update
402 # the release number on the configure script
403 #
404 # Revision 1.14  2002/03/26 14:25:15  hal9
405 # Added edit-actions-for-url-filter to templates in %%config
406 #
407 # Revision 1.13  2002/03/25 13:31:04  morcego
408 # Bumping Release tag.
409 #
410 # Revision 1.12  2002/03/25 03:11:40  hal9
411 # Do it right way this time :/
412 #
413 # Revision 1.11  2002/03/25 03:09:51  hal9
414 # Added faq to docs.
415 #
416 # Revision 1.10  2002/03/24 22:16:14  morcego
417 # Just removing some old commentaries.
418 #
419 # Revision 1.9  2002/03/24 22:03:22  morcego
420 # Should be working now. See %changelog for details
421 #
422 # Revision 1.8  2002/03/24 21:13:01  morcego
423 # Tis broken.
424 #
425 # Revision 1.7  2002/03/24 21:07:18  hal9
426 # Add autoheader, etc.
427 #
428 # Revision 1.6  2002/03/24 19:56:40  hal9
429 # /etc/junkbuster is now /etc/privoxy. Fixed ';' typo.
430 #
431 # Revision 1.4  2002/03/24 13:32:42  swa
432 # name change related issues
433 #
434 # Revision 1.3  2002/03/24 12:56:21  swa
435 # name change related issues.
436 #
437 # Revision 1.2  2002/03/24 11:40:14  swa
438 # name change
439 #
440 # Revision 1.1  2002/03/24 11:23:44  swa
441 # name change
442 #
443 # Revision 1.1  2002/03/22 20:53:03  morcego
444 # - Ongoing process to change name to JunkbusterNG
445 # - configure/configure.in: no change needed
446 # - GNUmakefile.in:
447 #         - TAR_ARCH = /tmp/JunkbusterNG-$(RPM_VERSION).tar.gz
448 #         - PROGRAM    = jbng@EXEEXT@
449 #         - rh-spec now references as junkbusterng-rh.spec
450 #         - redhat-upload: references changed to junkbusterng-* (package names)
451 #         - tarball-dist: references changed to JunkbusterNG-distribution-*
452 #         - tarball-src: now JunkbusterNG-*
453 #         - install: initscript now junkbusterng.init and junkbusterng (when
454 #                    installed)
455 # - junkbuster-rh.spec: renamed to junkbusterng-rh.spec
456 # - junkbusterng.spec:
457 #         - References to the expression ijb where changed where possible
458 #         - New package name: junkbusterng (all in lower case, acording to
459 #           the LSB recomendation)
460 #         - Version changed to: 2.9.13
461 #         - Release: 1
462 #         - Added: junkbuster to obsoletes and conflicts (Not sure this is
463 #           right. If it obsoletes, why conflict ? Have to check it later)
464 #         - Summary changed: Stefan, please check and aprove it
465 #         - Changes description to use the new name
466 #         - Sed string was NOT changed. Have to wait to the manpage to
467 #           change first
468 #         - Keeping the user junkbuster for now. It will require some aditional
469 #           changes on the script (scheduled for the next specfile release)
470 #         - Added post entry to move the old logfile to the new log directory
471 #         - Removing "chkconfig --add" entry (not good to have it automaticaly
472 #           added to the startup list).
473 #         - Added preun section to stop the service with the old name, as well
474 #           as remove it from the startup list
475 #         - Removed the chkconfig --del entry from the conditional block on
476 #           the preun scriptlet (now handled on the %files section)
477 # - junkbuster.init: renamed to junkbusterng.init
478 # - junkbusterng.init:
479 #         - Changed JB_BIN to jbng
480 #         - Created JB_OBIN with the old value of JB_BIN (junkbuster), to
481 #           be used where necessary (config dir)
482 #
483 # Aditional notes:
484 # - The config directory is /etc/junkbuster yet. Have to change it on the
485 # specfile, after it is changes on the code
486 # - The only files that got renamed on the cvs tree were the rh specfile and
487 # the init file. Some file references got changes on the makefile and on the
488 # rh-spec (as listed above)
489 #
490 # Revision 1.43  2002/03/21 16:04:10  hal9
491 # added ijb_docs.css to %doc
492 #
493 # Revision 1.42  2002/03/12 13:41:18  sarantis
494 # remove hard-coded "ijbswa" string in build phase
495 #
496 # Revision 1.41  2002/03/11 22:58:32  hal9
497 # Remove --enable-no-gifs
498 #
499 # Revision 1.39  2002/03/08 18:57:29  swa
500 # remove user junkbuster after de-installation.
501 #
502 # Revision 1.38  2002/03/08 13:45:27  morcego
503 # Adding libtool to Buildrequires
504 #
505 # Revision 1.37  2002/03/07 19:23:49  swa
506 # i hate to scroll. suse: wrong configdir.
507 #
508 # Revision 1.36  2002/03/07 05:06:54  morcego
509 # Fixed %pre scriptlet. And, as a bonus, you can even understand it now. :-)
510 #
511 # Revision 1.34  2002/03/07 00:11:57  morcego
512 # Few changes on the %pre and %post sections of the rh specfile to handle
513 # usernames more cleanly
514 #
515 # Revision 1.33  2002/03/05 13:13:57  morcego
516 # - Added "make redhat-dok" to the build phase
517 # - Added docbook-utils to BuildRequires
518 #
519 # Revision 1.32  2002/03/05 12:34:24  morcego
520 # - Changing section internaly on the manpage from 1 to 8
521 # - We now require packages, not files, to avoid issues with apt
522 #
523 # Revision 1.31  2002/03/04 18:06:09  morcego
524 # SPECFILE: fixing permissing of the init script (broken by the last change)
525 #
526 # Revision 1.30  2002/03/04 16:18:03  morcego
527 # General cleanup of the rh specfile.
528 #
529 # %changelog
530 # * Mon Mar 04 2002 Rodrigo Barbosa <rodrigob@tisbrasil.com.br>
531 # + junkbuster-2.9.11-2
532 # - General specfile fixup, using the best recomended practices, including:
533 #         - Adding -q to %%setup
534 #         - Using macros whereever possible
535 #         - Not using wildchars on %%files section
536 #         - Doubling the percentage char on changelog and comments, to
537 #           avoid rpm expanding them
538 #
539 # Revision 1.29  2002/03/03 19:21:22  hal9
540 # Init script fails if shell is /bin/false.
541 #
542 # Revision 1.28  2002/01/09 18:34:03  hal9
543 # nit.
544 #
545 # Revision 1.27  2002/01/09 18:32:02  hal9
546 # Removed RPM_OPT_FLAGS kludge.
547 #
548 # Revision 1.26  2002/01/09 18:21:10  hal9
549 # A few minor updates.
550 #
551 # Revision 1.25  2001/12/28 01:45:36  steudten
552 # Add paranoia check and BuildReq: gzip
553 #
554 # Revision 1.24  2001/12/01 21:43:14  hal9
555 # Allowed for new ijb.action file.
556 #
557 # Revision 1.23  2001/11/06 12:09:03  steudten
558 # Compress doc files. Install README and AUTHORS at last as document.
559 #
560 # Revision 1.22  2001/11/05 21:37:34  steudten
561 # Fix to include the actual version for name.
562 # Let the 'real' packager be included - sorry stefan.
563 #
564 # Revision 1.21  2001/10/31 19:27:27  swa
565 # consistent description. new name for suse since
566 # we had troubles with rpms of identical names
567 # on the webserver.
568 #
569 # Revision 1.20  2001/10/24 15:45:49  hal9
570 # To keep Thomas happy (aka correcting my  mistakes)
571 #
572 # Revision 1.19  2001/10/15 03:23:59  hal9
573 # Nits.
574 #
575 # Revision 1.17  2001/10/10 18:59:28  hal9
576 # Minor change for init script.
577 #
578 # Revision 1.16  2001/09/24 20:56:23  hal9
579 # Minor changes.
580 #
581 # Revision 1.13  2001/09/10 17:44:43  swa
582 # integrate three pieces of documentation. needs work.
583 # will not build cleanly under redhat.
584 #
585 # Revision 1.12  2001/09/10 16:25:04  swa
586 # copy all templates. version updated.
587 #
588 # Revision 1.11  2001/07/03 11:00:25  sarantis
589 # replaced permissionsfile with actionsfile
590 #
591 # Revision 1.10  2001/07/03 09:34:44  sarantis
592 # bumped up version number.
593 #
594 # Revision 1.9  2001/06/12 18:15:29  swa
595 # the %% in front of configure (see tag below) confused
596 # the rpm build process on 7.1.
597 #
598 # Revision 1.8  2001/06/12 17:15:56  swa
599 # fixes, because a clean build on rh6.1 was impossible.
600 # GZIP confuses make, %% configure confuses rpm, etc.
601 #
602 # Revision 1.7  2001/06/11 12:17:26  sarantis
603 # fix typo in %%post
604 #
605 # Revision 1.6  2001/06/11 11:28:25  sarantis
606 # Further optimizations and adaptations in the spec file.
607 #
608 # Revision 1.5  2001/06/09 09:14:11  swa
609 # shamelessly adapted RPM stuff from the newest rpm that
610 # RedHat provided for the JB.
611 #
612 # Revision 1.4  2001/06/08 20:54:18  swa
613 # type with status file. remove forward et. al from file list.
614 #
615 # Revision 1.3  2001/06/07 17:28:10  swa
616 # cosmetics
617 #
618 # Revision 1.2  2001/06/04 18:31:58  swa
619 # files are now prefixed with either `confdir' or `logdir'.
620 # `make redhat-dist' replaces both entries confdir and logdir
621 # with redhat values
622 #
623 # Revision 1.1  2001/06/04 10:44:57  swa
624 # `make redhatr-dist' now works. Except for the paths
625 # in the config file.
626 #
627 #
628 #
This page took 0.108104 seconds and 4 git commands to generate.