]> git.pld-linux.org Git - packages/pound.git/blob - pound.spec
- add pound user
[packages/pound.git] / pound.spec
1 Summary:        Pound - reverse-proxy and load-balancer
2 Summary(pl.UTF-8):      Pound - reverse-proxy i load-balancer
3 Name:           pound
4 Version:        2.4.3
5 Release:        2.2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.apsis.ch/pound/Pound-%{version}.tgz
9 # Source0-md5:  2de4c2ac1023b420b74a1bc08fb93b8a
10 Source1:        %{name}.cfg
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://www.apsis.ch/pound/
14 BuildRequires:  automake
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  pcre-devel
17 BuildRequires:  rpmbuild(macros) >= 1.202
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(postun):       /usr/sbin/groupdel
20 Requires(postun):       /usr/sbin/userdel
21 Requires(pre):  /bin/id
22 Requires(pre):  /usr/bin/getgid
23 Requires(pre):  /usr/sbin/groupadd
24 Requires(pre):  /usr/sbin/useradd
25 Requires:       rc-scripts
26 Provides:       group(pound)
27 Provides:       user(pound)
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Pound program is a reverse proxy, load balancer and HTTPS
32 front-end for Web server(s). Pound was developped to enable
33 distributing the load among several Web-servers and to allow for a
34 convenient SSL wrapper for those Web servers that do not offer it
35 natively. Pound is distributed under the GPL - no warranty, it's free
36 to use, copy and give away.
37
38 %description -l pl.UTF-8
39 Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
40 HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
41 rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
42 opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
43 jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
44 swobodnego używania, kopiowania i rozdawania.
45
46 %prep
47 %setup -q -n Pound-%{version}
48
49 %build
50 cp -f /usr/share/automake/config.sub .
51 %configure \
52         --with-maxbuf=2048
53
54 %{__make} \
55         CC="%{__cc}" \
56         F_CONF=%{_sysconfdir}/%{name}/pound.cfg
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir}/pound,/var/run/%{name},/etc/{sysconfig,rc.d/init.d}}
61
62 install pound    $RPM_BUILD_ROOT%{_sbindir}
63 install poundctl $RPM_BUILD_ROOT%{_sbindir}
64 install pound.8  $RPM_BUILD_ROOT%{_mandir}/man8
65 install poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
66 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
67 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
68 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %pre
74 %groupadd -g 200 %{name}
75 %useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
76
77 %post
78 /sbin/chkconfig --add %{name}
79 %service %{name} restart "Pound Daemon"
80
81 %preun
82 if [ "$1" = "0" ]; then
83         %service %{name} stop
84         /sbin/chkconfig --del %{name}
85 fi
86
87 %postun
88 if [ "$1" = "0" ]; then
89         %userremove %{name}
90         %groupremove %{name}
91 fi
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README FAQ CHANGELOG z*.py
96 %attr(755,root,root) %{_sbindir}/*
97 %dir %{_sysconfdir}/pound
98 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound/*
99 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
100 %attr(754,root,root) /etc/rc.d/init.d/%{name}
101 %{_mandir}/man8/*
102 %dir /var/run/%{name}
This page took 0.055249 seconds and 3 git commands to generate.