]> git.pld-linux.org Git - packages/pound.git/blob - pound.spec
- Vendor field fix
[packages/pound.git] / pound.spec
1 Summary:        Pound - reverse-proxy and load-balancer
2 Summary(pl):    Pound - reverse-proxy i load-balancer
3 Name:           pound
4 Version:        1.2
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Vendor:         Robert Segall <roseg@apsis.ch>
9 Source0:        http://www.apsis.ch/pound/Pound-%{version}.tgz
10 Source1:        %{name}.cfg
11 Source2:        %{name}.init
12 URL:            http://www.apsis.ch/pound/
13 BuildRequires:  openssl-devel >= 0.9.7
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The Pound program is a reverse proxy, load balancer and HTTPS
18 front-end for Web server(s). Pound was developped to enable
19 distributing the load among several Web-servers and to allow for a
20 convenient SSL wrapper for those Web servers that do not offer it
21 natively. Pound is distributed under the GPL - no warranty, it's free
22 to use, copy and give away.
23
24 %description -l pl
25 Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
26 HTTPS do serwera(ów) WWW. Pount zosta³ stworzony by pozwoliæ na
27 rozdzielenie obci±¿enia na kilka serwerów WWW i pozwoliæ na wygodne
28 opakowanie SSL-em tych serwerów, które same nie obs³uguj± SSL. Pound
29 jest rozpowszechniany na licencji GPL - bez gwarancji, z mo¿liwo¶ci±
30 swobodnego u¿ywania, kopiowania i rozdawania.
31
32 %prep
33 %setup -q -n pound
34
35 %build
36 %{configure}
37 %{__make} F_CONF=%{_sysconfdir}/pound/pound.cfg
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man8,%{_sysconfdir}/{pound/,rc.d/init.d}}
42
43 install pound   $RPM_BUILD_ROOT%{_bindir}
44 install pound.8 $RPM_BUILD_ROOT%{_mandir}/man8/
45 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pound/
46 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
47
48 %post
49 /sbin/chkconfig --add %{name}
50 if [ -f %{_var}/lock/subsys/%{name} ]; then
51         /etc/rc.d/init.d/%{name} restart 1>&2
52 else
53         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
54 fi
55
56 %preun
57 if [ "$1" = "0" -a -f %{_var}/lock/subsys/%{name} ]; then
58         /etc/rc.d/init.d/%{name} stop 1>&2
59 fi
60 /sbin/chkconfig --del %{name}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(755,root,root) %{_bindir}/*
69 %dir %{_sysconfdir}/pound
70 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pound/*
71 %attr(754,root,root) /etc/rc.d/init.d/%{name}
72 %{_mandir}/man8/*
This page took 0.038764 seconds and 3 git commands to generate.