]> git.pld-linux.org Git - SPECS.git/blob - portaudio.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / portaudio.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  apidocs         # documentation generated with doxygen
5 %bcond_without  asihpi          # ASI HPI support
6
7 %define snap    20161030
8 %define rel     2
9 Summary:        Free, cross platform, open-source, audio I/O library
10 Summary(pl.UTF-8):      Darmowa, międzyplatformowa i otwarta biblioteka I/O audio
11 Name:           portaudio
12 Version:        19
13 Release:        1.%{snap}.%{rel}
14 License:        MIT-like (see LICENSE.txt)
15 Group:          Libraries
16 Source0:        http://www.portaudio.com/archives/pa_stable_v%{version}0600_%{snap}.tgz
17 # Source0-md5:  4df8224e047529ca9ad42f0521bf81a8
18 Patch0:         %{name}-ac.patch
19 URL:            http://www.portaudio.com/
20 BuildRequires:  alsa-lib-devel >= 0.9
21 BuildRequires:  autoconf >= 2.13
22 BuildRequires:  automake
23 %{?with_apidocs:BuildRequires:  doxygen}
24 %{?with_asihpi:BuildRequires:   hpklinux-devel >= 4.06}
25 BuildRequires:  jack-audio-connection-kit-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.566
29 %{?with_asihpi:Requires:        hpklinux-libs >= 4.06}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 PortAudio is a free, cross platform, open-source, audio I/O library.
34 It lets you write simple audio programs in 'C' that will compile and
35 run on many platforms including Windows, Macintosh (8,9,X), Unix
36 (OSS), SGI, and BeOS.
37
38 %description -l pl.UTF-8
39 PortAudio to darmowa, międzyplatformowa i otwarta biblioteka I/O
40 audio. Pozwala na pisanie prostych programów w "C", które będą się
41 kompilować i uruchamiać na wielu platformach, w tym Windows, Macintosh
42 (8,9,X), Unix (OSS), SGI, i BeOS.
43
44 %package devel
45 Summary:        Header files for PortAudio library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PortAudio
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       alsa-lib-devel >= 0.9
50 %{?with_asihpi:Requires:        hpklinux-devel >= 4.06}
51 Requires:       jack-audio-connection-kit-devel
52
53 %description devel
54 Header files for PortAudio library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki PortAudio.
58
59 %package static
60 Summary:        Static PortAudio library
61 Summary(pl.UTF-8):      Statyczna biblioteka PortAudio
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static PortAudio library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka PortAudio.
70
71 %package apidocs
72 Summary:        portaudio API documentation
73 Summary(pl.UTF-8):      Documentacja API portaudio
74 Group:          Documentation
75 BuildArch:      noarch
76
77 %description apidocs
78 Documentation for portaudio API in HTML format generated from
79 portaudio sources by doxygen.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API portaudio w formacie HTML generowane ze źrodeł
83 portaudio przez doxygen.
84
85 %package c++
86 Summary:        C++ binding for PortAudio library
87 Summary(pl.UTF-8):      Wiązanie C++ do biblioteki PortAudio
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description c++
92 C++ binding for PortAudio library.
93
94 %description c++ -l pl.UTF-8
95 Wiązanie C++ do biblioteki PortAudio.
96
97 %package c++-devel
98 Summary:        Header files for C++ binding for PortAudio library
99 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania C++ do biblioteki PortAudio
100 Group:          Development/Libraries
101 Requires:       %{name}-c++ = %{version}-%{release}
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description c++-devel
106 Header files for C++ binding for PortAudio library.
107
108 %description c++-devel -l pl.UTF-8
109 Pliki nagłówkowe wiązania C++ do biblioteki PortAudio.
110
111 %package c++-static
112 Summary:        Static library of C++ binding for PortAudio library
113 Summary(pl.UTF-8):      Statyczna biblioteka wiązania C++ do biblioteki PortAudio
114 Group:          Development/Libraries
115 Requires:       %{name}-c++-devel = %{version}-%{release}
116
117 %description c++-static
118 Static library of C++ binding for PortAudio library.
119
120 %description c++-static -l pl.UTF-8
121 Statyczna biblioteka wiązania C++ do biblioteki PortAudio.
122
123 %prep
124 %setup -q -n %{name}
125 %patch0 -p1
126
127 %build
128 cp -f /usr/share/automake/config.sub .
129 %{__libtoolize}
130 cd bindings/cpp
131 %{__aclocal}
132 %{__autoconf}
133 %{__automake}
134 cd ../..
135 %{__aclocal}
136 %{__autoconf}
137 %configure \
138         --enable-cxx \
139         --enable-static%{!?with_static_libs:=no} \
140         %{!?with_asihpi:--without-asihpi}
141
142 %{__make} -j1
143 %{?with_apidocs:/usr/bin/doxygen}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %post   c++ -p /sbin/ldconfig
160 %postun c++ -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc README.txt LICENSE.txt
165 %attr(755,root,root) %{_libdir}/libportaudio.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libportaudio.so.2
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libportaudio.so
171 %{_includedir}/pa_jack.h
172 %{_includedir}/pa_linux_alsa.h
173 %{_includedir}/portaudio.h
174 %{_pkgconfigdir}/portaudio-2.0.pc
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libportaudio.a
180 %endif
181
182 %if %{with apidocs}
183 %files apidocs
184 %defattr(644,root,root,755)
185 %doc doc/html/*
186 %endif
187
188 %files c++
189 %defattr(644,root,root,755)
190 %doc bindings/cpp/{COPYING,ChangeLog}
191 %attr(755,root,root) %{_libdir}/libportaudiocpp.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libportaudiocpp.so.0
193
194 %files c++-devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libportaudiocpp.so
197 %{_includedir}/portaudiocpp
198 %{_pkgconfigdir}/portaudiocpp.pc
199
200 %if %{with static_libs}
201 %files c++-static
202 %defattr(644,root,root,755)
203 %{_libdir}/libportaudiocpp.a
204 %endif
This page took 0.247474 seconds and 3 git commands to generate.