]> git.pld-linux.org Git - packages/popt.git/blob - popt.spec
popt fixes for rpm
[packages/popt.git] / popt.spec
1 Summary:        C library for parsing command line parameters
2 Summary(de):    C-Library zum Parsen von Befehlszeilenparametern 
3 Summary(fr):    Bibliothèque C pour analyser les paramètres de la ligne de commande
4 Summary(pl):    Biblioteka C do przetwarzania parametrów przekazywanych do programów w linii poleceñ
5 Summary(tr):    Komut satýrý parametrelerini ayrýþtýrýmak için C arþivi
6 Name:           popt
7 Version:        1.6.2
8 Release:        1
9 License:        LGPL
10 Group:          Libraries
11 Group(de):      Libraries
12 Group(fr):      Librairies
13 Group(pl):      Biblioteki
14 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-values.patch
16 BuildRequires:  gettext-devel
17 BuildRequires:  autoconf
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Popt is a C library for pasing command line parameters. It was heavily
22 influenced by the getopt() and getopt_long() functions, but it allows
23 more powerfull argument expansion. It can parse arbitrary argv[] style
24 arrays and automatically set variables based on command line
25 arguments. It also allows command line arguments to be aliased via
26 configuration files and includes utility functions for parsing
27 arbitrary strings into argv[] arrays using shell-like rules.
28
29 %description -l de
30 Popt ist eine C-Library zum Parsen von Befehlszeilenparametern, stark
31 beeinflußt von den getopt() und getopt_long()-Funktionen, aber mit
32 sehr viel besserer Argumenterweiterung. Es können beliebige
33 argv[]-Argument- Arrays geparst und Variablen auf der Basis von
34 Befehlszeilenargumenten automatisch gesetzt werden. Ferner können
35 Befehlszeilenargumente über Konfigurationsdateien ge-aliast werden,
36 und die Library enthält Utility- funktionen zum Parsen beliebiger
37 Strings in argv[]-Arrays anhand von Shell-ähnlichen Regeln.
38
39 %description -l fr
40 Popt est une bibliothèque C pour analyser les paramêtres de la ligne
41 de commande. Elle a été beaucoup influencée par les fonctions getopt()
42 et getopt_long() mais permet une expansion plus puissante des
43 arguments. Elle peut analyser des tableaux arbitraires du style argv[]
44 et configure les variables automatiquement selon les arguments de la
45 ligne de commande. Elle permet aussi à ces arguments d'être des alias
46 via des fichiers de configuration et inclut des fonctions utilitaires
47 pour analyser des chaînes arbitraires dans les tableaux argv[] en
48 utilisant des règles à la shell
49
50 %description -l pl
51 Popt jest bibliotek± C s³u¿±c± przetwarzaniu parametrów wywo³ania.
52 Du¿y wp³yw mia³y na ni± getopt() i getopt_long(), ale ma od nich
53 znacznie wiêksze mo¿liwo¶ci. Mo¿e przetwarzaæ bezpo¶rednio tablice
54 typu argv[] i automatycznie ustawiaæ zmienne w oparciu i parametry
55 wywo³ania. Pozwala tak¿e na tworzenie zwi±zków pomiêdzy argumentami
56 wywo³ania a plikami konfiguracyjnymi oraz pozwala zamieniaæ ci±gi
57 znaków na tablice typu argv[] z wykorzystaniem zasad znanych z pow³ok
58 (shell'i).
59
60 %description -l tr
61 Popt, komut satýrý parametrelerini ayrýþtýran bir C arþividir.
62 Geliþigüzel argv[] tarzý dizileri ayrýþtýrabilir ve otomatik olarak
63 komut satýrý deðiþkenlerine dayalý deðiþkenleri atayabilir.
64
65 %package devel
66 Summary:        Header file and library for popt development
67 Summary(pl):    Pliki nag³ówkowe dla popt
68 Group:          Development/Libraries
69 Group(de):      Entwicklung/Libraries
70 Group(fr):      Development/Librairies
71 Group(pl):      Programowanie/Biblioteki
72 Requires:       %{name} = %{version}
73
74 %description devel
75 Header file and library for popt development.
76
77 %description devel -l pl
78 Pliki nag³ówkowe i dokumentacja dla popt.
79
80 %package static
81 Summary:        Static library for popt development
82 Summary(pl):    Biblioteka statyczna do popt
83 Group:          Development/Libraries
84 Group(de):      Entwicklung/Libraries
85 Group(fr):      Development/Librairies
86 Group(pl):      Programowanie/Biblioteki
87 Requires:       %{name}-devel = %{version}
88
89 %description static
90 Static library for popt development.
91
92 %description static -l pl
93 Biblioteka statyczna do popt.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 autoconf
101 %configure \
102         --enable-shared
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT/lib
108
109 %{__make} install DESTDIR=$RPM_BUILD_ROOT
110
111 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/lib
112 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
113 ln -sf ../../lib/`( cd $RPM_BUILD_ROOT/lib; echo *)` \
114         $RPM_BUILD_ROOT%{_libdir}/libpopt.so
115
116 %find_lang %{name}
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %attr(755,root,root) /lib/*
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libpopt.so
131 %attr(755,root,root) %{_libdir}/libpopt.la
132 %{_mandir}/man3/*
133 %{_includedir}/popt.h
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libpopt.a
This page took 0.066277 seconds and 3 git commands to generate.