]> git.pld-linux.org Git - packages/popt.git/blob - popt.spec
72976fd5b568759eead59481ffbe0b57f6680628
[packages/popt.git] / popt.spec
1 Summary:        C library for parsing command line parameters
2 Summary(de):    C-Library zum Parsen von Befehlszeilenparametern 
3 Summary(fr):    Bibliothèque C pour analyser les paramètres de la ligne de commande
4 Summary(pl):    Biblioteka C do przetwarzania parametrów przekazywanych do programów w linii poleceñ
5 Summary(tr):    Komut satýrý parametrelerini ayrýþtýrýmak için C arþivi
6 Name:           popt
7 Version:        1.6.2
8 Release:        2
9 License:        LGPL
10 Group:          Libraries
11 Group(de):      Libraries
12 Group(fr):      Librairies
13 Group(pl):      Biblioteki
14 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-values.patch
16 Patch1:         %{name}-cvs20010530.patch
17 BuildRequires:  gettext-devel
18 BuildRequires:  autoconf
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Popt is a C library for pasing command line parameters. It was heavily
23 influenced by the getopt() and getopt_long() functions, but it allows
24 more powerfull argument expansion. It can parse arbitrary argv[] style
25 arrays and automatically set variables based on command line
26 arguments. It also allows command line arguments to be aliased via
27 configuration files and includes utility functions for parsing
28 arbitrary strings into argv[] arrays using shell-like rules.
29
30 %description -l de
31 Popt ist eine C-Library zum Parsen von Befehlszeilenparametern, stark
32 beeinflußt von den getopt() und getopt_long()-Funktionen, aber mit
33 sehr viel besserer Argumenterweiterung. Es können beliebige
34 argv[]-Argument- Arrays geparst und Variablen auf der Basis von
35 Befehlszeilenargumenten automatisch gesetzt werden. Ferner können
36 Befehlszeilenargumente über Konfigurationsdateien ge-aliast werden,
37 und die Library enthält Utility- funktionen zum Parsen beliebiger
38 Strings in argv[]-Arrays anhand von Shell-ähnlichen Regeln.
39
40 %description -l fr
41 Popt est une bibliothèque C pour analyser les paramêtres de la ligne
42 de commande. Elle a été beaucoup influencée par les fonctions getopt()
43 et getopt_long() mais permet une expansion plus puissante des
44 arguments. Elle peut analyser des tableaux arbitraires du style argv[]
45 et configure les variables automatiquement selon les arguments de la
46 ligne de commande. Elle permet aussi à ces arguments d'être des alias
47 via des fichiers de configuration et inclut des fonctions utilitaires
48 pour analyser des chaînes arbitraires dans les tableaux argv[] en
49 utilisant des règles à la shell
50
51 %description -l pl
52 Popt jest bibliotek± C s³u¿±c± przetwarzaniu parametrów wywo³ania.
53 Du¿y wp³yw mia³y na ni± getopt() i getopt_long(), ale ma od nich
54 znacznie wiêksze mo¿liwo¶ci. Mo¿e przetwarzaæ bezpo¶rednio tablice
55 typu argv[] i automatycznie ustawiaæ zmienne w oparciu i parametry
56 wywo³ania. Pozwala tak¿e na tworzenie zwi±zków pomiêdzy argumentami
57 wywo³ania a plikami konfiguracyjnymi oraz pozwala zamieniaæ ci±gi
58 znaków na tablice typu argv[] z wykorzystaniem zasad znanych z pow³ok
59 (shell'i).
60
61 %description -l tr
62 Popt, komut satýrý parametrelerini ayrýþtýran bir C arþividir.
63 Geliþigüzel argv[] tarzý dizileri ayrýþtýrabilir ve otomatik olarak
64 komut satýrý deðiþkenlerine dayalý deðiþkenleri atayabilir.
65
66 %package devel
67 Summary:        Header file and library for popt development
68 Summary(pl):    Pliki nag³ówkowe dla popt
69 Group:          Development/Libraries
70 Group(de):      Entwicklung/Libraries
71 Group(fr):      Development/Librairies
72 Group(pl):      Programowanie/Biblioteki
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header file and library for popt development.
77
78 %description devel -l pl
79 Pliki nag³ówkowe i dokumentacja dla popt.
80
81 %package static
82 Summary:        Static library for popt development
83 Summary(pl):    Biblioteka statyczna do popt
84 Group:          Development/Libraries
85 Group(de):      Entwicklung/Libraries
86 Group(fr):      Development/Librairies
87 Group(pl):      Programowanie/Biblioteki
88 Requires:       %{name}-devel = %{version}
89
90 %description static
91 Static library for popt development.
92
93 %description static -l pl
94 Biblioteka statyczna do popt.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p2
100
101 %build
102 rm missing
103 autoupdate
104 libtoolize --force
105 autoheader
106 automake -a -i
107 autoconf
108 %configure2_50 \
109         --enable-shared
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT/lib
115
116 %{__make} install DESTDIR=$RPM_BUILD_ROOT
117
118 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/lib
119 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
120 ln -sf ../../lib/`( cd $RPM_BUILD_ROOT/lib; echo *)` \
121         $RPM_BUILD_ROOT%{_libdir}/libpopt.so
122
123 %find_lang %{name}
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %attr(755,root,root) /lib/*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libpopt.so
138 %attr(755,root,root) %{_libdir}/libpopt.la
139 %{_mandir}/man3/*
140 %{_includedir}/popt.h
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libpopt.a
This page took 0.062745 seconds and 2 git commands to generate.