]> git.pld-linux.org Git - packages/popt.git/blob - popt.spec
- adapterized, BuildRequires: automake, libtool
[packages/popt.git] / popt.spec
1 Summary:        C library for parsing command line parameters
2 Summary(de):    C-Library zum Parsen von Befehlszeilenparametern 
3 Summary(fr):    Bibliothèque C pour analyser les paramètres de la ligne de commande
4 Summary(pl):    Biblioteka C do przetwarzania parametrów przekazywanych do programów w linii poleceñ
5 Summary(tr):    Komut satýrý parametrelerini ayrýþtýrýmak için C arþivi
6 Name:           popt
7 Version:        1.6.2
8 Release:        2
9 License:        LGPL
10 Group:          Libraries
11 Group(de):      Libraries
12 Group(es):      Bibliotecas
13 Group(fr):      Librairies
14 Group(pl):      Biblioteki
15 Group(pt_BR):   Bibliotecas
16 Group(ru):      âÉÂÌÉÏÔÅËÉ
17 Group(uk):      â¦Â̦ÏÔÅËÉ
18 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
19 Patch0:         %{name}-values.patch
20 Patch1:         %{name}-cvs20010530.patch
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  libtool
24 BuildRequires:  gettext-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Popt is a C library for pasing command line parameters. It was heavily
29 influenced by the getopt() and getopt_long() functions, but it allows
30 more powerfull argument expansion. It can parse arbitrary argv[] style
31 arrays and automatically set variables based on command line
32 arguments. It also allows command line arguments to be aliased via
33 configuration files and includes utility functions for parsing
34 arbitrary strings into argv[] arrays using shell-like rules.
35
36 %description -l de
37 Popt ist eine C-Library zum Parsen von Befehlszeilenparametern, stark
38 beeinflußt von den getopt() und getopt_long()-Funktionen, aber mit
39 sehr viel besserer Argumenterweiterung. Es können beliebige
40 argv[]-Argument- Arrays geparst und Variablen auf der Basis von
41 Befehlszeilenargumenten automatisch gesetzt werden. Ferner können
42 Befehlszeilenargumente über Konfigurationsdateien ge-aliast werden,
43 und die Library enthält Utility- funktionen zum Parsen beliebiger
44 Strings in argv[]-Arrays anhand von Shell-ähnlichen Regeln.
45
46 %description -l fr
47 Popt est une bibliothèque C pour analyser les paramêtres de la ligne
48 de commande. Elle a été beaucoup influencée par les fonctions getopt()
49 et getopt_long() mais permet une expansion plus puissante des
50 arguments. Elle peut analyser des tableaux arbitraires du style argv[]
51 et configure les variables automatiquement selon les arguments de la
52 ligne de commande. Elle permet aussi à ces arguments d'être des alias
53 via des fichiers de configuration et inclut des fonctions utilitaires
54 pour analyser des chaînes arbitraires dans les tableaux argv[] en
55 utilisant des règles à la shell
56
57 %description -l pl
58 Popt jest bibliotek± C s³u¿±c± przetwarzaniu parametrów wywo³ania.
59 Du¿y wp³yw mia³y na ni± getopt() i getopt_long(), ale ma od nich
60 znacznie wiêksze mo¿liwo¶ci. Mo¿e przetwarzaæ bezpo¶rednio tablice
61 typu argv[] i automatycznie ustawiaæ zmienne w oparciu i parametry
62 wywo³ania. Pozwala tak¿e na tworzenie zwi±zków pomiêdzy argumentami
63 wywo³ania a plikami konfiguracyjnymi oraz pozwala zamieniaæ ci±gi
64 znaków na tablice typu argv[] z wykorzystaniem zasad znanych z pow³ok
65 (shell'i).
66
67 %description -l tr
68 Popt, komut satýrý parametrelerini ayrýþtýran bir C arþividir.
69 Geliþigüzel argv[] tarzý dizileri ayrýþtýrabilir ve otomatik olarak
70 komut satýrý deðiþkenlerine dayalý deðiþkenleri atayabilir.
71
72 %package devel
73 Summary:        Header file and library for popt development
74 Summary(pl):    Pliki nag³ówkowe dla popt
75 Group:          Development/Libraries
76 Group(de):      Entwicklung/Libraries
77 Group(es):      Desarrollo/Bibliotecas
78 Group(fr):      Development/Librairies
79 Group(pl):      Programowanie/Biblioteki
80 Group(pt_BR):   Desenvolvimento/Bibliotecas
81 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
82 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
83 Requires:       %{name} = %{version}
84
85 %description devel
86 Header file and library for popt development.
87
88 %description devel -l pl
89 Pliki nag³ówkowe i dokumentacja dla popt.
90
91 %package static
92 Summary:        Static library for popt development
93 Summary(pl):    Biblioteka statyczna do popt
94 Group:          Development/Libraries
95 Group(de):      Entwicklung/Libraries
96 Group(es):      Desarrollo/Bibliotecas
97 Group(fr):      Development/Librairies
98 Group(pl):      Programowanie/Biblioteki
99 Group(pt_BR):   Desenvolvimento/Bibliotecas
100 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
101 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
102 Requires:       %{name}-devel = %{version}
103
104 %description static
105 Static library for popt development.
106
107 %description static -l pl
108 Biblioteka statyczna do popt.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p2
114
115 %build
116 rm -f missing
117 autoupdate
118 libtoolize --force
119 autoheader
120 automake -a -i
121 autoconf
122 %configure \
123         --enable-shared
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT/lib
129
130 %{__make} install DESTDIR=$RPM_BUILD_ROOT
131
132 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/lib
133 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
134 ln -sf ../../lib/`( cd $RPM_BUILD_ROOT/lib; echo *)` \
135         $RPM_BUILD_ROOT%{_libdir}/libpopt.so
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %attr(755,root,root) /lib/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libpopt.so
152 %attr(755,root,root) %{_libdir}/libpopt.la
153 %{_mandir}/man3/*
154 %{_includedir}/popt.h
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libpopt.a
This page took 0.04541 seconds and 3 git commands to generate.