]> git.pld-linux.org Git - packages/popt.git/blob - popt.spec
- perl -pi -e "s/^libtoolize --copy --force/\%\{__libtoolize\}/"
[packages/popt.git] / popt.spec
1 Summary:        C library for parsing command line parameters
2 Summary(de):    C-Library zum Parsen von Befehlszeilenparametern
3 Summary(fr):    Bibliothèque C pour analyser les paramètres de la ligne de commande
4 Summary(pl):    Biblioteka C do przetwarzania parametrów przekazywanych do programów w linii poleceñ
5 Summary(tr):    Komut satýrý parametrelerini ayrýþtýrýmak için C arþivi
6 Name:           popt
7 Version:        1.6.2
8 Release:        3
9 License:        LGPL
10 Group:          Libraries
11 Source0:        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/%{name}-%{version}.tar.gz
12 Patch0:         %{name}-values.patch
13 Patch1:         %{name}-cvs20010530.patch
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  gettext-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Popt is a C library for pasing command line parameters. It was heavily
22 influenced by the getopt() and getopt_long() functions, but it allows
23 more powerfull argument expansion. It can parse arbitrary argv[] style
24 arrays and automatically set variables based on command line
25 arguments. It also allows command line arguments to be aliased via
26 configuration files and includes utility functions for parsing
27 arbitrary strings into argv[] arrays using shell-like rules.
28
29 %description -l de
30 Popt ist eine C-Library zum Parsen von Befehlszeilenparametern, stark
31 beeinflußt von den getopt() und getopt_long()-Funktionen, aber mit
32 sehr viel besserer Argumenterweiterung. Es können beliebige
33 argv[]-Argument- Arrays geparst und Variablen auf der Basis von
34 Befehlszeilenargumenten automatisch gesetzt werden. Ferner können
35 Befehlszeilenargumente über Konfigurationsdateien ge-aliast werden,
36 und die Library enthält Utility- funktionen zum Parsen beliebiger
37 Strings in argv[]-Arrays anhand von Shell-ähnlichen Regeln.
38
39 %description -l fr
40 Popt est une bibliothèque C pour analyser les paramêtres de la ligne
41 de commande. Elle a été beaucoup influencée par les fonctions getopt()
42 et getopt_long() mais permet une expansion plus puissante des
43 arguments. Elle peut analyser des tableaux arbitraires du style argv[]
44 et configure les variables automatiquement selon les arguments de la
45 ligne de commande. Elle permet aussi à ces arguments d'être des alias
46 via des fichiers de configuration et inclut des fonctions utilitaires
47 pour analyser des chaînes arbitraires dans les tableaux argv[] en
48 utilisant des règles à la shell
49
50 %description -l pl
51 Popt jest bibliotek± C s³u¿±c± przetwarzaniu parametrów wywo³ania.
52 Du¿y wp³yw mia³y na ni± getopt() i getopt_long(), ale ma od nich
53 znacznie wiêksze mo¿liwo¶ci. Mo¿e przetwarzaæ bezpo¶rednio tablice
54 typu argv[] i automatycznie ustawiaæ zmienne w oparciu i parametry
55 wywo³ania. Pozwala tak¿e na tworzenie zwi±zków pomiêdzy argumentami
56 wywo³ania a plikami konfiguracyjnymi oraz pozwala zamieniaæ ci±gi
57 znaków na tablice typu argv[] z wykorzystaniem zasad znanych z pow³ok
58 (shell'i).
59
60 %description -l tr
61 Popt, komut satýrý parametrelerini ayrýþtýran bir C arþividir.
62 Geliþigüzel argv[] tarzý dizileri ayrýþtýrabilir ve otomatik olarak
63 komut satýrý deðiþkenlerine dayalý deðiþkenleri atayabilir.
64
65 %package devel
66 Summary:        Header file and library for popt development
67 Summary(pl):    Pliki nag³ówkowe dla popt
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}
70
71 %description devel
72 Header file and library for popt development.
73
74 %description devel -l pl
75 Pliki nag³ówkowe i dokumentacja dla popt.
76
77 %package static
78 Summary:        Static library for popt development
79 Summary(pl):    Biblioteka statyczna do popt
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 Static library for popt development.
85
86 %description static -l pl
87 Biblioteka statyczna do popt.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p2
93
94 %build
95 rm -f missing
96 autoupdate
97 %{__libtoolize}
98 aclocal
99 autoheader
100 %{__autoconf}
101 automake -a -c -i
102 %configure \
103         --enable-shared
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT/lib
109
110 %{__make} install DESTDIR=$RPM_BUILD_ROOT
111
112 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/lib
113 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
114 ln -sf ../../lib/`( cd $RPM_BUILD_ROOT/lib; echo *)` \
115         $RPM_BUILD_ROOT%{_libdir}/libpopt.so
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %attr(755,root,root) /lib/*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libpopt.so
132 %attr(755,root,root) %{_libdir}/libpopt.la
133 %{_mandir}/man3/*
134 %{_includedir}/popt.h
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libpopt.a
This page took 0.04691 seconds and 3 git commands to generate.