]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- corrected name of the patch
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18
11 Release:        4
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 Patch0:         %{name}-vfprogress.patch
17 Patch1:         %{name}-poldek-hold-fix.patch
18 URL:            http://team.pld.org.pl/~mis/poldek/
19 Requires:       rpm >= 4.0.2-62
20 Requires:       sed
21 BuildRequires:  bzip2-devel
22 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre-devel
25 BuildRequires:  popt-devel
26 BuildRequires:  readline-devel
27 BuildRequires:  rpm-devel >= 4.0.2-62
28 BuildRequires:  zlib-devel
29 BuildRequires:  /usr/bin/pod2man
30 %{?_with_static:BuildRequires:  bzip2-static}
31 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
32 %{?_with_static:BuildRequires:  openssl-static}
33 %{?_with_static:BuildRequires:  pcre-static}
34 %{?_with_static:BuildRequires:  popt-static}
35 %{?_with_static:BuildRequires:  rpm-static}
36 %{?_with_static:BuildRequires:  zlib-static}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 poldek is an RPM package management tool which allows you to easily
41 perform package verification, installation (including system
42 installation from scratch), upgrading, and removal.
43
44 Program can be used in batch (like apt-get from Debian's APT) or
45 interactive mode. The interactive mode puts you into a readline
46 interface with command line autocompletion and history, similar to the
47 shell mode of Perl's CPAN.
48
49 %{?_with_static:This version is statically linked.}
50
51 %{?_without_imode:This version hasn't got interactive mode.}
52
53 %description -l pl
54 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
55 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
56 i usuwania pakietów.
57
58 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
59 lub interaktywnym. Tryb interaktywny posiada interfejs readline
60 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
61 modu³u CPAN.
62
63 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
64
65 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
66
67 %prep
68 %setup -q
69 %patch0 -p0 
70 %patch1 -p0 
71
72 %build
73 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
74         cp configure.in configure.in.orig
75         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
76 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
77                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
78                 configure.in.orig >configure.in
79         autopoint --force
80 fi
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         %{?_with_static:--enable-static} \
86         %{?_without_imode:--disable-imode} \
87         %{?_with_curl:--with-curl}
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_sysconfdir}
93
94 # no strip cause program's beta stage and core may be useful
95 %{__make} install DESTDIR=$RPM_BUILD_ROOT
96 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
97 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
98
99 %find_lang %{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files -f %{name}.lang
105 %defattr(644,root,root,755)
106 %doc README* NEWS TODO *sample* conf/poldekrc*
107 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
108 %attr(755,root,root) %{_bindir}/*
109 %{_mandir}/man1/%{name}*
110 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.107145 seconds and 4 git commands to generate.