]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- added --without curl bcond
[packages/poldek.git] / poldek.spec
1 # conditional build
2 #  --with static   -- don't use shared libraries
3 #  --without imode -- don't build interactive mode
4 #  --without curl  -- don't link curl
5 Summary:        RPM packages management helper tool
6 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
7 Name:           poldek
8 Version:        0.17.2
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
13 Source1:        %{name}.conf
14 URL:            http://team.pld.org.pl/~mis/poldek/
15 %{!?_with_static:Requires:      trurlib >= 0.43.5}
16 Requires:       /bin/rpm
17 BuildRequires:  bzip2-devel
18 BuildRequires:  db3-devel >= 3.1.14-2
19 BuildRequires:  curl-devel >= 7.8
20 BuildRequires:  openssl-devel
21 BuildRequires:  pcre-devel
22 BuildRequires:  popt-devel
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm-devel >= 4.0
25 BuildRequires:  trurlib-devel >= 0.43.5
26 BuildRequires:  zlib-devel
27 BuildRequires:  /usr/bin/pod2man
28 %{?_with_static:BuildRequires:  bzip2-static}
29 %{?_with_static:BuildRequires:  curl-static}
30 %{?_with_static:BuildRequires:  openssl-static}
31 %{?_with_static:BuildRequires:  popt-static}
32 %{?_with_static:BuildRequires:  rpm-static}
33 %{?_with_static:BuildRequires:  trurlib-static}
34 %{?_with_static:BuildRequires:  zlib-static}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 poldek is an RPM package management tool which allows you to easily
39 perform package verification, installation (including system
40 installation from scratch), upgrading, and removal.
41
42 Program can be used in batch (like apt-get from Debian's APT) or
43 interactive mode. The interactive mode puts you into a readline
44 interface with command line autocompletion and history, similar to the
45 shell mode of Perl's CPAN.
46
47 %{?_with_static:This version is statically linked}
48
49 %{?_without_imode:This version hasn't got interactive mode.}
50
51 %description -l pl
52 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
53 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji 
54 i usuwania pakietów.
55
56 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
57 lub interaktywnym. Tryb interaktywny posiada interfejs readline 
58 z dope³nianiem komend i histori±, podobny do trybu shell perlowego 
59 modu³u CPAN. 
60
61 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
62
63 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
64
65 %prep
66 %setup -q
67
68 %build
69 %configure \
70         %{?_with_static:--enable-static} \
71         %{?_without_imode:--disable-imode} \
72         %{?_without_curl:--without-curl}
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 install -d $RPM_BUILD_ROOT%{_sysconfdir}
78
79 # no strip cause program's alpha stage and core may be useful
80 %{__make} install DESTDIR=$RPM_BUILD_ROOT
81 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
82 sed "s/i686/%{_target_cpu}/g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
83
84 gzip -9nf README* *sample* NEWS TODO
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
92 %attr(755,root,root) %{_bindir}/*
93 %{_mandir}/man1/%{name}*
94 %doc *.gz
This page took 0.038687 seconds and 4 git commands to generate.