]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
remove --noorder option during package removal
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db60    # DB 6.0 instead of 5.2
8
9 # current snapshot name
10 %define         SNAP    2013
11
12 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
13 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
14 %if %{with db60}
15 %define         db_pkg          db6.0
16 %define         ver_db          6.0
17 %define         ver_db_rel      1
18 %else
19 %define         db_pkg          db5.2
20 %define         ver_db          5.2
21 %define         ver_db_rel      3
22 %endif
23 %define         ver_rpm         5.4.10
24
25 %define         rel     8
26 Summary:        RPM packages management helper tool
27 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
28 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
29 Name:           poldek
30 Version:        0.30.0
31 Release:        %{rel}%{?with_snap:.%{SNAP}}
32 License:        GPL v2
33 Group:          Applications/System
34 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
35 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
36 # Source0-md5:  392cfa125912fbedb6cc6d54dfbb80e3
37 Source1:        %{name}.conf
38 Source2:        %{name}-multilib.conf
39 Source5:        %{name}-aliases.conf
40 Source6:        %{name}.desktop
41 Source7:        %{name}.png
42 Source8:        %{name}-debuginfo.conf
43 Source9:        %{name}-aidath.conf
44 Source10:       %{name}-multilib-aidath.conf
45 Source11:       %{name}-archive.conf
46 Source100:      %{name}-snap.conf
47 Source101:      %{name}-multilib-snap.conf
48 Source102:      %{name}-debuginfo-snap.conf
49 Patch0:         %{name}-size-type.patch
50 Patch1:         %{name}-Os-fail-workaround.patch
51 Patch2:         %{name}-config.patch
52 Patch3:         at-char-completion.patch
53 Patch4:         %{name}-ignore-too-long-paths.patch
54 Patch5:         %{name}-noorder.patch
55 URL:            http://poldek.pld-linux.org/
56 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
57 BuildRequires:  autoconf
58 BuildRequires:  automake >= 1:1.11
59 BuildRequires:  bzip2-devel
60 BuildRequires:  check-devel
61 BuildRequires:  docbook-dtd412-xml
62 BuildRequires:  gettext-devel
63 BuildRequires:  libsemanage-devel
64 BuildRequires:  libtool
65 BuildRequires:  libxml2-devel
66 BuildRequires:  neon-devel
67 BuildRequires:  openssl-devel >= 0.9.7d
68 BuildRequires:  pcre-devel
69 BuildRequires:  pkgconfig
70 BuildRequires:  popt-devel
71 %{?with_python:BuildRequires:   python-devel}
72 BuildRequires:  readline-devel >= 5.0
73 BuildRequires:  rpm-devel >= %{ver_rpm}
74 %{?with_python:BuildRequires:   rpm-pythonprov}
75 BuildRequires:  swig-python
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  xmlto
78 BuildRequires:  xz
79 BuildRequires:  zlib-devel
80 %if %{with static}
81 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
82 BuildRequires:  bzip2-static
83 BuildRequires:  glibc-static
84 BuildRequires:  libselinux-static
85 BuildRequires:  libsemanage-static
86 BuildRequires:  libxml2-static
87 BuildRequires:  ncurses-static
88 BuildRequires:  openssl-static
89 BuildRequires:  pcre-static
90 BuildRequires:  popt-static
91 BuildRequires:  readline-static
92 BuildRequires:  rpm-static
93 BuildRequires:  zlib-static
94 %endif
95 Requires(triggerpostun):        awk
96 Requires(triggerpostun):        sed >= 4.0
97 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       rpm >= %{ver_rpm}
100 Requires:       rpm-db-ver = %{ver_db}
101 #Requires:      rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
102 Requires:       rpm-lib >= 5.4.10
103 # vf* scripts use sed
104 Requires:       sed
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _libexecdir     %{_prefix}/lib/%{name}
108
109 %description
110 poldek is an RPM package management tool which allows you to easily
111 perform package verification, installation (including system
112 installation from scratch), upgrading, and removal.
113
114 Program can be used in batch (like apt-get from Debian's APT) or
115 interactive mode. The interactive mode puts you into a readline
116 interface with command line autocompletion and history, similar to the
117 shell mode of Perl's CPAN.
118
119 %{?with_static:This version is statically linked.}
120
121 %{!?with_imode:This version hasn't got interactive mode.}
122 #'vim
123
124 %description -l hu.UTF-8
125 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
126 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
127 nulláról), frissítést és eltávolítást.
128
129 A program használható parancssorból (mint a Debian apt-get programja)
130 vagy interaktív módban. Az interaktív mód egy readline környezetet
131 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
132 shell módjához.
133
134 %{?with_static:Ez a verzió statikusan linkelt.}
135
136 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
137
138 %description -l pl.UTF-8
139 poldek jest narzędziem linii poleceń służącym do weryfikacji,
140 instalacji (włączając instalację systemu od zera), aktualizacji i
141 usuwania pakietów.
142
143 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
144 interaktywnym. Tryb interaktywny posiada interfejs readline z
145 dopełnianiem komend i historią, podobny do trybu shell perlowego
146 modułu CPAN.
147
148 %{?with_static:Ta wersja jest konsolidowana statycznie.}
149
150 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
151
152 %package libs
153 Summary:        poldek libraries
154 Summary(hu.UTF-8):      A poldek könyvtárai
155 Summary(pl.UTF-8):      Biblioteki poldka
156 Group:          Libraries
157
158 %description libs
159 poldek libraries.
160
161 %description libs -l hu.UTF-8
162 A poldek könyvtárai.
163
164 %description libs -l pl.UTF-8
165 Biblioteki poldka.
166
167 %package devel
168 Summary:        Header files for poldek libraries
169 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
170 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
171 Group:          Development/Libraries
172 Requires:       %{name}-libs = %{version}-%{release}
173 Requires:       rpm-devel >= %{ver_rpm}
174
175 %description devel
176 Header files for poldek libraries.
177
178 %description devel -l hu.UTF-8
179 A poldek könyvtár fejlesztői fájljai.
180
181 %description devel -l pl.UTF-8
182 Pliki nagłówkowe bibliotek poldka.
183
184 %package static
185 Summary:        poldek static libraries
186 Summary(hu.UTF-8):      poldek statikus könyvtárak
187 Summary(pl.UTF-8):      Biblioteki statyczne poldka
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}-%{release}
190
191 %description static
192 poldek static libraries.
193
194 %description static -l hu.UTF-8
195 poldek statikus könyvtárak.
196
197 %description static -l pl.UTF-8
198 Biblioteki statyczne poldka.
199
200 %package -n python-poldek
201 Summary:        Python modules for poldek
202 Summary(hu.UTF-8):      Python modulok poldek-hez
203 Summary(pl.UTF-8):      Moduły języka Python dla poldka
204 Group:          Libraries/Python
205 Requires:       %{name}-libs = %{version}-%{release}
206 Requires:       python-libs
207
208 %description -n python-poldek
209 Python modules for poldek.
210
211 %description -n python-poldek -l hu.UTF-8
212 Python modulok poldek-hez.
213
214 %description -n python-poldek -l pl.UTF-8
215 Moduły języka Python dla poldka.
216
217 %prep
218 %setup -q
219 %patch0 -p1
220 %patch1 -p1
221 %patch2 -p1
222 %patch3 -p1
223 %patch4 -p1
224 %patch5 -p1
225
226 %{__rm} m4/libtool.m4 m4/lt*.m4
227
228 # cleanup backups after patching
229 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
230 chmod u+x ./configure ./doc/conf-xml2.sh
231
232 %build
233 %{__libtoolize}
234 %{__aclocal} -I m4
235 %{__autoheader}
236 %{__autoconf}
237 %{__automake}
238 cd tndb
239 %{__libtoolize}
240 %{__aclocal}
241 %{__autoheader}
242 %{__autoconf}
243 %{__automake}
244 cd ../trurlib
245 %{__libtoolize}
246 %{__aclocal}
247 %{__autoheader}
248 %{__autoconf}
249 %{__automake}
250 cd ..
251
252 CPPFLAGS="%{rpmcppflags} -std=gnu99"
253 %configure \
254         %{?with_static:--enable-static --disable-shared} \
255         %{!?with_imode:--disable-imode} \
256         --with-pkglibdir=%{_libexecdir} \
257         --enable-nls \
258         %{?with_python:--with-python}
259 %{__make} -j1
260 #       --enable-trace
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
265
266 %{__make} install -j1 \
267         DESTDIR=$RPM_BUILD_ROOT
268
269 %if %{with python}
270 %{__make} -C python -j1 install \
271         DESTDIR=$RPM_BUILD_ROOT \
272         libdir=%{py_sitedir}
273 %endif
274
275 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
276
277 %ifarch i486 i686 ppc sparc alpha athlon
278         %define         _ftp_arch       %{_target_cpu}
279 %endif
280 %ifarch %{x8664}
281         %define         _ftp_arch       x86_64
282         %define         _ftp_alt_arch   i686
283 %endif
284 %ifarch i586
285         %define         _ftp_arch       i486
286 %endif
287 %ifarch pentium2 pentium3 pentium4
288         %define         _ftp_arch       i686
289 %endif
290 %ifarch sparcv9 sparc64
291         %define         _ftp_arch       sparc
292         %define         _ftp_arch       %{_target_cpu}
293         %ifarch sparc64
294                 %define         _ftp_alt_arch   sparcv9
295         %endif
296 %endif
297
298 %define pld_conf %{SOURCE1}
299 %define pld_debuginfo_conf %{SOURCE8}
300 %define pld_archive_conf %{SOURCE11}
301
302 %ifarch %{x8664}
303         %define pld_multilib_conf %{SOURCE2}
304 %endif
305
306 # aidath
307 %ifarch sparcv9 sparc64
308         %define pld_conf %{SOURCE9}
309         %undefine pld_archive_conf
310 %endif
311 %ifarch sparc64
312         %define pld_multilib_conf %{SOURCE10}
313 %endif
314
315 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
316
317 %if 0%{?pld_multilib_conf:1}
318         %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
319 %endif
320
321 %if 0%{?pld_debuginfo_conf:1}
322 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
323 %endif
324
325 %if 0%{?pld_archive_conf:1}
326 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
327 %endif
328
329 # Always install snapshot configs
330 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
331         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
332 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
333         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
334 %ifarch %{x8664}
335         %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
336                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
337 %endif
338
339 %if %{with snap}
340 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
341 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
342 %else
343 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
344 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
345 %endif
346
347 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
348
349 %if %{with imode}
350 # add desktop file and icon
351 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
352 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
353 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
354 %endif
355
356 # sources we don't package
357 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
358 # include them in %doc
359 %{__rm} -rf configs
360 cp -a conf configs
361 %{__rm} -f configs/Makefile*
362
363 %if %{with python}
364 %py_postclean
365 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
366 %endif
367
368 %find_lang %{name}
369
370 %clean
371 rm -rf $RPM_BUILD_ROOT
372
373 %post
374 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
375 if [ "$1" = "1" ]; then
376         # remove ignore = vserver-packages inside vserver on first install
377         {
378                 while read f ctx; do
379                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
380                 done </proc/self/status
381         } 2>/dev/null
382         if [ -z "$ctx" -o "$ctx" = "0" ]; then
383                 VSERVER=no
384         else
385                 VSERVER=yes
386         fi
387         if [ "$VSERVER" = "yes" ]; then
388                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
389         fi
390 fi
391
392 %postun -p      /sbin/postshell
393 -/usr/sbin/fix-info-dir -c %{_infodir}
394
395 %post   libs -p /sbin/ldconfig
396 %postun libs -p /sbin/ldconfig
397
398 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
399 if [ -f /etc/poldek.conf.rpmsave ]; then
400         awk '/^source/ {
401         name = $3;
402         path = $4;
403         auto = "yes";
404         autoup = "yes";
405         type = "pdir";
406         pri = "";
407
408         if (sub(",noauto", "", name)) {
409                 auto = "no";
410         }
411
412         # process pri=\d+
413         if (match(name, /,pri=[0-9]+/)) {
414                 pri = substr(name, RSTART + 5, RLENGTH - 5);
415                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
416         }
417
418         # skip ac sources. already in new config.
419         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
420                 print "";
421                 print "[source]";
422                 print "name = " name;
423                 print "type = " type;
424                 print "path = " path;
425                 print "auto = " auto;
426                 print "autoup = " autoup;
427                 if (pri) {
428                         print "pri = " pri;
429                 }
430         }
431
432         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
433         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
434
435         # copy hold=
436         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
437         if [ "$hold" ]; then
438                 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
439         fi
440 fi
441
442 %triggerpostun -- poldek < 0.30-0.20080225.00.1
443 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
444         %{__sed} -i -e '/^%%include source.conf/{
445                 a
446                 a# /etc/poldek/repos.d/*.conf
447                 a%%includedir repos.d
448         }' %{_sysconfdir}/%{name}/poldek.conf
449 fi
450
451 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
452 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
453
454 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
455         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
456         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
457 fi
458
459 %ifarch %{x8664}
460 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
461         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
462         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
463 fi
464 %endif
465
466 %files -f %{name}.lang
467 %defattr(644,root,root,755)
468 %doc ChangeLog README* NEWS TODO configs
469 %dir %{_sysconfdir}/%{name}
470 %dir %{_sysconfdir}/%{name}/repos.d
471 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
472 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
473 %attr(755,root,root) %{_bindir}/ipoldek
474 %attr(755,root,root) %{_bindir}/poldek
475 %attr(755,root,root) %{_bindir}/rpmvercmp
476 %dir %{_libexecdir}
477 %attr(755,root,root) %{_libexecdir}/*
478 %{_mandir}/man1/%{name}*.1*
479 %lang(pl) %{_mandir}/pl/man1/%{name}*
480 %{_infodir}/poldek.info*
481 %if %{with imode}
482 %{_desktopdir}/%{name}.desktop
483 %{_pixmapsdir}/%{name}.png
484 %endif
485 %dir /var/cache/%{name}
486
487 %if %{without static}
488 %files libs
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
491 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
492 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
493 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
494 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
496 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
497 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
498 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
499 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
500 %endif
501
502 %files devel
503 %defattr(644,root,root,755)
504 %if %{without static}
505 %attr(755,root,root) %{_libdir}/libpoclidek.so
506 %attr(755,root,root) %{_libdir}/libpoldek.so
507 %attr(755,root,root) %{_libdir}/libtndb.so
508 %attr(755,root,root) %{_libdir}/libtrurl.so
509 %attr(755,root,root) %{_libdir}/libvfile.so
510 %endif
511 %{_libdir}/libpoclidek.la
512 %{_libdir}/libpoldek.la
513 %{_libdir}/libtndb.la
514 %{_libdir}/libtrurl.la
515 %{_libdir}/libvfile.la
516 %{_includedir}/poldek
517 %{_includedir}/tndb
518 %{_includedir}/trurl
519 %{_includedir}/vfile
520 %{_pkgconfigdir}/tndb.pc
521 %{_pkgconfigdir}/trurlib.pc
522
523 %files static
524 %defattr(644,root,root,755)
525 %{_libdir}/libtndb.a
526 %{_libdir}/libtrurl.a
527
528 %if %{with python}
529 %files -n python-poldek
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
532 %{py_sitescriptdir}/poldek.py[co]
533 %{py_sitescriptdir}/poldekmod.py[co]
534 %endif
This page took 1.191938 seconds and 4 git commands to generate.