]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- RPM 4.2 related stuff
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18.1
11 Release:        4.5
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 Patch0:         %{name}-static.patch
17 Patch1:         %{name}-home_etc.patch
18 URL:            http://team.pld.org.pl/~mis/poldek/
19 Requires:       rpm >= 4.0.2-62
20 Requires:       sed
21 BuildRequires:  bzip2-devel
22 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
23 BuildRequires:  automake
24 BuildRequires:  autoconf
25 BuildRequires:  gettext-autopoint
26 BuildRequires:  openssl-devel >= 0.9.7
27 BuildRequires:  pcre-devel
28 BuildRequires:  popt-devel
29 BuildRequires:  readline-devel
30 BuildRequires:  rpm-devel >= 4.0.2-62
31 BuildRequires:  zlib-devel
32 BuildRequires:  /usr/bin/pod2man
33 %{?_with_static:BuildRequires:  bzip2-static}
34 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
35 %{?_with_static:BuildRequires:  ncurses-static}
36 %{?_with_static:BuildRequires:  openssl-static}
37 %{?_with_static:BuildRequires:  pcre-static}
38 %{?_with_static:BuildRequires:  popt-static}
39 %{?_with_static:BuildRequires:  readline-static}
40 %{?_with_static:BuildRequires:  rpm-static}
41 %{?_with_static:BuildRequires:  zlib-static}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 poldek is an RPM package management tool which allows you to easily
46 perform package verification, installation (including system
47 installation from scratch), upgrading, and removal.
48
49 Program can be used in batch (like apt-get from Debian's APT) or
50 interactive mode. The interactive mode puts you into a readline
51 interface with command line autocompletion and history, similar to the
52 shell mode of Perl's CPAN.
53
54 %{?_with_static:This version is statically linked.}
55
56 %{?_without_imode:This version hasn't got interactive mode.}
57
58 %description -l pl
59 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
60 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
61 i usuwania pakietów.
62
63 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
64 lub interaktywnym. Tryb interaktywny posiada interfejs readline
65 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
66 modu³u CPAN.
67
68 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
69
70 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
71
72 %prep
73 %setup -q
74 %patch0 -p1
75 %patch1 -p1
76
77 %build
78 autopoint --force
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         %{?_with_static:--enable-static} \
84         %{?_without_imode:--disable-imode} \
85         %{?_with_curl:--with-curl}
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_sysconfdir}
91
92 # no strip cause program's beta stage and core may be useful
93 %{__make} install DESTDIR=$RPM_BUILD_ROOT
94 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
95 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
96
97 %find_lang %{name}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files -f %{name}.lang
103 %defattr(644,root,root,755)
104 %doc README* NEWS TODO *sample* conf/poldekrc*
105 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
106 %attr(755,root,root) %{_bindir}/*
107 %{_mandir}/man1/%{name}*
108 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.033898 seconds and 4 git commands to generate.