]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- s/db/db3/ in BuildRequires rules.
[packages/poldek.git] / poldek.spec
1 #
2 # conditional build:
3 #  --with static        - don't use shared libraries
4 #  --without imode      - don't build interactive mode
5 #  --without curl       - don't link curl
6 #
7 Summary:        RPM packages management helper tool
8 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
9 Name:           poldek
10 Version:        0.18
11 Release:        1
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
15 Source1:        %{name}.conf
16 URL:            http://team.pld.org.pl/~mis/poldek/
17 Requires:       rpm >= 4.0.2-62
18 Requires:       sed
19 BuildRequires:  bzip2-devel
20 %{?_with_curl:BuildRequires:    curl-devel >= 7.8}
21 BuildRequires:  db3-devel
22 BuildRequires:  openssl-devel
23 BuildRequires:  pcre-devel
24 BuildRequires:  popt-devel
25 BuildRequires:  readline-devel
26 BuildRequires:  rpm-devel >= 4.0.2-62
27 BuildRequires:  zlib-devel
28 BuildRequires:  /usr/bin/pod2man
29 %{?_with_static:BuildRequires:  bzip2-static}
30 %{?_with_curl:%{?_with_static:BuildRequires:    curl-static}}
31 %{?_with_static:BuildRequires:  openssl-static}
32 %{?_with_static:BuildRequires:  pcre-static}
33 %{?_with_static:BuildRequires:  popt-static}
34 %{?_with_static:BuildRequires:  rpm-static}
35 %{?_with_static:BuildRequires:  zlib-static}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 poldek is an RPM package management tool which allows you to easily
40 perform package verification, installation (including system
41 installation from scratch), upgrading, and removal.
42
43 Program can be used in batch (like apt-get from Debian's APT) or
44 interactive mode. The interactive mode puts you into a readline
45 interface with command line autocompletion and history, similar to the
46 shell mode of Perl's CPAN.
47
48 %{?_with_static:This version is statically linked.}
49
50 %{?_without_imode:This version hasn't got interactive mode.}
51
52 %description -l pl
53 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
54 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
55 i usuwania pakietów.
56
57 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
58 lub interaktywnym. Tryb interaktywny posiada interfejs readline
59 z dope³nianiem komend i histori±, podobny do trybu shell perlowego
60 modu³u CPAN.
61
62 %{?_with_static:Ta wersja jest konsolidowana statycznie.}
63
64 %{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
65
66 %prep
67 %setup -q
68
69 %build
70 if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
71         cp configure.in configure.in.orig
72         sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
73 AM_GNU_GETTEXT_VERSION(0.10.40)/' \
74                 -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
75                 configure.in.orig >configure.in
76         autopoint --force
77 fi
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__automake}
81 %configure \
82         %{?_with_static:--enable-static} \
83         %{?_without_imode:--disable-imode} \
84         %{?_with_curl:--with-curl}
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_sysconfdir}
90
91 # no strip cause program's beta stage and core may be useful
92 %{__make} install DESTDIR=$RPM_BUILD_ROOT
93 %{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
94 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
95
96 %find_lang %{name}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files -f %{name}.lang
102 %defattr(644,root,root,755)
103 %doc README* NEWS TODO *sample* conf/poldekrc*
104 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
105 %attr(755,root,root) %{_bindir}/*
106 %{_mandir}/man1/%{name}*
107 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.043916 seconds and 4 git commands to generate.