]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
requires run-parts
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2014
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         ver_db          4.7.25
27 %define         ver_db_rel      1
28 %define         ver_rpm         4.5-49
29 %else
30 %define         ver_rpm         5.4.10
31 %endif
32
33 %define         rel     8
34 Summary:        RPM packages management helper tool
35 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
36 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
37 Name:           poldek
38 Version:        0.30.1
39 Release:        %{rel}%{?with_snap:.%{SNAP}}
40 License:        GPL v2
41 Group:          Applications/System
42 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
43 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
44 # Source0-md5:  e569c8454df0932df53b09cee9998927
45 Source1:        %{name}.conf
46 Source2:        %{name}-multilib.conf
47 Source5:        %{name}-aliases.conf
48 Source6:        %{name}.desktop
49 Source7:        %{name}.png
50 Source8:        %{name}-debuginfo.conf
51 Source9:        %{name}-aidath.conf
52 Source10:       %{name}-multilib-aidath.conf
53 Source11:       %{name}-archive.conf
54 Source100:      %{name}-snap.conf
55 Source101:      %{name}-multilib-snap.conf
56 Source102:      %{name}-debuginfo-snap.conf
57 Patch0:         %{name}-size-type.patch
58 Patch1:         %{name}-config.patch
59 Patch2:         %{name}-missing-include.patch
60 Patch3:         pm-hooks.patch
61 URL:            http://poldek.pld-linux.org/
62 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
63 BuildRequires:  autoconf
64 BuildRequires:  automake >= 1:1.11
65 BuildRequires:  bzip2-devel
66 BuildRequires:  check-devel
67 BuildRequires:  docbook-dtd412-xml
68 BuildRequires:  gettext-tools
69 BuildRequires:  libtool
70 BuildRequires:  libxml2-devel
71 BuildRequires:  neon-devel
72 BuildRequires:  openssl-devel >= 0.9.7d
73 BuildRequires:  pcre-devel
74 BuildRequires:  pkgconfig
75 BuildRequires:  popt-devel
76 %{?with_python:BuildRequires:   python-devel}
77 BuildRequires:  readline-devel >= 5.0
78 BuildRequires:  rpm-devel >= %{ver_rpm}
79 %{?with_python:BuildRequires:   rpm-pythonprov}
80 BuildRequires:  swig-python
81 BuildRequires:  tar >= 1:1.22
82 BuildRequires:  xmlto
83 BuildRequires:  xz
84 BuildRequires:  zlib-devel
85 %if %{with static}
86 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
87 BuildRequires:  bzip2-static
88 BuildRequires:  glibc-static
89 BuildRequires:  libxml2-static
90 BuildRequires:  ncurses-static
91 BuildRequires:  openssl-static
92 BuildRequires:  pcre-static
93 BuildRequires:  popt-static
94 BuildRequires:  readline-static
95 BuildRequires:  rpm-static
96 BuildRequires:  zlib-static
97 %endif
98 Requires(triggerpostun):        awk
99 Requires(triggerpostun):        sed >= 4.0
100 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
101 Requires:       %{name}-libs = %{version}-%{release}
102 Requires:       /bin/run-parts
103 Requires:       rpm >= %{ver_rpm}
104 Requires:       rpm-db-ver = %{ver_db}
105 Requires:       rpm-lib >= %{ver_rpm}
106 Requires:       sed
107 Conflicts:      etckeeper < 1.18-2
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         _libexecdir     %{_prefix}/lib/%{name}
111
112 %description
113 poldek is an RPM package management tool which allows you to easily
114 perform package verification, installation (including system
115 installation from scratch), upgrading, and removal.
116
117 Program can be used in batch (like apt-get from Debian's APT) or
118 interactive mode. The interactive mode puts you into a readline
119 interface with command line autocompletion and history, similar to the
120 shell mode of Perl's CPAN.
121
122 %{?with_static:This version is statically linked.}
123
124 %{!?with_imode:This version hasn't got interactive mode.}
125 #'vim
126
127 %description -l hu.UTF-8
128 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
129 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
130 nulláról), frissítést és eltávolítást.
131
132 A program használható parancssorból (mint a Debian apt-get programja)
133 vagy interaktív módban. Az interaktív mód egy readline környezetet
134 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
135 shell módjához.
136
137 %{?with_static:Ez a verzió statikusan linkelt.}
138
139 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
140
141 %description -l pl.UTF-8
142 poldek jest narzędziem linii poleceń służącym do weryfikacji,
143 instalacji (włączając instalację systemu od zera), aktualizacji i
144 usuwania pakietów.
145
146 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
147 interaktywnym. Tryb interaktywny posiada interfejs readline z
148 dopełnianiem komend i historią, podobny do trybu shell perlowego
149 modułu CPAN.
150
151 %{?with_static:Ta wersja jest konsolidowana statycznie.}
152
153 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
154
155 %package libs
156 Summary:        poldek libraries
157 Summary(hu.UTF-8):      A poldek könyvtárai
158 Summary(pl.UTF-8):      Biblioteki poldka
159 Group:          Libraries
160
161 %description libs
162 poldek libraries.
163
164 %description libs -l hu.UTF-8
165 A poldek könyvtárai.
166
167 %description libs -l pl.UTF-8
168 Biblioteki poldka.
169
170 %package devel
171 Summary:        Header files for poldek libraries
172 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
173 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
174 Group:          Development/Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176 Requires:       rpm-devel >= %{ver_rpm}
177
178 %description devel
179 Header files for poldek libraries.
180
181 %description devel -l hu.UTF-8
182 A poldek könyvtár fejlesztői fájljai.
183
184 %description devel -l pl.UTF-8
185 Pliki nagłówkowe bibliotek poldka.
186
187 %package static
188 Summary:        poldek static libraries
189 Summary(hu.UTF-8):      poldek statikus könyvtárak
190 Summary(pl.UTF-8):      Biblioteki statyczne poldka
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193
194 %description static
195 poldek static libraries.
196
197 %description static -l hu.UTF-8
198 poldek statikus könyvtárak.
199
200 %description static -l pl.UTF-8
201 Biblioteki statyczne poldka.
202
203 %package -n python-poldek
204 Summary:        Python modules for poldek
205 Summary(hu.UTF-8):      Python modulok poldek-hez
206 Summary(pl.UTF-8):      Moduły języka Python dla poldka
207 Group:          Libraries/Python
208 Requires:       %{name}-libs = %{version}-%{release}
209 Requires:       python-libs
210
211 %description -n python-poldek
212 Python modules for poldek.
213
214 %description -n python-poldek -l hu.UTF-8
215 Python modulok poldek-hez.
216
217 %description -n python-poldek -l pl.UTF-8
218 Moduły języka Python dla poldka.
219
220 %prep
221 %setup -q
222 %patch0 -p1
223 %patch1 -p1
224 %patch2 -p1
225 %patch3 -p1
226
227 %{__rm} m4/libtool.m4 m4/lt*.m4
228
229 # cleanup backups after patching
230 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
231 chmod u+x ./configure ./doc/conf-xml2.sh
232
233 %build
234 %{__gettextize}
235 %{__libtoolize}
236 %{__aclocal} -I m4
237 %{__autoheader}
238 %{__autoconf}
239 %{__automake}
240 cd tndb
241 %{__libtoolize}
242 %{__aclocal}
243 %{__autoheader}
244 %{__autoconf}
245 %{__automake}
246 cd ../trurlib
247 %{__libtoolize}
248 %{__aclocal}
249 %{__autoheader}
250 %{__autoconf}
251 %{__automake}
252 cd ..
253
254 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
255 %configure \
256         %{?with_static:--enable-static --disable-shared} \
257         %{!?with_imode:--disable-imode} \
258         --with-pkglibdir=%{_libexecdir} \
259         --enable-nls \
260         %{?with_python:--with-python}
261 %{__make} -j1
262 #       --enable-trace
263
264 %install
265 rm -rf $RPM_BUILD_ROOT
266 install -d $RPM_BUILD_ROOT/var/cache/%{name}
267
268 %{__make} install -j1 \
269         DESTDIR=$RPM_BUILD_ROOT
270
271 %if %{with python}
272 %{__make} -C python -j1 install \
273         DESTDIR=$RPM_BUILD_ROOT \
274         libdir=%{py_sitedir}
275 %endif
276
277 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
278
279 %ifarch i486 i686 ppc sparc alpha athlon
280         %define         ftp_arch        %{_target_cpu}
281 %endif
282 %ifarch %{x8664}
283         %define         ftp_arch        x86_64
284         %define         ftp_alt_arch    i686
285         %define         ftp_alt2_arch   x32
286 %endif
287 %ifarch x32
288         %define         ftp_arch        x32
289         %define         ftp_alt_arch    x86_64
290         %define         ftp_alt2_arch   i686
291 %endif
292 %ifarch i586
293         %define         ftp_arch        i486
294 %endif
295 %ifarch pentium2 pentium3 pentium4
296         %define         ftp_arch        i686
297 %endif
298 %ifarch sparcv9 sparc64
299         %define         ftp_arch        sparc
300         %define         ftp_arch        %{_target_cpu}
301         %ifarch sparc64
302                 %define         ftp_alt_arch    sparcv9
303         %endif
304 %endif
305
306 %define pld_conf %{SOURCE1}
307 %define pld_debuginfo_conf %{SOURCE8}
308 %define pld_archive_conf %{SOURCE11}
309
310 %ifarch %{x8664} x32
311         %define pld_multilib_conf %{SOURCE2}
312         %define pld_multilib2_conf %{SOURCE2}
313 %endif
314
315 # aidath
316 %ifarch sparcv9 sparc64
317         %define pld_conf %{SOURCE9}
318         %undefine pld_archive_conf
319 %endif
320 %ifarch sparc64
321         %define pld_multilib_conf %{SOURCE10}
322 %endif
323
324 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
325
326 %if 0%{?pld_multilib_conf:1}
327         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
328 %endif
329
330 %if 0%{?pld_multilib2_conf:1}
331         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
332 %endif
333
334 %if 0%{?pld_debuginfo_conf:1}
335 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
336 %endif
337
338 %if 0%{?pld_archive_conf:1}
339 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
340 %endif
341
342 # Always install snapshot configs
343 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
344         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
345 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
346         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
347 %ifarch %{x8664} x32
348         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
349                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
350         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
351                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
352 %endif
353
354 %if %{with snap}
355 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
356 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
357 %else
358 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
359 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
360 %endif
361
362 # create "all" meta repo
363 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
364 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
365 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
366 [source]
367 type    = group
368 name    = th-all
369 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
370 EOF
371 %endif
372
373 # th-2014 snap does not exist for x32 yet
374 %if "%{ftp_arch}" == "x32"
375 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
376 %endif
377 %if "%{ftp_alt2_arch}" == "x32"
378 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
379 %endif
380
381 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
382
383 %if %{with imode}
384 # add desktop file and icon
385 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
386 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
387 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
388 %endif
389
390 # sources we don't package
391 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
392 # include them in %doc
393 %{__rm} -rf configs
394 cp -a conf configs
395 %{__rm} -f configs/Makefile*
396
397 %if %{with python}
398 %py_postclean
399 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
400 %endif
401
402 %find_lang %{name}
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %post
408 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
409 if [ "$1" = "1" ]; then
410         # remove ignore = vserver-packages inside vserver on first install
411         {
412                 while read f ctx; do
413                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
414                 done </proc/self/status
415         } 2>/dev/null
416         if [ -z "$ctx" -o "$ctx" = "0" ]; then
417                 VSERVER=no
418         else
419                 VSERVER=yes
420         fi
421         if [ "$VSERVER" = "yes" ]; then
422                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
423         fi
424 fi
425
426 %postun -p      /sbin/postshell
427 -/usr/sbin/fix-info-dir -c %{_infodir}
428
429 %post   libs -p /sbin/ldconfig
430 %postun libs -p /sbin/ldconfig
431
432 %triggerpostun -- poldek < 0.30-0.20080225.00.1
433 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
434         %{__sed} -i -e '/^%%include source.conf/{
435                 a
436                 a# /etc/poldek/repos.d/*.conf
437                 a%%includedir repos.d
438         }' %{_sysconfdir}/%{name}/poldek.conf
439 fi
440
441 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
442 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
443
444 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
445         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
446         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
447 fi
448
449 %ifarch %{x8664}
450 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
451         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
452         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
453 fi
454 %endif
455
456 %triggerpostun -- poldek < 0.30.1-3
457 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
458         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
459         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
460 fi
461 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
462         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
463         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
464 fi
465
466 %triggerpostun -- %{name} < 0.30.1-8
467 if [ $1 -le 1 ]; then
468         # revert change on  --downgrade
469         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
470 else
471         # setup pm command
472         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
473 fi
474
475 %files -f %{name}.lang
476 %defattr(644,root,root,755)
477 %doc ChangeLog README* NEWS TODO configs
478 %dir %{_sysconfdir}/%{name}
479 %dir %{_sysconfdir}/%{name}/pre-install.d
480 %{_sysconfdir}/%{name}/pre-install.d/README
481 %dir %{_sysconfdir}/%{name}/post-install.d
482 %{_sysconfdir}/%{name}/post-install.d/README
483 %dir %{_sysconfdir}/%{name}/repos.d
484 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
486 %attr(755,root,root) %{_bindir}/ipoldek
487 %attr(755,root,root) %{_bindir}/poldek
488 %attr(755,root,root) %{_bindir}/rpmvercmp
489 %dir %{_libexecdir}
490 %attr(755,root,root) %{_libexecdir}/pm-command.sh
491 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
492 %attr(755,root,root) %{_libexecdir}/vfcompr
493 %attr(755,root,root) %{_libexecdir}/vfjuggle
494 %attr(755,root,root) %{_libexecdir}/vfsmb
495 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
496 %{_mandir}/man1/%{name}*.1*
497 %lang(pl) %{_mandir}/pl/man1/%{name}*
498 %{_infodir}/poldek.info*
499 %if %{with imode}
500 %{_desktopdir}/%{name}.desktop
501 %{_pixmapsdir}/%{name}.png
502 %endif
503 %dir /var/cache/%{name}
504
505 %if %{without static}
506 %files libs
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
509 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
510 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
511 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
512 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
513 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
514 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
515 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
516 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
517 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
518 %endif
519
520 %files devel
521 %defattr(644,root,root,755)
522 %if %{without static}
523 %attr(755,root,root) %{_libdir}/libpoclidek.so
524 %attr(755,root,root) %{_libdir}/libpoldek.so
525 %attr(755,root,root) %{_libdir}/libtndb.so
526 %attr(755,root,root) %{_libdir}/libtrurl.so
527 %attr(755,root,root) %{_libdir}/libvfile.so
528 %endif
529 %{_libdir}/libpoclidek.la
530 %{_libdir}/libpoldek.la
531 %{_libdir}/libtndb.la
532 %{_libdir}/libtrurl.la
533 %{_libdir}/libvfile.la
534 %{_includedir}/poldek
535 %{_includedir}/tndb
536 %{_includedir}/trurl
537 %{_includedir}/vfile
538 %{_pkgconfigdir}/tndb.pc
539 %{_pkgconfigdir}/trurlib.pc
540
541 %files static
542 %defattr(644,root,root,755)
543 %{_libdir}/libtndb.a
544 %{_libdir}/libtrurl.a
545
546 %if %{with python}
547 %files -n python-poldek
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
550 %{py_sitescriptdir}/poldek.py[co]
551 %{py_sitescriptdir}/poldekmod.py[co]
552 %endif
This page took 0.065507 seconds and 4 git commands to generate.