]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
8987f2fe0319ce03dc4cfc0bc82b5bfecb206c5b
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2015
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         db_pkg          db4.7
27 %define         ver_db          4.7.25
28 %define         ver_db_rel      1
29 %define         ver_rpm         4.5-49
30 %else
31 %define         ver_rpm         5.4.10
32 %endif
33
34 %define         rel     13
35 Summary:        RPM packages management helper tool
36 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
37 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
38 Name:           poldek
39 Version:        0.30.1
40 Release:        %{rel}%{?with_snap:.%{SNAP}}
41 License:        GPL v2
42 Group:          Applications/System
43 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
44 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
45 # Source0-md5:  e569c8454df0932df53b09cee9998927
46 Source1:        %{name}.conf
47 Source2:        %{name}-multilib.conf
48 Source5:        %{name}-aliases.conf
49 Source6:        %{name}.desktop
50 Source7:        %{name}.png
51 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
52 Source8:        %{name}-debuginfo.conf
53 Source9:        %{name}-aidath.conf
54 Source10:       %{name}-multilib-aidath.conf
55 Source11:       %{name}-archive.conf
56 Source100:      %{name}-snap.conf
57 Source101:      %{name}-multilib-snap.conf
58 Source102:      %{name}-debuginfo-snap.conf
59 Patch0:         %{name}-size-type.patch
60 Patch1:         %{name}-config.patch
61 Patch2:         %{name}-missing-include.patch
62 Patch3:         pm-hooks.patch
63 Patch4:         %{name}-setenv-null.patch
64 Patch5:         %{name}-assert-sigint.patch
65 Patch6:         %{name}-upgrade-orphan.patch
66 URL:            http://poldek.pld-linux.org/
67 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
68 BuildRequires:  autoconf
69 BuildRequires:  automake >= 1:1.11
70 BuildRequires:  bzip2-devel
71 BuildRequires:  check-devel
72 BuildRequires:  docbook-dtd412-xml
73 BuildRequires:  gettext-tools
74 BuildRequires:  libgomp-devel
75 BuildRequires:  libtool
76 BuildRequires:  libxml2-devel
77 BuildRequires:  openssl-devel >= 0.9.7d
78 BuildRequires:  pcre-devel
79 BuildRequires:  pkgconfig
80 BuildRequires:  popt-devel
81 %{?with_python:BuildRequires:   python-devel}
82 BuildRequires:  readline-devel >= 5.0
83 BuildRequires:  rpm-devel >= %{ver_rpm}
84 %{?with_python:BuildRequires:   rpm-pythonprov}
85 BuildRequires:  tar >= 1:1.22
86 BuildRequires:  xmlto
87 BuildRequires:  xz
88 BuildRequires:  zlib-devel
89 %if %{with static}
90 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
91 BuildRequires:  bzip2-static
92 BuildRequires:  glibc-static
93 BuildRequires:  libxml2-static
94 BuildRequires:  ncurses-static
95 BuildRequires:  openssl-static
96 BuildRequires:  pcre-static
97 BuildRequires:  popt-static
98 BuildRequires:  readline-static
99 BuildRequires:  rpm-static
100 BuildRequires:  zlib-static
101 %endif
102 Requires(triggerpostun):        awk
103 Requires(triggerpostun):        sed >= 4.0
104 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       /bin/run-parts
107 Requires:       rpm >= %{ver_rpm}
108 Requires:       rpm-db-ver = %{ver_db}
109 Requires:       rpm-lib >= %{ver_rpm}
110 Requires:       sed
111 Conflicts:      etckeeper < 1.18-2
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _libexecdir     %{_prefix}/lib/%{name}
115
116 %description
117 poldek is an RPM package management tool which allows you to easily
118 perform package verification, installation (including system
119 installation from scratch), upgrading, and removal.
120
121 Program can be used in batch (like apt-get from Debian's APT) or
122 interactive mode. The interactive mode puts you into a readline
123 interface with command line autocompletion and history, similar to the
124 shell mode of Perl's CPAN.
125
126 %{?with_static:This version is statically linked.}
127
128 %{!?with_imode:This version hasn't got interactive mode.}
129 #'vim
130
131 %description -l hu.UTF-8
132 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134 nulláról), frissítést és eltávolítást.
135
136 A program használható parancssorból (mint a Debian apt-get programja)
137 vagy interaktív módban. Az interaktív mód egy readline környezetet
138 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139 shell módjához.
140
141 %{?with_static:Ez a verzió statikusan linkelt.}
142
143 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
145 %description -l pl.UTF-8
146 poldek jest narzędziem linii poleceń służącym do weryfikacji,
147 instalacji (włączając instalację systemu od zera), aktualizacji i
148 usuwania pakietów.
149
150 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
151 interaktywnym. Tryb interaktywny posiada interfejs readline z
152 dopełnianiem komend i historią, podobny do trybu shell perlowego
153 modułu CPAN.
154
155 %{?with_static:Ta wersja jest konsolidowana statycznie.}
156
157 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
158
159 %package libs
160 Summary:        poldek libraries
161 Summary(hu.UTF-8):      A poldek könyvtárai
162 Summary(pl.UTF-8):      Biblioteki poldka
163 Group:          Libraries
164
165 %description libs
166 poldek libraries.
167
168 %description libs -l hu.UTF-8
169 A poldek könyvtárai.
170
171 %description libs -l pl.UTF-8
172 Biblioteki poldka.
173
174 %package devel
175 Summary:        Header files for poldek libraries
176 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
177 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
178 Group:          Development/Libraries
179 Requires:       %{name}-libs = %{version}-%{release}
180 Requires:       rpm-devel >= %{ver_rpm}
181
182 %description devel
183 Header files for poldek libraries.
184
185 %description devel -l hu.UTF-8
186 A poldek könyvtár fejlesztői fájljai.
187
188 %description devel -l pl.UTF-8
189 Pliki nagłówkowe bibliotek poldka.
190
191 %package static
192 Summary:        poldek static libraries
193 Summary(hu.UTF-8):      poldek statikus könyvtárak
194 Summary(pl.UTF-8):      Biblioteki statyczne poldka
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197
198 %description static
199 poldek static libraries.
200
201 %description static -l hu.UTF-8
202 poldek statikus könyvtárak.
203
204 %description static -l pl.UTF-8
205 Biblioteki statyczne poldka.
206
207 %package -n python-poldek
208 Summary:        Python modules for poldek
209 Summary(hu.UTF-8):      Python modulok poldek-hez
210 Summary(pl.UTF-8):      Moduły języka Python dla poldka
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{version}-%{release}
213 Requires:       python-libs
214
215 %description -n python-poldek
216 Python modules for poldek.
217
218 %description -n python-poldek -l hu.UTF-8
219 Python modulok poldek-hez.
220
221 %description -n python-poldek -l pl.UTF-8
222 Moduły języka Python dla poldka.
223
224 %prep
225 %setup -q
226 %patch0 -p1
227 %patch1 -p1
228 %patch2 -p1
229 %patch3 -p1
230 %patch4 -p1
231 %patch5 -p1
232 %patch6 -p1
233
234 %{__rm} m4/libtool.m4 m4/lt*.m4
235
236 # cleanup backups after patching
237 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
238 chmod u+x ./configure ./doc/conf-xml2.sh
239
240 %build
241 %{__gettextize}
242 %{__libtoolize}
243 %{__aclocal} -I m4
244 %{__autoheader}
245 %{__autoconf}
246 %{__automake}
247 cd tndb
248 %{__libtoolize}
249 %{__aclocal}
250 %{__autoheader}
251 %{__autoconf}
252 %{__automake}
253 cd ../trurlib
254 %{__libtoolize}
255 %{__aclocal}
256 %{__autoheader}
257 %{__autoconf}
258 %{__automake}
259 cd ..
260
261 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
262 %configure \
263         %{?with_static:--enable-static --disable-shared} \
264         %{!?with_imode:--disable-imode} \
265         --with-pkglibdir=%{_libexecdir} \
266         --enable-nls \
267         %{?with_python:--with-python}
268 %{__make} -j1
269 #       --enable-trace
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273 install -d $RPM_BUILD_ROOT/var/cache/%{name}
274
275 %{__make} install -j1 \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 %if %{with python}
279 %{__make} -C python -j1 install \
280         DESTDIR=$RPM_BUILD_ROOT \
281         libdir=%{py_sitedir}
282 %endif
283
284 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
285
286 %ifarch i486 i686 ppc sparc alpha athlon
287         %define         ftp_arch        %{_target_cpu}
288 %endif
289 %ifarch %{x8664}
290         %define         ftp_arch        x86_64
291         %define         ftp_alt_arch    i686
292         %define         ftp_alt2_arch   x32
293 %endif
294 %ifarch x32
295         %define         ftp_arch        x32
296         %define         ftp_alt_arch    x86_64
297         %define         ftp_alt2_arch   i686
298 %endif
299 %ifarch i586
300         %define         ftp_arch        i486
301 %endif
302 %ifarch pentium2 pentium3 pentium4
303         %define         ftp_arch        i686
304 %endif
305 %ifarch sparcv9 sparc64
306         %define         ftp_arch        sparc
307         %define         ftp_arch        %{_target_cpu}
308         %ifarch sparc64
309                 %define         ftp_alt_arch    sparcv9
310         %endif
311 %endif
312
313 %define pld_conf %{SOURCE1}
314 %define pld_debuginfo_conf %{SOURCE8}
315 %define pld_archive_conf %{SOURCE11}
316
317 %ifarch %{x8664} x32
318         %define pld_multilib_conf %{SOURCE2}
319         %define pld_multilib2_conf %{SOURCE2}
320 %endif
321
322 # aidath
323 %ifarch sparcv9 sparc64
324         %define pld_conf %{SOURCE9}
325         %undefine pld_archive_conf
326 %endif
327 %ifarch sparc64
328         %define pld_multilib_conf %{SOURCE10}
329 %endif
330
331 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
332
333 %if 0%{?pld_multilib_conf:1}
334         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
335 %endif
336
337 %if 0%{?pld_multilib2_conf:1}
338         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
339 %endif
340
341 %if 0%{?pld_debuginfo_conf:1}
342 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
343 %endif
344
345 %if 0%{?pld_archive_conf:1}
346 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
347 %endif
348
349 # Always install snapshot configs
350 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
351         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
352 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
353         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
354 %ifarch %{x8664} x32
355         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
356                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
357         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
358                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
359 %endif
360
361 %if %{with snap}
362 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
363 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
364 %else
365 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
366 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
367 %endif
368
369 # create "all" meta repo
370 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
371 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
372 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
373 [source]
374 type    = group
375 name    = th-all
376 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
377 EOF
378 %endif
379
380 # th-2014 snap does not exist for x32 yet
381 %if "%{ftp_arch}" == "x32"
382 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
383 %endif
384 %if "%{ftp_alt2_arch}" == "x32"
385 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
386 %endif
387
388 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
389
390 %if %{with imode}
391 # add desktop file and icon
392 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
393 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
394 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
395 %endif
396
397 # sources we don't package
398 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
399 # include them in %doc
400 %{__rm} -rf configs
401 cp -a conf configs
402 %{__rm} -f configs/Makefile*
403
404 %if %{with python}
405 %py_postclean
406 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
407 %endif
408
409 %find_lang %{name}
410
411 %clean
412 rm -rf $RPM_BUILD_ROOT
413
414 %post
415 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
416 if [ "$1" = "1" ]; then
417         # remove ignore = vserver-packages inside vserver on first install
418         {
419                 while read f ctx; do
420                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
421                 done </proc/self/status
422         } 2>/dev/null
423         if [ -z "$ctx" -o "$ctx" = "0" ]; then
424                 VSERVER=no
425         else
426                 VSERVER=yes
427         fi
428         if [ "$VSERVER" = "yes" ]; then
429                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
430         fi
431 fi
432
433 %postun -p      /sbin/postshell
434 -/usr/sbin/fix-info-dir -c %{_infodir}
435
436 %post   libs -p /sbin/ldconfig
437 %postun libs -p /sbin/ldconfig
438
439 %triggerpostun -- poldek < 0.30-0.20080225.00.1
440 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
441         %{__sed} -i -e '/^%%include source.conf/{
442                 a
443                 a# /etc/poldek/repos.d/*.conf
444                 a%%includedir repos.d
445         }' %{_sysconfdir}/%{name}/poldek.conf
446 fi
447
448 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
449 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
450
451 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
452         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
453         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
454 fi
455
456 %ifarch %{x8664}
457 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
458         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
459         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
460 fi
461 %endif
462
463 %triggerpostun -- poldek < 0.30.1-3
464 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
465         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
466         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
467 fi
468 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
469         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
470         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
471 fi
472
473 %triggerpostun -- %{name} < 0.30.1-8
474 if [ $1 -le 1 ]; then
475         # revert change on  --downgrade
476         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
477 else
478         # setup pm command
479         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
480 fi
481
482 %files -f %{name}.lang
483 %defattr(644,root,root,755)
484 %doc ChangeLog README* NEWS TODO configs
485 %dir %{_sysconfdir}/%{name}
486 %dir %{_sysconfdir}/%{name}/pre-install.d
487 %{_sysconfdir}/%{name}/pre-install.d/README
488 %dir %{_sysconfdir}/%{name}/post-install.d
489 %{_sysconfdir}/%{name}/post-install.d/README
490 %dir %{_sysconfdir}/%{name}/repos.d
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
492 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
493 %attr(755,root,root) %{_bindir}/ipoldek
494 %attr(755,root,root) %{_bindir}/poldek
495 %attr(755,root,root) %{_bindir}/rpmvercmp
496 %dir %{_libexecdir}
497 %attr(755,root,root) %{_libexecdir}/pm-command.sh
498 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
499 %attr(755,root,root) %{_libexecdir}/vfcompr
500 %attr(755,root,root) %{_libexecdir}/vfjuggle
501 %attr(755,root,root) %{_libexecdir}/vfsmb
502 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
503 %{_mandir}/man1/%{name}*.1*
504 %lang(pl) %{_mandir}/pl/man1/%{name}*
505 %{_infodir}/poldek.info*
506 %if %{with imode}
507 %{_desktopdir}/%{name}.desktop
508 %{_pixmapsdir}/%{name}.png
509 %endif
510 %dir /var/cache/%{name}
511
512 %if %{without static}
513 %files libs
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
516 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
517 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
518 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
519 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
520 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
521 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
522 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
523 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
524 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
525 %endif
526
527 %files devel
528 %defattr(644,root,root,755)
529 %if %{without static}
530 %attr(755,root,root) %{_libdir}/libpoclidek.so
531 %attr(755,root,root) %{_libdir}/libpoldek.so
532 %attr(755,root,root) %{_libdir}/libtndb.so
533 %attr(755,root,root) %{_libdir}/libtrurl.so
534 %attr(755,root,root) %{_libdir}/libvfile.so
535 %endif
536 %{_libdir}/libpoclidek.la
537 %{_libdir}/libpoldek.la
538 %{_libdir}/libtndb.la
539 %{_libdir}/libtrurl.la
540 %{_libdir}/libvfile.la
541 %{_includedir}/poldek
542 %{_includedir}/tndb
543 %{_includedir}/trurl
544 %{_includedir}/vfile
545 %{_pkgconfigdir}/tndb.pc
546 %{_pkgconfigdir}/trurlib.pc
547
548 %files static
549 %defattr(644,root,root,755)
550 %{_libdir}/libtndb.a
551 %{_libdir}/libtrurl.a
552
553 %if %{with python}
554 %files -n python-poldek
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
557 %{py_sitescriptdir}/poldek.py[co]
558 %{py_sitescriptdir}/poldekmod.py[co]
559 %endif
This page took 0.066478 seconds and 3 git commands to generate.