]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
393a9ba8ee1a663df48a816f68ed4a5972008f45
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     rpm4    # use rpm4 instead of rpm5
11 %bcond_without  tests   # tests
12
13 # current snapshot name
14 %define         SNAP    2019
15
16 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17 %if %{with rpm4}
18 %define         db_pkg          db
19 %define         ver_db          5.3
20 %define         ver_rpm         1:4.14
21 %define         ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
22 %else
23 %define         ver_db          %(rpm -q --provides rpm | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
24 %define         db_pkg          db%{ver_db}
25 %define         ver_rpm         5.4.10
26 %endif
27
28 %define         rel     1
29 Summary:        RPM packages management helper tool
30 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
31 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
32 Name:           poldek
33 Version:        0.42.0
34 Release:        %{rel}%{?with_snap:.%{SNAP}}
35 License:        GPL v2
36 Group:          Applications/System
37 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
38 Source0:        https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
39 # Source0-md5:  f224a4f62cdedf0d8bcfe0ce6dd533b2
40 Source1:        %{name}.conf
41 Source2:        %{name}-multilib.conf
42 Source3:        %{name}-config.sh
43 Source5:        %{name}-aliases.conf
44 Source6:        %{name}.desktop
45 Source7:        %{name}.png
46 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
47 Source8:        %{name}-debuginfo.conf
48 Source9:        %{name}-aidath.conf
49 Source10:       %{name}-multilib-aidath.conf
50 Source11:       %{name}-archive.conf
51 Source100:      %{name}-snap.conf
52 Source101:      %{name}-multilib-snap.conf
53 Source102:      %{name}-debuginfo-snap.conf
54 Patch0:         %{name}-config.patch
55 Patch1:         pm-hooks.patch
56 Patch2:         %{name}-ext-down-enable.patch
57 Patch3:         %{name}-pc.patch
58 URL:            http://poldek.pld-linux.org/
59 BuildRequires:  %{db_pkg}-devel >= %{ver_db}
60 BuildRequires:  autoconf >= 2.63
61 BuildRequires:  automake >= 1:1.11
62 BuildRequires:  bzip2-devel
63 BuildRequires:  check-devel
64 BuildRequires:  docbook-dtd412-xml
65 BuildRequires:  gettext-tools >= 0.11.5
66 BuildRequires:  libgomp-devel
67 BuildRequires:  libtool
68 BuildRequires:  libxml2-devel >= 2
69 BuildRequires:  ncurses-devel
70 BuildRequires:  openssl-devel >= 0.9.7d
71 BuildRequires:  pcre-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  popt-devel
74 %{?with_python:BuildRequires:   python-devel}
75 BuildRequires:  readline-devel >= 5.0
76 BuildRequires:  rpm >= %{ver_rpm}
77 BuildRequires:  rpm-devel >= %{ver_rpm}
78 %{?with_python:BuildRequires:   rpm-pythonprov}
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xmlto
81 BuildRequires:  xz
82 BuildRequires:  zlib-devel
83 BuildRequires:  zstd-devel
84 %if %{with static}
85 BuildRequires:  %{db_pkg}-static >= %{ver_db}
86 BuildRequires:  bzip2-static
87 BuildRequires:  glibc-static
88 BuildRequires:  libxml2-static
89 BuildRequires:  ncurses-static
90 BuildRequires:  openssl-static
91 BuildRequires:  pcre-static
92 BuildRequires:  popt-static
93 BuildRequires:  readline-static
94 BuildRequires:  rpm-static
95 BuildRequires:  zlib-static
96 BuildRequires:  zstd-static
97 %endif
98 Requires(triggerpostun):        awk
99 Requires(triggerpostun):        sed >= 4.0
100 %if %{with rpm4}
101 Requires:       %{db_pkg} >= %{ver_db_devel}
102 %else
103 Requires:       %{db_pkg} >= %{ver_db}
104 Requires:       rpm-db-ver = %{ver_db}
105 %endif
106 Requires:       %{name}-libs = %{version}-%{release}
107 Requires:       /bin/run-parts
108 Requires:       rpm >= %{ver_rpm}
109 Requires:       rpm-lib >= %{ver_rpm}
110 Requires:       sed
111 Conflicts:      etckeeper < 1.18-2
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _libexecdir     %{_prefix}/lib/%{name}
115
116 %description
117 poldek is an RPM package management tool which allows you to easily
118 perform package verification, installation (including system
119 installation from scratch), upgrading, and removal.
120
121 Program can be used in batch (like apt-get from Debian's APT) or
122 interactive mode. The interactive mode puts you into a readline
123 interface with command line autocompletion and history, similar to the
124 shell mode of Perl's CPAN.
125
126 %{?with_static:This version is statically linked.}
127
128 %{!?with_imode:This version hasn't got interactive mode.}
129 #'vim
130
131 %description -l hu.UTF-8
132 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134 nulláról), frissítést és eltávolítást.
135
136 A program használható parancssorból (mint a Debian apt-get programja)
137 vagy interaktív módban. Az interaktív mód egy readline környezetet
138 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139 shell módjához.
140
141 %{?with_static:Ez a verzió statikusan linkelt.}
142
143 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
145 %description -l pl.UTF-8
146 poldek jest narzędziem linii poleceń służącym do weryfikacji,
147 instalacji (włączając instalację systemu od zera), aktualizacji i
148 usuwania pakietów.
149
150 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
151 interaktywnym. Tryb interaktywny posiada interfejs readline z
152 dopełnianiem komend i historią, podobny do trybu shell perlowego
153 modułu CPAN.
154
155 %{?with_static:Ta wersja jest konsolidowana statycznie.}
156
157 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
158
159 %package libs
160 Summary:        poldek libraries
161 Summary(hu.UTF-8):      A poldek könyvtárai
162 Summary(pl.UTF-8):      Biblioteki poldka
163 Group:          Libraries
164
165 %description libs
166 poldek libraries.
167
168 %description libs -l hu.UTF-8
169 A poldek könyvtárai.
170
171 %description libs -l pl.UTF-8
172 Biblioteki poldka.
173
174 %package devel
175 Summary:        Header files for poldek libraries
176 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
177 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
178 Group:          Development/Libraries
179 Requires:       %{name}-libs = %{version}-%{release}
180 Requires:       rpm-devel >= %{ver_rpm}
181
182 %description devel
183 Header files for poldek libraries.
184
185 %description devel -l hu.UTF-8
186 A poldek könyvtár fejlesztői fájljai.
187
188 %description devel -l pl.UTF-8
189 Pliki nagłówkowe bibliotek poldka.
190
191 %package static
192 Summary:        poldek static libraries
193 Summary(hu.UTF-8):      poldek statikus könyvtárak
194 Summary(pl.UTF-8):      Biblioteki statyczne poldka
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197
198 %description static
199 poldek static libraries.
200
201 %description static -l hu.UTF-8
202 poldek statikus könyvtárak.
203
204 %description static -l pl.UTF-8
205 Biblioteki statyczne poldka.
206
207 %package -n python-poldek
208 Summary:        Python modules for poldek
209 Summary(hu.UTF-8):      Python modulok poldek-hez
210 Summary(pl.UTF-8):      Moduły języka Python dla poldka
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{version}-%{release}
213 Requires:       python-libs
214
215 %description -n python-poldek
216 Python modules for poldek.
217
218 %description -n python-poldek -l hu.UTF-8
219 Python modulok poldek-hez.
220
221 %description -n python-poldek -l pl.UTF-8
222 Moduły języka Python dla poldka.
223
224 %prep
225 %setup -q
226 %patch0 -p1
227 %patch1 -p1
228 %patch2 -p1
229 %patch3 -p1
230
231 %{__rm} m4/libtool.m4 m4/lt*.m4
232
233 # cleanup backups after patching
234 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
235 chmod u+x ./configure ./doc/conf-xml2.sh
236
237 %build
238 %{__gettextize}
239 %{__libtoolize}
240 %{__aclocal} -I m4
241 %{__autoheader}
242 %{__autoconf}
243 %{__automake}
244 cd tndb
245 %{__libtoolize}
246 %{__aclocal}
247 %{__autoheader}
248 %{__autoconf}
249 %{__automake}
250 cd ../trurlib
251 %{__libtoolize}
252 %{__aclocal}
253 %{__autoheader}
254 %{__autoconf}
255 %{__automake}
256 cd ..
257
258 %configure \
259         %{?with_static:--enable-static --disable-shared} \
260         %{!?with_imode:--disable-imode} \
261         --with-pkglibdir=%{_libexecdir} \
262         --enable-nls \
263         %{?with_python:--with-python}
264 %{__make}
265 #       --enable-trace
266
267 %if %{with python}
268 %{__make} -C python
269 %endif
270
271 %if %{with tests}
272 %{__make} check
273 %endif
274
275 %install
276 rm -rf $RPM_BUILD_ROOT
277 install -d $RPM_BUILD_ROOT/var/cache/%{name}
278
279 %{__make} install \
280         DESTDIR=$RPM_BUILD_ROOT
281
282 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
283
284 %if %{with python}
285 %{__make} -C python install \
286         DESTDIR=$RPM_BUILD_ROOT \
287         py_sitedir=%{py_sitedir}
288 %endif
289
290 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
291
292 %ifarch i486 i686 ppc sparc alpha athlon
293         %define         ftp_arch        %{_target_cpu}
294 %endif
295 %ifarch %{x8664}
296         %define         ftp_arch        x86_64
297         %define         ftp_alt_arch    i686
298         %define         ftp_alt2_arch   x32
299 %endif
300 %ifarch x32
301         %define         ftp_arch        x32
302         %define         ftp_alt_arch    x86_64
303         %define         ftp_alt2_arch   i686
304 %endif
305 %ifarch i586
306         %define         ftp_arch        i486
307 %endif
308 %ifarch pentium2 pentium3 pentium4
309         %define         ftp_arch        i686
310 %endif
311 %ifarch sparcv9 sparc64
312         %define         ftp_arch        sparc
313         %define         ftp_arch        %{_target_cpu}
314         %ifarch sparc64
315                 %define         ftp_alt_arch    sparcv9
316         %endif
317 %endif
318
319 %define pld_conf %{SOURCE1}
320 %define pld_debuginfo_conf %{SOURCE8}
321 %define pld_archive_conf %{SOURCE11}
322
323 %ifarch %{x8664} x32
324         %define pld_multilib_conf %{SOURCE2}
325         %define pld_multilib2_conf %{SOURCE2}
326 %endif
327
328 # aidath
329 %ifarch sparcv9 sparc64
330         %define pld_conf %{SOURCE9}
331         %undefine pld_archive_conf
332 %endif
333 %ifarch sparc64
334         %define pld_multilib_conf %{SOURCE10}
335 %endif
336
337 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
338
339 %if 0%{?pld_multilib_conf:1}
340         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
341 %endif
342
343 %if 0%{?pld_multilib2_conf:1}
344         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
345 %endif
346
347 %if 0%{?pld_debuginfo_conf:1}
348 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
349 %endif
350
351 %if 0%{?pld_archive_conf:1}
352 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
353 %endif
354
355 # Always install snapshot configs
356 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
357         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
358 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
359         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
360 %ifarch %{x8664} x32
361         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
362                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
363         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
364                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
365 %endif
366
367 %if %{with snap}
368 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
369 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
370 %else
371 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
372 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
373 %endif
374
375 # create "all" meta repo
376 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
377 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
378 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
379 [source]
380 type    = group
381 name    = th-all
382 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
383 EOF
384 %endif
385
386 # th-2014 snap does not exist for x32 yet
387 %if "%{ftp_arch}" == "x32"
388 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
389 %endif
390 %if "%{ftp_alt2_arch}" == "x32"
391 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
392 %endif
393
394 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
395
396 %if %{with imode}
397 # add desktop file and icon
398 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
399 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
400 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
401 %endif
402
403 # sources we don't package
404 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
405 # include them in %doc
406 %{__rm} -rf configs
407 cp -a conf configs
408 %{__rm} -f configs/Makefile*
409
410 %if %{with python}
411 %py_postclean
412 %{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
413 %endif
414
415 %find_lang %{name}
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post
421 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
422 if [ "$1" = "1" ]; then
423         # remove ignore = vserver-packages inside vserver on first install
424         {
425                 while read f ctx; do
426                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
427                 done </proc/self/status
428         } 2>/dev/null
429         if [ -z "$ctx" -o "$ctx" = "0" ]; then
430                 VSERVER=no
431         else
432                 VSERVER=yes
433         fi
434         if [ "$VSERVER" = "yes" ]; then
435                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
436         fi
437 fi
438
439 %postun -p      /sbin/postshell
440 -/usr/sbin/fix-info-dir -c %{_infodir}
441
442 %post   libs -p /sbin/ldconfig
443 %postun libs -p /sbin/ldconfig
444
445 %triggerpostun -- poldek < 0.30-0.20080225.00.1
446 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
447         %{__sed} -i -e '/^%%include source.conf/{
448                 a
449                 a# /etc/poldek/repos.d/*.conf
450                 a%%includedir repos.d
451         }' %{_sysconfdir}/%{name}/poldek.conf
452 fi
453
454 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
455 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
456
457 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
458         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
459         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
460 fi
461
462 %ifarch %{x8664}
463 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
464         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
465         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
466 fi
467 %endif
468
469 %triggerpostun -- poldek < 0.30.1-3
470 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
471         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
472         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
473 fi
474 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
475         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
476         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
477 fi
478
479 %triggerpostun -- %{name} < 0.30.1-8
480 if [ $1 -le 1 ]; then
481         # revert change on  --downgrade
482         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
483 else
484         # setup pm command
485         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
486 fi
487
488 %files -f %{name}.lang
489 %defattr(644,root,root,755)
490 %doc ChangeLog README* NEWS configs
491 %dir %{_sysconfdir}/%{name}
492 %dir %{_sysconfdir}/%{name}/pre-install.d
493 %{_sysconfdir}/%{name}/pre-install.d/README
494 %dir %{_sysconfdir}/%{name}/post-install.d
495 %{_sysconfdir}/%{name}/post-install.d/README
496 %dir %{_sysconfdir}/%{name}/repos.d
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
499 %attr(755,root,root) %{_bindir}/ipoldek
500 %attr(755,root,root) %{_bindir}/poldek
501 %attr(755,root,root) %{_bindir}/poldek-config
502 %attr(755,root,root) %{_bindir}/rpmvercmp
503 %dir %{_libexecdir}
504 %attr(755,root,root) %{_libexecdir}/pm-command.sh
505 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
506 %attr(755,root,root) %{_libexecdir}/vfcompr
507 %attr(755,root,root) %{_libexecdir}/vfjuggle
508 %attr(755,root,root) %{_libexecdir}/vfsmb
509 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
510 %{_mandir}/man1/%{name}*.1*
511 %lang(pl) %{_mandir}/pl/man1/%{name}*
512 %{_infodir}/poldek.info*
513 %if %{with imode}
514 %{_desktopdir}/%{name}.desktop
515 %{_pixmapsdir}/%{name}.png
516 %endif
517 %dir /var/cache/%{name}
518
519 %if %{without static}
520 %files libs
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
523 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
524 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
525 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
526 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
527 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.1
528 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.3
529 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
530 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
531 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
532 %endif
533
534 %files devel
535 %defattr(644,root,root,755)
536 %if %{without static}
537 %attr(755,root,root) %{_libdir}/libpoclidek.so
538 %attr(755,root,root) %{_libdir}/libpoldek.so
539 %attr(755,root,root) %{_libdir}/libtndb.so
540 %attr(755,root,root) %{_libdir}/libtrurl.so
541 %attr(755,root,root) %{_libdir}/libvfile.so
542 %endif
543 %{_libdir}/libpoclidek.la
544 %{_libdir}/libpoldek.la
545 %{_libdir}/libtndb.la
546 %{_libdir}/libtrurl.la
547 %{_libdir}/libvfile.la
548 %{_includedir}/poldek
549 %{_includedir}/tndb
550 %{_includedir}/trurl
551 %{_includedir}/vfile
552 %{_pkgconfigdir}/tndb.pc
553 %{_pkgconfigdir}/trurlib.pc
554
555 %files static
556 %defattr(644,root,root,755)
557 %{_libdir}/libtndb.a
558 %{_libdir}/libtrurl.a
559
560 %if %{with python}
561 %files -n python-poldek
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
564 %{py_sitescriptdir}/poldek.py[co]
565 %{py_sitescriptdir}/poldekmod.py[co]
566 %endif
This page took 0.071139 seconds and 3 git commands to generate.