]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- kill %post
[packages/plymouth.git] / plymouth.spec
1 # TODO
2 # - revisit subpackages
3 # - fix: Requires: /bin/bash
4 Summary:        Graphical Boot Animation and Logger
5 Name:           plymouth
6 Version:        0.8.3
7 Release:        0.1
8 License:        GPL v2+
9 Group:          Base
10 Source0:        http://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
11 # Source0-md5:  a479180467b21dd1c5477160d5a1fd35
12 Source1:        %{name}-logo.png
13 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
14 #Patch0:                libdrm.patch
15 URL:            http://www.freedesktop.org/wiki/Software/Plymouth
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  libdrm-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtool
23 BuildRequires:  pango-devel >= 1:1.21.0
24 BuildRequires:  pkgconfig
25 Requires(post): %{name}-scripts = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         plymouthdaemon_execdir  /sbin
29 %define         plymouthclient_execdir  /bin
30 %define         plymouth_libdir                 /%{_lib}
31
32 %description
33 Plymouth provides an attractive graphical boot animation in place of
34 the text messages that normally get shown. Text messages are instead
35 redirected to a log file for viewing after boot.
36
37 %package libs
38 Summary:        Plymouth libraries
39 Group:          Development/Libraries
40
41 %description libs
42 This package contains the libply and libplybootsplash libraries used
43 by Plymouth.
44
45 %package devel
46 Summary:        Libraries and headers for writing Plymouth splash plugins
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       pkgconfig
50
51 %description devel
52 This package contains the libply and libplybootsplash libraries and
53 headers needed to develop 3rd party splash plugins for Plymouth.
54
55 %package utils
56 Summary:        Plymouth related utilities
57 Group:          Applications/System
58 Requires:       %{name} = %{version}-%{release}
59
60 %description utils
61 This package contains utilities that integrate with Plymouth including
62 a boot log viewing application.
63
64 %package scripts
65 Summary:        Plymouth related scripts
66 Group:          Applications/System
67
68 %description scripts
69 This package contains scripts that help integrate Plymouth with the
70 system.
71
72 %package gdm-hooks
73 Summary:        Plymouth GDM integration
74 Group:          Applications/System
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       gdm >= 1:2.22.0
77 Requires:       plymouth-utils
78
79 %description gdm-hooks
80 This package contains support files for integrating Plymouth with GDM
81 Namely, it adds hooks to show boot messages at the login screen in the
82 event start-up services fail.
83
84 %prep
85 %setup -q
86 #%patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         --enable-tracing \
95         --disable-tests \
96         --without-boot-entry \
97         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
98         --with-background-start-color-stop=0x0073B3 \
99         --with-background-end-color-stop=0x00457E \
100         --with-background-color=0x3391cd \
101         --enable-gdm-transition \
102         --with-system-root-install
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
113 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
114
115 # Temporary symlink until rc.sysinit is fixed
116 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
117
118 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
119 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
120 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %postun
126 if [ $1 -eq 0 ]; then
127         rm -f %{_libdir}/plymouth/default.so
128 fi
129
130 %post libs -p /sbin/ldconfig
131 %postun libs -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS NEWS README
136 %attr(755,root,root) %{_bindir}/rhgb-client
137 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
138 %dir %{_sysconfdir}/plymouth
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
140 %{_mandir}/man8/plymouth.8*
141 %dir %{_datadir}/plymouth
142 %{_datadir}/plymouth/plymouthd.defaults
143 %{_datadir}/plymouth/themes
144 %dir %{_libexecdir}/plymouth
145 %dir %{_localstatedir}/lib/plymouth
146 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
147 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
148 %attr(755,root,root) %{_bindir}/plymouth
149 %{_libdir}/plymouth/details.so
150 %{_libdir}/plymouth/fade-throbber.so
151 %{_libdir}/plymouth/label.so
152 %{_libdir}/plymouth/script.so
153 %{_libdir}/plymouth/space-flares.so
154 %{_libdir}/plymouth/text.so
155 %{_libdir}/plymouth/throbgress.so
156 %{_libdir}/plymouth/two-step.so
157 %{_localstatedir}/run/plymouth
158 %{_localstatedir}/spool/plymouth
159 %{_pixmapsdir}/plymouth-logo.png
160
161 %files devel
162 %defattr(644,root,root,755)
163 %{plymouth_libdir}/libply.so
164 %{plymouth_libdir}/libply-splash-core.so
165 %{_libdir}/libply-boot-client.so
166 %{_libdir}/libply-splash-graphics.so
167 %{_pkgconfigdir}/ply-boot-client.pc
168 %{_pkgconfigdir}/ply-splash-core.pc
169 %{_pkgconfigdir}/ply-splash-graphics.pc
170 %{_includedir}/plymouth-1
171
172 %files libs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{plymouth_libdir}/libply.so.*.*.*
175 %attr(755,root,root) %ghost %{plymouth_libdir}/libply.so.2
176 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so.*.*.*
177 %attr(755,root,root) %ghost %{plymouth_libdir}/libply-splash-core.so.2
178 %attr(755,root,root) %{_libdir}/libply-boot-client.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libply-boot-client.so.2
180 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libply-splash-graphics.so.2
182 %dir %{_libdir}/plymouth
183 %dir %{_libdir}/plymouth/renderers
184 %attr(755,root,root) %{_libdir}/plymouth/renderers/drm.so
185 %attr(755,root,root) %{_libdir}/plymouth/renderers/frame-buffer.so
186 %attr(755,root,root) %{_libdir}/plymouth/renderers/x11.so
187
188 %files scripts
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-generate-initrd
191 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-populate-initrd
192 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-update-initrd
193
194 %files utils
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
197
198 %files gdm-hooks
199 %defattr(644,root,root,755)
200 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
This page took 0.038645 seconds and 4 git commands to generate.