]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- no nash
[packages/plymouth.git] / plymouth.spec
1 %define plymouthdaemon_execdir /sbin
2 %define plymouthclient_execdir /bin
3 %define plymouth_libdir /%{_lib}
4
5 Summary:        Graphical Boot Animation and Logger
6 Name:           plymouth
7 Version:        0.6.0
8 Release:        0.1
9 License:        GPL v2+
10 Group:          Base
11 Source0:        http://freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
12 # Source0-md5:  e29e754e942e6fcaf5185772d18fd97e
13 URL:            http://freedesktop.org/software/plymouth/releases
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  cairo-devel
17 BuildRequires:  gtk+2-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  libtool
20 BuildRequires:  pango-devel >= 1.21.0
21 BuildRequires:  pkgconfig
22 Requires(post): %{name}-scripts
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Plymouth provides an attractive graphical boot animation in place of
27 the text messages that normally get shown. Text messages are instead
28 redirected to a log file for viewing after boot.
29
30 %package system-plugin
31 Summary:        Plymouth default plugin
32 Group:          Base
33 Requires:       plymouth(system-plugin) = %{version}-%{release}
34 Provides:       rhgb = 1:10.0.0
35 Obsoletes:      rhgb < 1:10.0.0
36
37 %description system-plugin
38 This metapackage tracks the current distribution default plugin.
39
40 %package libs
41 Summary:        Plymouth libraries
42 Group:          Development/Libraries
43
44 %description libs
45 This package contains the libply and libplybootsplash libraries used
46 by Plymouth.
47
48 %package devel
49 Summary:        Libraries and headers for writing Plymouth splash plugins
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       pkgconfig
53
54 %description devel
55 This package contains the libply and libplybootsplash libraries and
56 headers needed to develop 3rd party splash plugins for Plymouth.
57
58 %package utils
59 Summary:        Plymouth related utilities
60 Group:          Applications/System
61 Requires:       %{name} = %{version}-%{release}
62
63 %description utils
64 This package contains utilities that integrate with Plymouth including
65 a boot log viewing application.
66
67 %package scripts
68 Summary:        Plymouth related scripts
69 Group:          Applications/System
70
71 %description scripts
72 This package contains scripts that help integrate Plymouth with the
73 system.
74
75 %package gdm-hooks
76 Summary:        Plymouth GDM integration
77 Group:          Applications/System
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       gdm >= 1:2.22.0
80 Requires:       plymouth-utils
81
82 %description gdm-hooks
83 This package contains support files for integrating Plymouth with GDM
84 Namely, it adds hooks to show boot messages at the login screen in the
85 event start-up services fail.
86
87 %package plugin-label
88 Summary:        Plymouth label plugin
89 Group:          Base
90 Requires:       %{name}-libs = %{version}-%{release}
91
92 %description plugin-label
93 This package contains the label control plugin for Plymouth. It
94 provides the ability to render text on graphical boot splashes using
95 pango and cairo.
96
97 %package plugin-fade-in
98 Summary:        Plymouth "Fade-In" plugin
99 Group:          Base
100 Requires(post): %{_sbindir}/plymouth-set-default-plugin
101 Requires:       %{name}-libs = %{version}-%{release}
102
103 %description plugin-fade-in
104 This package contains the "Fade-In" boot splash plugin for Plymouth.
105 It features a centered logo that fades in and out while stars twinkle
106 around the logo during system boot up.
107
108 %package plugin-pulser
109 Summary:        Plymouth "Pulser" plugin
110 Group:          Base
111 Requires(post): %{_sbindir}/plymouth-set-default-plugin
112 Requires:       %{name}-libs = %{version}-%{release}
113
114 %description plugin-pulser
115 This package contains the "Pulser" boot splash plugin for Plymouth. It
116 features a pulsing text progress indicator centered in the screen
117 during system boot up.
118
119 %package plugin-spinfinity
120 Summary:        Plymouth "Spinfinity" plugin
121 Group:          Base
122 Requires(post): %{_sbindir}/plymouth-set-default-plugin
123 Requires:       %{name}-libs = %{version}-%{release}
124 Requires:       plymouth-plugin-label
125
126 %description plugin-spinfinity
127 This package contains the "Spinfinity" boot splash plugin for
128 Plymouth. It features a centered logo and animated spinner that spins
129 in the shape of an infinity sign.
130
131 %package plugin-solar
132 Summary:        Plymouth "Solar" plugin
133 Group:          Base
134 Requires(post): %{_sbindir}/plymouth-set-default-plugin
135 Requires:       %{name}-libs = %{version}-%{release}
136 Requires:       plymouth-plugin-label
137 Provides:       plymouth(system-plugin) = %{version}-%{release}
138
139 %description plugin-solar
140 This package contains the "Solar" boot splash plugin for Plymouth. It
141 features a blue flamed sun with animated solar flares.
142
143 %prep
144 %setup -q
145
146 %build
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__automake}
151 %configure \
152         --enable-tracing \
153         --disable-tests \
154         --without-boot-entry \
155         --without-default-plugin \
156         --with-logo=%{_pixmapsdir}/system-logo-white.png \
157         --with-background-start-color-stop=0x0073B3 \
158         --with-background-end-color-stop=0x00457E \
159         --with-background-color=0x3391cd \
160         --enable-gdm-transition \
161         --with-system-root-install
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
172 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
173
174 # Temporary symlink until rc.sysinit is fixed
175 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
176
177 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post
183 [ -f %{_localstatedir}/lib/plymouth/boot-duration ] || cp -f %{_datadir}/plymouth/default-boot-duration %{_localstatedir}/lib/plymouth/boot-duration
184
185 %postun
186 if [ $1 -eq 0 ]; then
187     rm -f %{_libdir}/plymouth/default.so
188 fi
189
190 %post libs -p /sbin/ldconfig
191 %postun libs -p /sbin/ldconfig
192
193 %postun plugin-spinfinity
194 export LIB=%{_lib}
195 if [ $1 -eq 0 ]; then
196     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "spinfinity" ]; then
197         %{_sbindir}/plymouth-set-default-plugin --reset
198     fi
199 fi
200
201 %postun plugin-fade-in
202 export LIB=%{_lib}
203 if [ $1 -eq 0 ]; then
204     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "fade-in" ]; then
205         %{_sbindir}/plymouth-set-default-plugin --reset
206     fi
207 fi
208
209 %post plugin-solar
210 export LIB=%{_lib}
211 if [ $1 -eq 1 ]; then
212     %{_sbindir}/plymouth-set-default-plugin solar
213 fi
214
215 %postun plugin-solar
216 export LIB=%{_lib}
217 if [ $1 -eq 0 ]; then
218     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "solar" ]; then
219         %{_sbindir}/plymouth-set-default-plugin text
220     fi
221 fi
222
223 %postun plugin-pulser
224 export LIB=%{_lib}
225 if [ $1 -eq 0 ]; then
226     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "pulser" ]; then
227         %{_sbindir}/plymouth-set-default-plugin --reset
228     fi
229 fi
230
231 %files
232 %defattr(644,root,root,755)
233 %doc AUTHORS NEWS README
234 %dir %{_datadir}/plymouth
235 %dir %{_libexecdir}/plymouth
236 %dir %{_localstatedir}/lib/plymouth
237 %{plymouthdaemon_execdir}/plymouthd
238 %{plymouthclient_execdir}/plymouth
239 %attr(755,root,root) %{_bindir}/plymouth
240 %attr(755,root,root) %{_bindir}/rhgb-client
241 %{_libdir}/plymouth/details.so
242 %{_libdir}/plymouth/text.so
243 %{_localstatedir}/run/plymouth
244 %{_localstatedir}/spool/plymouth
245 #%ghost %{_localstatedir}/lib/plymouth/boot-duration
246
247 %files devel
248 %defattr(644,root,root,755)
249 %{plymouth_libdir}/libply.so
250 %{_libdir}/libplybootsplash.so
251 %{_pkgconfigdir}/plymouth-1.pc
252 %{_includedir}/plymouth-1
253
254 %files libs
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{plymouth_libdir}/libply.so.*
257 %attr(755,root,root) %{_libdir}/libplybootsplash.so.*
258 %dir %{_libdir}/plymouth
259
260 %files scripts
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_sbindir}/plymouth-set-default-plugin
263 %{_libexecdir}/plymouth/plymouth-update-initrd
264 %{_libexecdir}/plymouth/plymouth-populate-initrd
265
266 %files utils
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
269
270 %files gdm-hooks
271 %defattr(644,root,root,755)
272 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
273
274 %files plugin-label
275 %defattr(644,root,root,755)
276 %{_libdir}/plymouth/label.so
277
278 %files plugin-fade-in
279 %defattr(644,root,root,755)
280 %dir %{_datadir}/plymouth/fade-in
281 %{_datadir}/plymouth/fade-in/bullet.png
282 %{_datadir}/plymouth/fade-in/entry.png
283 %{_datadir}/plymouth/fade-in/lock.png
284 %{_datadir}/plymouth/fade-in/star.png
285 %{_libdir}/plymouth/fade-in.so
286
287 %files plugin-pulser
288 %defattr(644,root,root,755)
289 %{_libdir}/plymouth/pulser.so
290
291 %files plugin-spinfinity
292 %defattr(644,root,root,755)
293 %dir %{_datadir}/plymouth/spinfinity
294 %{_datadir}/plymouth/spinfinity/box.png
295 %{_datadir}/plymouth/spinfinity/bullet.png
296 %{_datadir}/plymouth/spinfinity/entry.png
297 %{_datadir}/plymouth/spinfinity/lock.png
298 %{_datadir}/plymouth/spinfinity/throbber-[0-3][0-9].png
299 %{_libdir}/plymouth/spinfinity.so
300
301 %files plugin-solar
302 %defattr(644,root,root,755)
303 %dir %{_datadir}/plymouth/solar
304 %{_datadir}/plymouth/solar/*.png
305 %{_libdir}/plymouth/solar.so
306
307 %files system-plugin
308 %defattr(644,root,root,755)
This page took 0.063345 seconds and 4 git commands to generate.