]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- more fixes
[packages/plymouth.git] / plymouth.spec
1 %define plymouthdaemon_execdir /sbin
2 %define plymouthclient_execdir /bin
3 %define plymouth_libdir /%{_lib}
4
5 Summary:        Graphical Boot Animation and Logger
6 Name:           plymouth
7 Version:        0.6.0
8 Release:        0.1
9 License:        GPL v2+
10 Group:          Base
11 Source0:        http://freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
12 # Source0-md5:  e29e754e942e6fcaf5185772d18fd97e
13 Source1:        %{name}-logo.png
14 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
15 URL:            http://freedesktop.org/software/plymouth/releases
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  libpng-devel
21 BuildRequires:  libtool
22 BuildRequires:  pango-devel >= 1.21.0
23 BuildRequires:  pkgconfig
24 Requires(post): %{name}-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Plymouth provides an attractive graphical boot animation in place of
29 the text messages that normally get shown. Text messages are instead
30 redirected to a log file for viewing after boot.
31
32 %package system-plugin
33 Summary:        Plymouth default plugin
34 Group:          Base
35 Requires:       plymouth(system-plugin) = %{version}-%{release}
36 Provides:       rhgb = 1:10.0.0
37 Obsoletes:      rhgb < 1:10.0.0
38
39 %description system-plugin
40 This metapackage tracks the current distribution default plugin.
41
42 %package libs
43 Summary:        Plymouth libraries
44 Group:          Development/Libraries
45
46 %description libs
47 This package contains the libply and libplybootsplash libraries used
48 by Plymouth.
49
50 %package devel
51 Summary:        Libraries and headers for writing Plymouth splash plugins
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       pkgconfig
55
56 %description devel
57 This package contains the libply and libplybootsplash libraries and
58 headers needed to develop 3rd party splash plugins for Plymouth.
59
60 %package utils
61 Summary:        Plymouth related utilities
62 Group:          Applications/System
63 Requires:       %{name} = %{version}-%{release}
64
65 %description utils
66 This package contains utilities that integrate with Plymouth including
67 a boot log viewing application.
68
69 %package scripts
70 Summary:        Plymouth related scripts
71 Group:          Applications/System
72
73 %description scripts
74 This package contains scripts that help integrate Plymouth with the
75 system.
76
77 %package gdm-hooks
78 Summary:        Plymouth GDM integration
79 Group:          Applications/System
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gdm >= 1:2.22.0
82 Requires:       plymouth-utils
83
84 %description gdm-hooks
85 This package contains support files for integrating Plymouth with GDM
86 Namely, it adds hooks to show boot messages at the login screen in the
87 event start-up services fail.
88
89 %package plugin-label
90 Summary:        Plymouth label plugin
91 Group:          Base
92 Requires:       %{name}-libs = %{version}-%{release}
93
94 %description plugin-label
95 This package contains the label control plugin for Plymouth. It
96 provides the ability to render text on graphical boot splashes using
97 pango and cairo.
98
99 %package plugin-fade-in
100 Summary:        Plymouth "Fade-In" plugin
101 Group:          Base
102 Requires(post): %{_sbindir}/plymouth-set-default-plugin
103 Requires:       %{name}-libs = %{version}-%{release}
104
105 %description plugin-fade-in
106 This package contains the "Fade-In" boot splash plugin for Plymouth.
107 It features a centered logo that fades in and out while stars twinkle
108 around the logo during system boot up.
109
110 %package plugin-pulser
111 Summary:        Plymouth "Pulser" plugin
112 Group:          Base
113 Requires(post): %{_sbindir}/plymouth-set-default-plugin
114 Requires:       %{name}-libs = %{version}-%{release}
115
116 %description plugin-pulser
117 This package contains the "Pulser" boot splash plugin for Plymouth. It
118 features a pulsing text progress indicator centered in the screen
119 during system boot up.
120
121 %package plugin-spinfinity
122 Summary:        Plymouth "Spinfinity" plugin
123 Group:          Base
124 Requires(post): %{_sbindir}/plymouth-set-default-plugin
125 Requires:       %{name}-libs = %{version}-%{release}
126 Requires:       plymouth-plugin-label
127
128 %description plugin-spinfinity
129 This package contains the "Spinfinity" boot splash plugin for
130 Plymouth. It features a centered logo and animated spinner that spins
131 in the shape of an infinity sign.
132
133 %package plugin-solar
134 Summary:        Plymouth "Solar" plugin
135 Group:          Base
136 Requires(post): %{_sbindir}/plymouth-set-default-plugin
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       plymouth-plugin-label
139 Provides:       plymouth(system-plugin) = %{version}-%{release}
140
141 %description plugin-solar
142 This package contains the "Solar" boot splash plugin for Plymouth. It
143 features a blue flamed sun with animated solar flares.
144
145 %prep
146 %setup -q
147
148 %build
149 %{__libtoolize}
150 %{__aclocal}
151 %{__autoconf}
152 %{__automake}
153 %configure \
154         --enable-tracing \
155         --disable-tests \
156         --without-boot-entry \
157         --without-default-plugin \
158         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
159         --with-background-start-color-stop=0x0073B3 \
160         --with-background-end-color-stop=0x00457E \
161         --with-background-color=0x3391cd \
162         --enable-gdm-transition \
163         --with-system-root-install
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
174 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
175
176 # Temporary symlink until rc.sysinit is fixed
177 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
178
179 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
180 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
181 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 [ -f %{_localstatedir}/lib/plymouth/boot-duration ] || cp -f %{_datadir}/plymouth/default-boot-duration %{_localstatedir}/lib/plymouth/boot-duration
188
189 %postun
190 if [ $1 -eq 0 ]; then
191     rm -f %{_libdir}/plymouth/default.so
192 fi
193
194 %post libs -p /sbin/ldconfig
195 %postun libs -p /sbin/ldconfig
196
197 %postun plugin-spinfinity
198 export LIB=%{_lib}
199 if [ $1 -eq 0 ]; then
200     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "spinfinity" ]; then
201         %{_sbindir}/plymouth-set-default-plugin --reset
202     fi
203 fi
204
205 %postun plugin-fade-in
206 export LIB=%{_lib}
207 if [ $1 -eq 0 ]; then
208     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "fade-in" ]; then
209         %{_sbindir}/plymouth-set-default-plugin --reset
210     fi
211 fi
212
213 %post plugin-solar
214 export LIB=%{_lib}
215 if [ $1 -eq 1 ]; then
216     %{_sbindir}/plymouth-set-default-plugin solar
217 fi
218
219 %postun plugin-solar
220 export LIB=%{_lib}
221 if [ $1 -eq 0 ]; then
222     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "solar" ]; then
223         %{_sbindir}/plymouth-set-default-plugin text
224     fi
225 fi
226
227 %postun plugin-pulser
228 export LIB=%{_lib}
229 if [ $1 -eq 0 ]; then
230     if [ "$(%{_sbindir}/plymouth-set-default-plugin)" == "pulser" ]; then
231         %{_sbindir}/plymouth-set-default-plugin --reset
232     fi
233 fi
234
235 %files
236 %defattr(644,root,root,755)
237 %doc AUTHORS NEWS README
238 %dir %{_datadir}/plymouth
239 %dir %{_libexecdir}/plymouth
240 %dir %{_localstatedir}/lib/plymouth
241 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
242 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
243 %attr(755,root,root) %{_bindir}/plymouth
244 %{_libdir}/plymouth/details.so
245 %{_libdir}/plymouth/text.so
246 %{_localstatedir}/run/plymouth
247 %{_localstatedir}/spool/plymouth
248 %{_pixmapsdir}/plymouth-logo.png
249 #%ghost %{_localstatedir}/lib/plymouth/boot-duration
250
251 %files devel
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{plymouth_libdir}/libply.so
254 %{_libdir}/libplybootsplash.so
255 %{_pkgconfigdir}/plymouth-1.pc
256 %{_includedir}/plymouth-1
257
258 %files libs
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{plymouth_libdir}/libply.so.*
261 %attr(755,root,root) %{_libdir}/libplybootsplash.so.*
262 %dir %{_libdir}/plymouth
263
264 %files scripts
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{_sbindir}/plymouth-set-default-plugin
267 %{_libexecdir}/plymouth/plymouth-update-initrd
268 %{_libexecdir}/plymouth/plymouth-populate-initrd
269
270 %files utils
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
273
274 %files gdm-hooks
275 %defattr(644,root,root,755)
276 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
277
278 %files plugin-label
279 %defattr(644,root,root,755)
280 %{_libdir}/plymouth/label.so
281
282 %files plugin-fade-in
283 %defattr(644,root,root,755)
284 %dir %{_datadir}/plymouth/fade-in
285 %{_datadir}/plymouth/fade-in/bullet.png
286 %{_datadir}/plymouth/fade-in/entry.png
287 %{_datadir}/plymouth/fade-in/lock.png
288 %{_datadir}/plymouth/fade-in/star.png
289 %{_libdir}/plymouth/fade-in.so
290
291 %files plugin-pulser
292 %defattr(644,root,root,755)
293 %{_libdir}/plymouth/pulser.so
294
295 %files plugin-spinfinity
296 %defattr(644,root,root,755)
297 %dir %{_datadir}/plymouth/spinfinity
298 %{_datadir}/plymouth/spinfinity/box.png
299 %{_datadir}/plymouth/spinfinity/bullet.png
300 %{_datadir}/plymouth/spinfinity/entry.png
301 %{_datadir}/plymouth/spinfinity/lock.png
302 %{_datadir}/plymouth/spinfinity/throbber-[0-3][0-9].png
303 %{_libdir}/plymouth/spinfinity.so
304
305 %files plugin-solar
306 %defattr(644,root,root,755)
307 %dir %{_datadir}/plymouth/solar
308 %{_datadir}/plymouth/solar/*.png
309 %{_libdir}/plymouth/solar.so
310
311 %files system-plugin
312 %defattr(644,root,root,755)
This page took 0.076364 seconds and 4 git commands to generate.