]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- 0.7.2
[packages/plymouth.git] / plymouth.spec
1 %define plymouthdaemon_execdir /sbin
2 %define plymouthclient_execdir /bin
3 %define plymouth_libdir /%{_lib}
4
5 Summary:        Graphical Boot Animation and Logger
6 Name:           plymouth
7 Version:        0.7.2
8 Release:        0.1
9 License:        GPL v2+
10 Group:          Base
11 Source0:        http://freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
12 # Source0-md5:  5d5b2b7c2dd38ef91c8c6cffb088ce93
13 Source1:        %{name}-logo.png
14 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
15 URL:            http://freedesktop.org/software/plymouth/releases
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  libpng-devel
21 BuildRequires:  libtool
22 BuildRequires:  pango-devel >= 1.21.0
23 BuildRequires:  pkgconfig
24 Requires(post): %{name}-scripts
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Plymouth provides an attractive graphical boot animation in place of
29 the text messages that normally get shown. Text messages are instead
30 redirected to a log file for viewing after boot.
31
32 %package libs
33 Summary:        Plymouth libraries
34 Group:          Development/Libraries
35
36 %description libs
37 This package contains the libply and libplybootsplash libraries used
38 by Plymouth.
39
40 %package devel
41 Summary:        Libraries and headers for writing Plymouth splash plugins
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       pkgconfig
45
46 %description devel
47 This package contains the libply and libplybootsplash libraries and
48 headers needed to develop 3rd party splash plugins for Plymouth.
49
50 %package utils
51 Summary:        Plymouth related utilities
52 Group:          Applications/System
53 Requires:       %{name} = %{version}-%{release}
54
55 %description utils
56 This package contains utilities that integrate with Plymouth including
57 a boot log viewing application.
58
59 %package scripts
60 Summary:        Plymouth related scripts
61 Group:          Applications/System
62
63 %description scripts
64 This package contains scripts that help integrate Plymouth with the
65 system.
66
67 %package gdm-hooks
68 Summary:        Plymouth GDM integration
69 Group:          Applications/System
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       gdm >= 1:2.22.0
72 Requires:       plymouth-utils
73
74 %description gdm-hooks
75 This package contains support files for integrating Plymouth with GDM
76 Namely, it adds hooks to show boot messages at the login screen in the
77 event start-up services fail.
78
79 %prep
80 %setup -q
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__automake}
87 %configure \
88         --enable-tracing \
89         --disable-tests \
90         --without-boot-entry \
91         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
92         --with-background-start-color-stop=0x0073B3 \
93         --with-background-end-color-stop=0x00457E \
94         --with-background-color=0x3391cd \
95         --enable-gdm-transition \
96         --with-system-root-install
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
107 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108
109 # Temporary symlink until rc.sysinit is fixed
110 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
111
112 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
113 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
114 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 [ -f %{_localstatedir}/lib/plymouth/boot-duration ] || cp -f %{_datadir}/plymouth/default-boot-duration %{_localstatedir}/lib/plymouth/boot-duration
121
122 %postun
123 if [ $1 -eq 0 ]; then
124     rm -f %{_libdir}/plymouth/default.so
125 fi
126
127 %post libs -p /sbin/ldconfig
128 %postun libs -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS NEWS README
133 %attr(755,root,root) %{_bindir}/rhgb-client
134 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
135 %dir %{_datadir}/plymouth
136 %{_datadir}/plymouth/themes
137 %dir %{_libexecdir}/plymouth
138 %dir %{_localstatedir}/lib/plymouth
139 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
140 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
141 %attr(755,root,root) %{_bindir}/plymouth
142 %{_libdir}/plymouth/details.so
143 %{_libdir}/plymouth/fade-throbber.so
144 %{_libdir}/plymouth/label.so
145 %{_libdir}/plymouth/script.so
146 %{_libdir}/plymouth/space-flares.so
147 %{_libdir}/plymouth/text.so
148 %{_libdir}/plymouth/throbgress.so
149 %{_libdir}/plymouth/two-step.so
150 %{_localstatedir}/run/plymouth
151 %{_localstatedir}/spool/plymouth
152 %{_pixmapsdir}/plymouth-logo.png
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{plymouth_libdir}/libply.so
157 %{_libdir}/libplybootsplash.so
158 %{_pkgconfigdir}/plymouth-1.pc
159 %{_includedir}/plymouth-1
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{plymouth_libdir}/libply.so.*
164 %attr(755,root,root) %{_libdir}/libplybootsplash.so.*
165 %dir %{_libdir}/plymouth
166
167 %files scripts
168 %defattr(644,root,root,755)
169 %{_libexecdir}/plymouth/plymouth-update-initrd
170 %{_libexecdir}/plymouth/plymouth-populate-initrd
171
172 %files utils
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
175
176 %files gdm-hooks
177 %defattr(644,root,root,755)
178 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
This page took 0.115298 seconds and 4 git commands to generate.