]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- add systemd scriptlets
[packages/plymouth.git] / plymouth.spec
1 # TODO
2 # - integrate with geninitrd
3 # - pldize recent update (r1.18)
4 # - verify if systemd services have to be installed for targets,
5 #       and remove the symlinks if not
6 #
7 # Conditional build:
8 %bcond_without  drm_intel       # disable building with libdrm_intel support
9 %bcond_without  drm_radeon      # disable building with libdrm_radeon support
10 %bcond_with     drm_nouveau     # enable building with libdrm_nouveau support
11 %bcond_without  kms             # disable building with libkms support
12 #
13 Summary:        Graphical Boot Animation and Logger
14 Summary(pl.UTF-8):      Graficzna animacja i logowanie startu systemu
15 Name:           plymouth
16 Version:        0.8.5.1
17 Release:        1
18 License:        GPL v2+
19 Group:          Base
20 Source0:        http://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  76714ebe125991f59b8a5029070f9b83
22 Source1:        %{name}-logo.png
23 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
24 Source2:        %{name}.tmpfiles
25 Source3:        charge.%{name}
26 Source4:        boot-duration
27 Source5:        %{name}-set-default-plugin
28 Source6:        %{name}-update-initrd
29 Source7:        systemd-ask-password-plymouth.path
30 Source8:        systemd-ask-password-plymouth.service
31 Patch0:         text-colors.patch
32 URL:            http://www.freedesktop.org/wiki/Software/Plymouth
33 BuildRequires:  cairo-devel
34 BuildRequires:  gtk+2-devel >= 2:2.12.0
35 %if %{with drm_intel} ||  %{with drm_radeon} ||  %{with drm_nouveau} ||  %{with kms}
36 BuildRequires:  libdrm-devel
37 %endif
38 BuildRequires:  libpng-devel >= 2:1.2.16
39 BuildRequires:  pango-devel >= 1:1.21.0
40 BuildRequires:  pkgconfig
41 Requires:       %{name}-graphics-libs = %{version}-%{release}
42 Requires(post): %{name}-scripts = %{version}-%{release}
43 Requires:       /etc/os-release
44 Requires:       systemd-units
45 Obsoletes:      plymouth-gdm-hooks
46 Obsoletes:      plymouth-utils
47 Obsoletes:      systemd-plymouth
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         plymouthdaemon_execdir  /sbin
51 %define         plymouthclient_execdir  /bin
52 %define         plymouth_libdir         /%{_lib}
53
54 %description
55 Plymouth provides an attractive graphical boot animation in place of
56 the text messages that normally get shown. Text messages are instead
57 redirected to a log file for viewing after boot.
58
59 %description -l pl.UTF-8
60 Plymouth zapewnia atrakcyjną animację w trakcie startu systemu zamiast
61 zwykle wyświetlanych komunikatów tekstowych. Komunikaty tekstowe
62 zamiast tego są przekierowywane do logu, który można obejrzeć po
63 uruchomieniu systemu.
64
65 %package core-libs
66 Summary:        Plymouth core libraries
67 Summary(pl.UTF-8):      Podstawowe biblioteki Plymouth
68 Group:          Libraries
69 Conflicts:      plymouth-libs < 0.8.4-0.20120319.1
70
71 %description core-libs
72 This package contains the libply and libply-splash-core libraries used
73 by Plymouth.
74
75 %description core-libs -l pl.UTF-8
76 Ten pakiet zawiera biblioteki libply i libply-splash-core
77 wykorzystywane przez Plymouth.
78
79 %package graphics-libs
80 Summary:        Plymouth graphics libraries
81 Summary(pl.UTF-8):      Biblioteki graficzne Plymouth
82 Group:          Development/Libraries
83 Requires:       %{name}-core-libs = %{version}-%{release}
84 Provides:       %{name}-graphics-libs = %{version}-%{release}
85 Obsoletes:      plymouth-libs < %{version}-%{release}
86 Conflicts:      plymouth-libs < 0.8.4-0.20120319.1
87
88 %description graphics-libs
89 This package contains the libply-splash-graphics library used by
90 graphical Plymouth splashes.
91
92 %description graphics-libs -l pl.UTF-8
93 Ten pakiet zawiera bibliotekę libply-splash-graphics wykorzystywaną
94 przez graficzne ekrany Plymouth.
95
96 %package devel
97 Summary:        Header files for writing Plymouth splash plugins
98 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek graficznych Plymouth
99 Group:          Development/Libraries
100 Requires:       %{name}-graphics-libs = %{version}-%{release}
101
102 %description devel
103 This package contains the header files for libply and libplybootsplash
104 libraries needed to develop 3rd party splash plugins for Plymouth.
105
106 %description devel -l pl.UTF-8
107 Ten pakiet zawiera pliki nagłówkowe bibliotek libply i
108 libplybootsplash, potrzebne do tworzenia wtyczek graficznych Plymouth.
109
110 %package scripts
111 Summary:        Plymouth related scripts
112 Summary(pl.UTF-8):      Skrypty pomocnicze do Plymouth
113 Group:          Applications/System
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       coreutils
116 Requires:       cpio
117 #Requires:      dracut
118 Requires:       findutils
119 Requires:       gzip
120
121 %description scripts
122 This package contains scripts that help integrate Plymouth with the
123 system.
124
125 %description scripts -l pl.UTF-8
126 Ten pakiet zawiera skrypty pomagające zintegrować Plymouth z systemem.
127
128 %package plugin-fade-throbber
129 Summary:        Plymouth "Fade-Throbber" plugin
130 Summary(pl.UTF-8):      Wtyczka Plymouth "Fade-Throbber"
131 Group:          Base
132 Requires:       %{name}-graphics-libs = %{version}-%{release}
133
134 %description plugin-fade-throbber
135 This package contains the "Fade-Throbber" boot splash plugin for
136 Plymouth. It features a centered image that fades in and out while
137 other images pulsate around during system boot up.
138
139 %description plugin-fade-throbber -l pl.UTF-8
140 Ten pakiet zawiera wtyczkę ekranu startowego Plymouth "Fade-Throbber".
141 Cechuje się ona środkowym obrazkiem, który płynnie pojawia się i
142 wygasa, podczas gdy inne obrazki pulsują w trakcie startu systemu.
143
144 %package plugin-label
145 Summary:        Plymouth label plugin
146 Summary(pl.UTF-8):      Wtyczka Plymouth z etykietami
147 Group:          Base
148 Requires:       %{name}-graphics-libs = %{version}-%{release}
149
150 %description plugin-label
151 This package contains the label control plugin for Plymouth. It
152 provides the ability to render text on graphical boot splashes using
153 pango and cairo.
154
155 %description plugin-label -l pl.UTF-8
156 Ten pakiet zawiera wtyczkę Plymouth sterującą etykietami. Daje ona
157 możliwość renderowania tekstu na graficznych ekranach startowych przy
158 użyciu bibliotek pango i cairo.
159
160 %package plugin-script
161 Summary:        Plymouth "script" plugin
162 Summary(pl.UTF-8):      Wtyczka Plymouth "script"
163 Group:          Base
164 Requires:       %{name}-graphics-libs = %{version}-%{release}
165
166 %description plugin-script
167 This package contains the "script" boot splash plugin for Plymouth. It
168 features an extensible, scriptable boot splash language that
169 simplifies the process of designing custom boot splash themes.
170
171 %description plugin-script -l pl.UTF-8
172 Ten pakiet zawiera wtyczkę ekranu startowego Plymouth "script".
173 Odznacza się ona rozszerzalnym, skryptowym językiem ekranu startowego,
174 upraszczającym proces projektowania własnych motywów ekranów
175 startowych.
176
177 %package plugin-space-flares
178 Summary:        Plymouth "space-flares" plugin
179 Summary(pl.UTF-8):      Wtyczka Plymouth "space-flares"
180 Group:          Base
181 Requires:       %{name}-graphics-libs = %{version}-%{release}
182 Requires:       %{name}-plugin-label = %{version}-%{release}
183
184 %description plugin-space-flares
185 This package contains the "space-flares" boot splash plugin for
186 Plymouth. It features a corner image with animated flares.
187
188 %description plugin-space-flares -l pl.UTF-8
189 Ten pakiet zawiera wtyczkę ekranu startowego Plymouth "space-flares".
190 Odznacza się ona umieszczonym w rogu obrazkiem z animowanymi
191 promieniami.
192
193 %package plugin-two-step
194 Summary:        Plymouth "two-step" plugin
195 Summary(pl.UTF-8):      Wtyczka Plymouth "two-step"
196 Group:          Base
197 Requires:       %{name}-graphics-libs = %{version}-%{release}
198 Requires:       %{name}-plugin-label = %{version}-%{release}
199
200 %description plugin-two-step
201 This package contains the "two-step" boot splash plugin for Plymouth.
202 It features a two phased boot process that starts with a progressing
203 animation synced to boot time and finishes with a short, fast one-shot
204 animation.
205
206 %description plugin-two-step -l pl.UTF-8
207 Ten pakeit zawiera wtyczkę ekranu startowego Plymouth "two-step".
208 Odznacza się ona dwuetapowym procesem startu, rozpoczynającym się
209 postępującą animacją synchronizowaną z czasem uruchamiania, a kończy
210 krótką, jednorazową animacją.
211
212 %package plugin-throbgress
213 Summary:        Plymouth "Throbgress" plugin
214 Summary(pl.UTF-8):      Wtyczka Plymouth "Throbgress"
215 Group:          Base
216 Requires:       %{name}-graphics-libs = %{version}-%{release}
217 Requires:       %{name}-plugin-label = %{version}-%{release}
218
219 %description plugin-throbgress
220 This package contains the "throbgress" boot splash plugin for
221 Plymouth. It features a centered logo and animated spinner that spins
222 repeatedly while a progress bar advances at the bottom of the screen.
223
224 %description plugin-throbgress -l pl.UTF-8
225 Ten pakiet zawiera wtyczkę ekranu startowego "Throbgress" do Plymouth.
226 Cechuje się ona umieszczonym pośrodku logiem oraz animowanym kręcącym
227 się kółkiem, podczas gdy pasek postępu przesuwa się na dole ekranu.
228
229 %package system-theme
230 Summary:        Plymouth default theme
231 Summary(pl.UTF-8):      Domyślny motyw Plymouth
232 Group:          Base
233 Requires:       %{name}(system-theme) = %{version}-%{release}
234 Provides:       %{name}-system-plugin = %{version}-%{release}
235 Obsoletes:      plymouth-system-plugin < %{version}-%{release}
236
237 %description system-theme
238 This metapackage tracks the current distribution default theme.
239
240 %description system-theme -l pl.UTF-8
241 Ten metapakiet śledzi domyślny motyw dystrybucji.
242
243 %package theme-charge
244 Summary:        Plymouth "Charge" theme
245 Summary(pl.UTF-8):      Motyw Plymouth "Charge"
246 Group:          Base
247 Requires:       %{name}-plugin-two-step = %{version}-%{release}
248 Requires(post): %{name}-scripts = %{version}-%{release}
249 Provides:       %{name}(system-theme) = %{version}-%{release}
250
251 %description theme-charge
252 This package contains the "charge" boot splash theme for Plymouth. It
253 features the shadowy hull of a Fedora logo charge up and and finally
254 burst into full form.
255
256 %description theme-charge -l pl.UTF-8
257 Ten pakiet zawiera motyw ekranu startowego Plymouth "Charge". Odznacza
258 się on cieniowaną łupiną loga Fedory, która rośnie, a ostatecznie
259 wybucha do pełnej postaci.
260
261 %package theme-fade-in
262 Summary:        Plymouth "Fade-In" theme
263 Summary(pl.UTF-8):      Motyw Plymouth "Fade in"
264 Group:          Base
265 Requires(post): %{name}-scripts = %{version}-%{release}
266 Requires:       %{name}-plugin-fade-throbber = %{version}-%{release}
267 Obsoletes:      plymouth-plugin-fade-in
268
269 %description theme-fade-in
270 This package contains the "Fade-In" boot splash theme for Plymouth. It
271 features a centered logo that fades in and out while stars twinkle
272 around the logo during system boot up.
273
274 %description theme-fade-in -l pl.UTF-8
275 Ten pakiet zawiera motyw ekranu startowego Plymouth "Fade-In".
276 Odznacza się on umieszczonym pośrodku logiem, które w trakcie startu
277 systemu płynnie pojawia się i wygasa, podczas gdy wokół loga migoczą
278 gwiazdy.
279
280 %package theme-script
281 Summary:        Plymouth "Script" theme
282 Summary(pl.UTF-8):      Motyw Plymouth "Script"
283 Group:          Base
284 Requires(post): %{name}-scripts = %{version}-%{release}
285 Requires:       %{name}-plugin-script = %{version}-%{release}
286
287 %description theme-script
288 This package contains the "script" boot splash theme for Plymouth. It
289 it is a simple example theme the uses the "script" plugin.
290
291 %description theme-script -l pl.UTF-8
292 Ten pakiet zawiera motyw ekranu startowego Plymouth "Script". Jest to
293 prosty przykład wykorzystujący wtyczkę "script".
294
295 %package theme-solar
296 Summary:        Plymouth "Solar" theme
297 Summary(pl.UTF-8):      Motyw Plymouth "Solar"
298 Group:          Base
299 Requires(post): %{name}-scripts = %{version}-%{release}
300 Requires:       %{name}-plugin-space-flares = %{version}-%{release}
301 Obsoletes:      plymouth-plugin-solar
302
303 %description theme-solar
304 This package contains the "Solar" boot splash theme for Plymouth. It
305 features a blue flamed sun with animated solar flares.
306
307 %description theme-solar -l pl.UTF-8
308 Ten pakiet zawiera motyw ekranu startowego Plymouth "Solar". Odznacza
309 się on słońcem w niebieskich płomieniach z animowanymi promieniami
310 słonecznymi.
311
312 %package theme-spinfinity
313 Summary:        Plymouth "Spinfinity" theme
314 Summary(pl.UTF-8):      Motyw Plymouth "Spinfinity"
315 Group:          Base
316 Requires(post): %{name}-scripts = %{version}-%{release}
317 Requires:       %{name}-plugin-throbgress = %{version}-%{release}
318 Obsoletes:      plymouth-plugin-spinfinity
319
320 %description theme-spinfinity
321 This package contains the "Spinfinity" boot splash theme for Plymouth.
322 It features a centered logo and animated spinner that spins in the
323 shape of an infinity sign.
324
325 %description theme-spinfinity -l pl.UTF-8
326 Ten pakiet zawiera motyw ekranu startowego Plymouth "Spinfinity".
327 Odznacza się on umieszczonym pośrodku logiem i animowanym kółkiem
328 kręcącym się po kształcie znaku nieskończoności.
329
330 %package theme-spinner
331 Summary:        Plymouth "Spinner" theme
332 Summary(pl.UTF-8):      Motyw Plymouth "Spinner"
333 Group:          Base
334 Requires(post): %{name}-scripts = %{version}-%{release}
335 Requires:       %{name}-plugin-two-step = %{version}-%{release}
336
337 %description theme-spinner
338 This package contains the "spinner" boot splash theme for Plymouth. It
339 features a small spinner on a dark background.
340
341 %description theme-spinner -l pl.UTF-8
342 Ten pakiet zawiera motyw ekranu startowego Plymouth "Spinner".
343 Odznacza się on małym kółkiem kręcącym się na ciemnym tle.
344
345 %prep
346 %setup -q
347 %patch0 -p1
348
349 # Change the default theme
350 sed -i -e 's/fade-in/charge/g' src/plymouthd.defaults
351
352 %build
353 %configure \
354         %{__enable_disable drm_intel libdrm_intel} \
355         %{__enable_disable drm_radeon libdrm_radeon} \
356         %{__enable_disable drm_nouveau libdrm_nouveau} \
357         %{__enable_disable kms libkms} \
358         --disable-silent-rules \
359         --disable-static \
360         --disable-tests \
361         --disable-gdm-transition \
362         --enable-systemd-integration \
363         --enable-tracing \
364         --without-rhgb-compat-link \
365         --with-background-start-color-stop=0x009431 \
366         --with-background-end-color-stop=0x006300 \
367         --with-background-color=0x00c663 \
368         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
369         --with-release-file=/etc/os-release \
370         --with-system-root-install
371
372 %{__make}
373
374 %install
375 rm -rf $RPM_BUILD_ROOT
376 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{systemdtmpfilesdir}}
377
378 %{__make} install \
379         DESTDIR=$RPM_BUILD_ROOT
380
381 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
382 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/plymouth/default-boot-duration
383 > $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth/boot-duration
384
385 # FC: Add charge, our new default
386 install -d $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/charge
387 cp %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/charge
388 cp $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/glow/{box,bullet,entry,lock}.png $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/charge
389
390 # FC: Drop glow, it's not very Fedora-y
391 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/plymouth/themes/glow
392
393 # FC: Override plymouth-update-initrd to work dracut or mkinitrd
394 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/plymouth/plymouth-update-initrd
395
396 # FC: Add compat script for upgrades
397 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sbindir}
398
399 %{__rm} $RPM_BUILD_ROOT{%{plymouth_libdir},%{_libdir}}/*.la \
400         $RPM_BUILD_ROOT%{_libdir}/plymouth/*.la \
401         $RPM_BUILD_ROOT%{_libdir}/plymouth/renderers/*.la
402
403 # Temporary symlink until rc.sysinit is fixed
404 ln -sf /bin/plymouth $RPM_BUILD_ROOT%{_bindir}/plymouth
405
406 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
407
408 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
409 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
410
411 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/systemd-ask-password-plymouth.path
412 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/systemd-ask-password-plymouth.service
413
414 # install plymouth services for targets
415 # http://cgit.freedesktop.org/systemd/systemd/commit/?id=26cbf29c52a36b6ad9d1ccc16d8f7adccefeddca
416 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{halt,kexec,poweroff,reboot,sysinit,multi-user}.target.wants
417 ln -sf ../plymouth-start.service $RPM_BUILD_ROOT%{systemdunitdir}/sysinit.target.wants/plymouth-start.service
418 ln -sf ../plymouth-read-write.service $RPM_BUILD_ROOT%{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
419 ln -sf ../plymouth-quit.service $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
420 ln -sf ../plymouth-quit-wait.service $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
421 ln -sf ../plymouth-reboot.service $RPM_BUILD_ROOT%{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
422 ln -sf ../plymouth-kexec.service $RPM_BUILD_ROOT%{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
423 ln -sf ../plymouth-poweroff.service $RPM_BUILD_ROOT%{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
424 ln -sf ../plymouth-halt.service $RPM_BUILD_ROOT%{systemdunitdir}/halt.target.wants/plymouth-halt.service
425
426 %clean
427 rm -rf $RPM_BUILD_ROOT
428
429 %post
430 %systemd_reload
431
432 %postun
433 if [ $1 -eq 0 ]; then
434         rm -f %{_libdir}/plymouth/default.so
435 fi
436 %systemd_reload
437
438 %post   core-libs -p /sbin/ldconfig
439 %postun core-libs -p /sbin/ldconfig
440 %post   graphics-libs -p /sbin/ldconfig
441 %postun graphics-libs -p /sbin/ldconfig
442
443 %files
444 %defattr(644,root,root,755)
445 %doc AUTHORS README TODO
446 %attr(755,root,root) %{_bindir}/plymouth
447 %dir %{_sysconfdir}/plymouth
448 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
449 %{_mandir}/man8/plymouth.8*
450 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
451 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
452 %attr(755,root,root) %{_libdir}/plymouth/details.so
453 %attr(755,root,root) %{_libdir}/plymouth/text.so
454 %attr(755,root,root) %{_libdir}/plymouth/renderers/drm.so
455 %attr(755,root,root) %{_libdir}/plymouth/renderers/frame-buffer.so
456 %dir %{_datadir}/plymouth
457 %dir %{_datadir}/plymouth/themes
458 %dir %{_datadir}/plymouth/themes/details
459 %dir %{_datadir}/plymouth/themes/text
460 %{_datadir}/plymouth/plymouthd.defaults
461 %{_datadir}/plymouth/default-boot-duration
462 %{_datadir}/plymouth/themes/details/details.plymouth
463 %{_datadir}/plymouth/themes/text/text.plymouth
464 %{_pixmapsdir}/plymouth-logo.png
465 %{systemdtmpfilesdir}/%{name}.conf
466 %dir %{_localstatedir}/lib/plymouth
467 %ghost %{_localstatedir}/lib/plymouth/boot-duration
468 %{_localstatedir}/run/plymouth
469 %{_localstatedir}/spool/plymouth
470
471 %{systemdunitdir}/plymouth-halt.service
472 %{systemdunitdir}/plymouth-kexec.service
473 %{systemdunitdir}/plymouth-poweroff.service
474 %{systemdunitdir}/plymouth-quit-wait.service
475 %{systemdunitdir}/plymouth-quit.service
476 %{systemdunitdir}/plymouth-read-write.service
477 %{systemdunitdir}/plymouth-reboot.service
478 %{systemdunitdir}/plymouth-start.service
479 %{systemdunitdir}/systemd-ask-password-plymouth.path
480 %{systemdunitdir}/systemd-ask-password-plymouth.service
481 %{systemdunitdir}/halt.target.wants/plymouth-halt.service
482 %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
483 %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
484 %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
485 %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
486 %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
487 %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
488 %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
489
490 %files core-libs
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{plymouth_libdir}/libply.so.*.*.*
493 %attr(755,root,root) %ghost %{plymouth_libdir}/libply.so.2
494 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so.*.*.*
495 %attr(755,root,root) %ghost %{plymouth_libdir}/libply-splash-core.so.2
496 %attr(755,root,root) %{_libdir}/libply-boot-client.so.*.*.*
497 %attr(755,root,root) %ghost %{_libdir}/libply-boot-client.so.2
498 %dir %{_libdir}/plymouth
499 %dir %{_libdir}/plymouth/renderers
500
501 %files graphics-libs
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so.*.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libply-splash-graphics.so.2
505 %attr(755,root,root) %{_libdir}/plymouth/renderers/x11.so
506
507 %files devel
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{plymouth_libdir}/libply.so
510 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so
511 %attr(755,root,root) %{_libdir}/libply-boot-client.so
512 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so
513 %{_includedir}/plymouth-1
514 %{_pkgconfigdir}/ply-boot-client.pc
515 %{_pkgconfigdir}/ply-splash-core.pc
516 %{_pkgconfigdir}/ply-splash-graphics.pc
517
518 %files scripts
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_sbindir}/plymouth-set-default-plugin
521 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
522 %attr(755,root,root) %{_libdir}/plymouth/plymouth-generate-initrd
523 %attr(755,root,root) %{_libdir}/plymouth/plymouth-populate-initrd
524 %attr(755,root,root) %{_libdir}/plymouth/plymouth-update-initrd
525
526 %files plugin-fade-throbber
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{_libdir}/plymouth/fade-throbber.so
529
530 %files plugin-label
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/plymouth/label.so
533
534 %files plugin-script
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/plymouth/script.so
537
538 %files plugin-space-flares
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_libdir}/plymouth/space-flares.so
541
542 %files plugin-throbgress
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/plymouth/throbgress.so
545
546 %files plugin-two-step
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/plymouth/two-step.so
549
550 %files system-theme
551 %defattr(644,root,root,755)
552
553 %files theme-charge
554 %defattr(644,root,root,755)
555 %dir %{_datadir}/plymouth/themes/charge
556 %{_datadir}/plymouth/themes/charge/*.png
557 %{_datadir}/plymouth/themes/charge/charge.plymouth
558
559 %files theme-fade-in
560 %defattr(644,root,root,755)
561 %dir %{_datadir}/plymouth/themes/fade-in
562 %{_datadir}/plymouth/themes/fade-in/bullet.png
563 %{_datadir}/plymouth/themes/fade-in/entry.png
564 %{_datadir}/plymouth/themes/fade-in/lock.png
565 %{_datadir}/plymouth/themes/fade-in/star.png
566 %{_datadir}/plymouth/themes/fade-in/fade-in.plymouth
567
568 %files theme-spinner
569 %defattr(644,root,root,755)
570 %dir %{_datadir}/plymouth/themes/spinner
571 %{_datadir}/plymouth/themes/spinner/*.png
572 %{_datadir}/plymouth/themes/spinner/spinner.plymouth
573
574 %files theme-spinfinity
575 %defattr(644,root,root,755)
576 %dir %{_datadir}/plymouth/themes/spinfinity
577 %{_datadir}/plymouth/themes/spinfinity/box.png
578 %{_datadir}/plymouth/themes/spinfinity/bullet.png
579 %{_datadir}/plymouth/themes/spinfinity/entry.png
580 %{_datadir}/plymouth/themes/spinfinity/lock.png
581 %{_datadir}/plymouth/themes/spinfinity/throbber-[0-3][0-9].png
582 %{_datadir}/plymouth/themes/spinfinity/spinfinity.plymouth
583
584 %files theme-solar
585 %defattr(644,root,root,755)
586 %dir %{_datadir}/plymouth/themes/solar
587 %{_datadir}/plymouth/themes/solar/*.png
588 %{_datadir}/plymouth/themes/solar/solar.plymouth
589
590 %files theme-script
591 %defattr(644,root,root,755)
592 %dir %{_datadir}/plymouth/themes/script
593 %{_datadir}/plymouth/themes/script/*.png
594 %{_datadir}/plymouth/themes/script/script.script
595 %{_datadir}/plymouth/themes/script/script.plymouth
This page took 0.129553 seconds and 4 git commands to generate.