]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- pl
[packages/plymouth.git] / plymouth.spec
1 # TODO
2 # - revisit subpackages
3 # - fix: Requires: /bin/bash
4 # - integrate with geninitrd
5 %define         snap    20120212
6 Summary:        Graphical Boot Animation and Logger
7 Summary(pl.UTF-8):      Graficzna animacja i logowanie startu systemu
8 Name:           plymouth
9 Version:        0.8.4
10 Release:        0.%{snap}.1
11 License:        GPL v2+
12 Group:          Base
13 #Source0:       http://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.%{snap}.tar.bz2
14 Source0:        %{name}-%{version}.%{snap}.tar.bz2
15 # Source0-md5:  6accf3a89fa9e5a99fbc4eb63909bcd5
16 Source1:        %{name}-logo.png
17 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
18 Source2:        %{name}.tmpfiles
19 URL:            http://www.freedesktop.org/wiki/Software/Plymouth
20 #BuildRequires: autoconf >= 2.50
21 #BuildRequires: automake
22 BuildRequires:  cairo-devel
23 BuildRequires:  gtk+2-devel >= 2:2.12.0
24 BuildRequires:  libdrm-devel
25 BuildRequires:  libpng-devel >= 1.2.16
26 #BuildRequires: libtool >= 2:2.0
27 BuildRequires:  pango-devel >= 1:1.21.0
28 BuildRequires:  pkgconfig
29 Requires:       %{name}-libs = %{version}-%{release}
30 Requires(post): %{name}-scripts = %{version}-%{release}
31 Obsoletes:      plymouth-utils
32 Obsoletes:      plymouth-gdm-hooks
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         plymouthdaemon_execdir  /sbin
36 %define         plymouthclient_execdir  /bin
37 %define         plymouth_libdir         /%{_lib}
38
39 %description
40 Plymouth provides an attractive graphical boot animation in place of
41 the text messages that normally get shown. Text messages are instead
42 redirected to a log file for viewing after boot.
43
44 %description -l pl.UTF-8
45 Plymouth zapewnia atrakcyjną animację w trakcie startu systemu zamiast
46 zwykle wyświetlanych komunikatów tekstowych. Komunikaty tekstowe
47 zamiast tego są przekierowywane do logu, który można obejrzeć po
48 uruchomieniu systemu.
49
50 %package libs
51 Summary:        Plymouth libraries
52 Summary(pl.UTF-8):      Biblioteki Plymouth
53 Group:          Libraries
54
55 %description libs
56 This package contains the libply and libplybootsplash libraries used
57 by Plymouth.
58
59 %description libs -l pl.UTF-8
60 Ten pakiet zawiera biblioteki libply i libplybootsplash używane przez
61 Plymouth.
62
63 %package devel
64 Summary:        Header files for writing Plymouth splash plugins
65 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia wtyczek graficznych Plymouth
66 Group:          Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68
69 %description devel
70 This package contains the header files for libply and libplybootsplash
71 libraries needed to develop 3rd party splash plugins for Plymouth.
72
73 %description devel -l pl.UTF-8
74 Ten pakiet zawiera pliki nagłówkowe bibliotek libply i
75 libplybootsplash, potrzebne do tworzenia wtyczek graficznych Plymouth.
76
77 %package scripts
78 Summary:        Plymouth related scripts
79 Summary(pl.UTF-8):      Skrypty pomocnicze do Plymouth
80 Group:          Applications/System
81 Requires:       %{name} = %{version}-%{release}
82
83 %description scripts
84 This package contains scripts that help integrate Plymouth with the
85 system.
86
87 %description scripts -l pl.UTF-8
88 Ten pakiet zawiera skrypty pomagające zintegrować Plymouth z systemem.
89
90 %prep
91 %setup -q
92
93 %build
94 %configure \
95         --disable-silent-rules \
96         --disable-static \
97         --disable-tests \
98         --enable-gdm-transition \
99         --enable-systemd-integration \
100         --enable-tracing \
101         --with-background-start-color-stop=0x003194 \
102         --with-background-end-color-stop=0x000063 \
103         --with-background-color=0x0063c6 \
104         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
105         --with-system-root-install
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT{%{plymouth_libdir},%{_libdir}}/*.la \
117         $RPM_BUILD_ROOT%{_libdir}/plymouth/*.la \
118         $RPM_BUILD_ROOT%{_libdir}/plymouth/renderers/*.la
119
120 # Temporary symlink until rc.sysinit is fixed
121 ln -sf /bin/plymouth $RPM_BUILD_ROOT%{_bindir}/plymouth
122
123 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
124 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
125
126 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
127 install %{SOURCE2} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %postun
133 if [ $1 -eq 0 ]; then
134         rm -f %{_libdir}/plymouth/default.so
135 fi
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS README TODO
143 %attr(755,root,root) %{_bindir}/rhgb-client
144 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
145 %dir %{_sysconfdir}/plymouth
146 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
147 %{_mandir}/man8/plymouth.8*
148 %dir %{_datadir}/plymouth
149 %{_datadir}/plymouth/plymouthd.defaults
150 %{_datadir}/plymouth/themes
151 %dir %{_libexecdir}/plymouth
152 %dir %{_localstatedir}/lib/plymouth
153 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
154 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
155 %attr(755,root,root) %{_bindir}/plymouth
156 %attr(755,root,root) %{_libdir}/plymouth/details.so
157 %attr(755,root,root) %{_libdir}/plymouth/fade-throbber.so
158 %attr(755,root,root) %{_libdir}/plymouth/label.so
159 %attr(755,root,root) %{_libdir}/plymouth/script.so
160 %attr(755,root,root) %{_libdir}/plymouth/space-flares.so
161 %attr(755,root,root) %{_libdir}/plymouth/text.so
162 %attr(755,root,root) %{_libdir}/plymouth/throbgress.so
163 %attr(755,root,root) %{_libdir}/plymouth/two-step.so
164 /usr/lib/tmpfiles.d/%{name}.conf
165 %{_localstatedir}/run/plymouth
166 %{_localstatedir}/spool/plymouth
167 %{_pixmapsdir}/plymouth-logo.png
168
169 %files libs
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{plymouth_libdir}/libply.so.*.*.*
172 %attr(755,root,root) %ghost %{plymouth_libdir}/libply.so.2
173 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so.*.*.*
174 %attr(755,root,root) %ghost %{plymouth_libdir}/libply-splash-core.so.2
175 %attr(755,root,root) %{_libdir}/libply-boot-client.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libply-boot-client.so.2
177 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libply-splash-graphics.so.2
179 %dir %{_libdir}/plymouth
180 %dir %{_libdir}/plymouth/renderers
181 %attr(755,root,root) %{_libdir}/plymouth/renderers/drm.so
182 %attr(755,root,root) %{_libdir}/plymouth/renderers/frame-buffer.so
183 %attr(755,root,root) %{_libdir}/plymouth/renderers/x11.so
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{plymouth_libdir}/libply.so
188 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so
189 %attr(755,root,root) %{_libdir}/libply-boot-client.so
190 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so
191 %{_includedir}/plymouth-1
192 %{_pkgconfigdir}/ply-boot-client.pc
193 %{_pkgconfigdir}/ply-splash-core.pc
194 %{_pkgconfigdir}/ply-splash-graphics.pc
195
196 %files scripts
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-generate-initrd
199 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-populate-initrd
200 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-update-initrd
This page took 0.042642 seconds and 4 git commands to generate.