]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- up to 0.8.2
[packages/plymouth.git] / plymouth.spec
1 # TODO
2 # - revisit subpackages
3 # - fix: Requires: /bin/bash
4 Summary:        Graphical Boot Animation and Logger
5 Name:           plymouth
6 Version:        0.8.2
7 Release:        0.1
8 License:        GPL v2+
9 Group:          Base
10 Source0:        http://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
11 # Source0-md5:  c2a45a9f1584f0051b6ab214527fd98e
12 Source1:        %{name}-logo.png
13 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
14 Patch0:         libdrm.patch
15 URL:            http://www.freedesktop.org/wiki/Software/Plymouth
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  gtk+2-devel
20 BuildRequires:  libdrm-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtool
23 BuildRequires:  pango-devel >= 1:1.21.0
24 BuildRequires:  pkgconfig
25 Requires(post): %{name}-scripts = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         plymouthdaemon_execdir  /sbin
29 %define         plymouthclient_execdir  /bin
30 %define         plymouth_libdir                 /%{_lib}
31
32 %description
33 Plymouth provides an attractive graphical boot animation in place of
34 the text messages that normally get shown. Text messages are instead
35 redirected to a log file for viewing after boot.
36
37 %package libs
38 Summary:        Plymouth libraries
39 Group:          Development/Libraries
40
41 %description libs
42 This package contains the libply and libplybootsplash libraries used
43 by Plymouth.
44
45 %package devel
46 Summary:        Libraries and headers for writing Plymouth splash plugins
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       pkgconfig
50
51 %description devel
52 This package contains the libply and libplybootsplash libraries and
53 headers needed to develop 3rd party splash plugins for Plymouth.
54
55 %package utils
56 Summary:        Plymouth related utilities
57 Group:          Applications/System
58 Requires:       %{name} = %{version}-%{release}
59
60 %description utils
61 This package contains utilities that integrate with Plymouth including
62 a boot log viewing application.
63
64 %package scripts
65 Summary:        Plymouth related scripts
66 Group:          Applications/System
67
68 %description scripts
69 This package contains scripts that help integrate Plymouth with the
70 system.
71
72 %package gdm-hooks
73 Summary:        Plymouth GDM integration
74 Group:          Applications/System
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       gdm >= 1:2.22.0
77 Requires:       plymouth-utils
78
79 %description gdm-hooks
80 This package contains support files for integrating Plymouth with GDM
81 Namely, it adds hooks to show boot messages at the login screen in the
82 event start-up services fail.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         --enable-tracing \
95         --disable-tests \
96         --without-boot-entry \
97         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
98         --with-background-start-color-stop=0x0073B3 \
99         --with-background-end-color-stop=0x00457E \
100         --with-background-color=0x3391cd \
101         --enable-gdm-transition \
102         --with-system-root-install
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
113 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
114
115 # Temporary symlink until rc.sysinit is fixed
116 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
117
118 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
119 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
120 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 [ -f %{_localstatedir}/lib/plymouth/boot-duration ] || cp -f %{_datadir}/plymouth/default-boot-duration %{_localstatedir}/lib/plymouth/boot-duration
127
128 %postun
129 if [ $1 -eq 0 ]; then
130         rm -f %{_libdir}/plymouth/default.so
131 fi
132
133 %post libs -p /sbin/ldconfig
134 %postun libs -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README
139 %attr(755,root,root) %{_bindir}/rhgb-client
140 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
142 %{_mandir}/man8/plymouth.8*
143 %dir %{_datadir}/plymouth
144 %{_datadir}/plymouth/plymouthd.defaults
145 %{_datadir}/plymouth/themes
146 %dir %{_libexecdir}/plymouth
147 %dir %{_localstatedir}/lib/plymouth
148 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
149 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
150 %attr(755,root,root) %{_bindir}/plymouth
151 %{_libdir}/plymouth/details.so
152 %{_libdir}/plymouth/fade-throbber.so
153 %{_libdir}/plymouth/label.so
154 %{_libdir}/plymouth/script.so
155 %{_libdir}/plymouth/space-flares.so
156 %{_libdir}/plymouth/text.so
157 %{_libdir}/plymouth/throbgress.so
158 %{_libdir}/plymouth/two-step.so
159 %{_localstatedir}/run/plymouth
160 %{_localstatedir}/spool/plymouth
161 %{_pixmapsdir}/plymouth-logo.png
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{plymouth_libdir}/libply.so
166 %{plymouth_libdir}/libply-splash-core.so
167 %{_libdir}/libply-boot-client.so
168 %{_libdir}/libply-splash-graphics.so
169 %{_pkgconfigdir}/ply-boot-client.pc
170 %{_pkgconfigdir}/ply-splash-core.pc
171 %{_pkgconfigdir}/ply-splash-graphics.pc
172 %{_includedir}/plymouth-1
173
174 %files libs
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{plymouth_libdir}/libply.so.*.*.*
177 %attr(755,root,root) %ghost %{plymouth_libdir}/libply.so.2
178 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so.*.*.*
179 %attr(755,root,root) %ghost %{plymouth_libdir}/libply-splash-core.so.2
180 %attr(755,root,root) %{_libdir}/libply-boot-client.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libply-boot-client.so.2
182 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libply-splash-graphics.so.2
184 %dir %{_libdir}/plymouth
185 %attr(755,root,root) %{_libdir}/plymouth/renderers/drm.so
186 %attr(755,root,root) %{_libdir}/plymouth/renderers/frame-buffer.so
187 %attr(755,root,root) %{_libdir}/plymouth/renderers/x11.so
188
189 %files scripts
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-generate-initrd
192 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-populate-initrd
193 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-update-initrd
194
195 %files utils
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
198
199 %files gdm-hooks
200 %defattr(644,root,root,755)
201 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
This page took 0.332446 seconds and 4 git commands to generate.