]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- release 2.
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
4 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
5 Name:           gaim
6 Version:        0.52
7 Release:        2
8 Epoch:          1
9 License:        GPL
10 Group:          Applications/Communications
11 Source0:        http://prdownloads.sourceforge.net/gaim/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gg_logoff.patch
13 URL:            http://gaim.sourceforge.net/
14 BuildRequires:  ORBit-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gnome-libs-devel >= 1.2.13
18 BuildRequires:  esound-devel
19 BuildRequires:  gtk+-devel >= 1.2.5
20 BuildRequires:  gettext-devel
21 BuildRequires:  libtool
22 BuildRequires:  perl-devel
23 BuildRequires:  gnome-core-devel
24 BuildRequires:  gdk-pixbuf-devel
25 Requires:       applnk
26 Requires:       gaim-ui
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _prefix         /usr/X11R6
30 %define         _sysconfdir     /etc/X11/GNOME
31 %define         _mandir         %{_prefix}/man
32
33 %description
34 Gaim allows you to talk to anyone using AOL's Instant Messenger
35 service (you can sign up at http://www.aim.aol.com). It uses the TOC
36 version of the AOL protocol, so your buddy list is stored on AOL's
37 servers and can be retrieved from anywhere. It contains many of the
38 same features as AOL's IM client while at the same time incorporating
39 many new features. Gaim also contains a multiple connection feature
40 which consists of protocol plugins. These plugins allow you to use
41 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
42 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
43
44 %description -l pl
45 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
46 Messenger (mo¿na siê zarejstrowaæ pod adresem
47 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
48 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
49 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
50 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
51 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
52 oraz Gadu-Gadu.
53
54 %description -l pt_BR
55 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
56 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
57 características do cliente da AOL, tendo uma interface similiar.
58 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
59 MSN, Jabber e Napster.
60
61 %package ui-gtk
62 Summary:        gtk+ user interface for gaim
63 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
64 Group:          Applications/Communications
65 Provides:       gaim-ui
66
67 %description ui-gtk
68 gtk+ user interface for gaim.
69
70 %description ui-gtk -l pl
71 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
72
73 %package ui-gnome
74 Summary:        GNOME user interface for gaim (applet)
75 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
76 Group:          Applications/Communications
77 Provides:       gaim-ui
78
79 %description ui-gnome
80 GNOME user interface for gaim (applet).
81
82 %description ui-gnome -l pl
83 Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 rm  -f missing
91 libtoolize --copy --force
92 gettextize --copy --force
93 aclocal -I m4
94 autoheader
95 autoconf
96 automake -a -c
97 %configure \
98         --disable-panel \
99         --enable-esd \
100         --disable-nas \
101         --disable-artsc \
102         --with-gnome
103 %{__make}
104 mv plugins/iconaway{,_standalone}.so
105 mv src/gaim{,_standalone}
106 %{__make} clean
107
108 %configure \
109         --enable-panel \
110         --enable-esd \
111         --disable-nas \
112         --disable-artsc \
113         --with-gnome
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 # NOTE: make ignores gaimdesktopdir set below.
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT \
122         gaimdesktopdir=%{_applnkdir}/Network/Communications \
123         distribdesktopdir=%{_applnkdir}/Network/Communications
124
125 mv $RPM_BUILD_ROOT{%{_datadir}/gnome/apps/Internet/gaim.desktop,%{_applnkdir}/Network/Communications}
126
127 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
128 install plugins/iconaway_standalone.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
129 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
130
131 gzip -9nf AUTHORS ChangeLog NEWS README* TODO HACKING \
132         doc/{CREDITS,FAQ}
133
134 %find_lang %{name} --with-gnome --all-name
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc {*,doc/*}.gz
142 %dir %{_libdir}/gaim
143 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
144 %{_pixmapsdir}/*
145 %{_mandir}/man?/*
146
147 %files ui-gtk
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/gaim
150 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
151 %{_applnkdir}/Network/Communications/gaim.desktop
152
153 %files ui-gnome
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/gaim_applet
156 %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
157 %{_applnkdir}/Network/Communications/gaim_applet.desktop
158 %{_sysconfdir}/CORBA/servers/*
This page took 0.069851 seconds and 4 git commands to generate.