]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- uncomment %patch{0,1}.
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
4 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
5 Name:           gaim
6 Version:        0.59.2
7 Release:        1
8 Epoch:          1
9 License:        GPL
10 Group:          Applications/Communications
11 Source0:        http://belnet.dl.sourceforge.net/sourceforge/gaim/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gg_logoff.patch
13 Patch1:         %{name}-am_ac.patch
14 URL:            http://gaim.sourceforge.net/
15 BuildRequires:  ORBit-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gnome-libs-devel >= 1.2.13
19 BuildRequires:  esound-devel
20 BuildRequires:  gtk+-devel >= 1.2.5
21 BuildRequires:  gettext-devel
22 BuildRequires:  libtool
23 BuildRequires:  perl-devel
24 BuildRequires:  gnome-core-devel
25 BuildRequires:  gdk-pixbuf-devel
26 Requires:       applnk
27 Requires:       gaim-ui = %{version}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _prefix         /usr/X11R6
31 %define         _sysconfdir     /etc/X11/GNOME
32 %define         _mandir         %{_prefix}/man
33
34 %description
35 Gaim allows you to talk to anyone using AOL's Instant Messenger
36 service (you can sign up at http://www.aim.aol.com). It uses the TOC
37 version of the AOL protocol, so your buddy list is stored on AOL's
38 servers and can be retrieved from anywhere. It contains many of the
39 same features as AOL's IM client while at the same time incorporating
40 many new features. Gaim also contains a multiple connection feature
41 which consists of protocol plugins. These plugins allow you to use
42 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
43 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
44
45 %description -l pl
46 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
47 Messenger (mo¿na siê zarejstrowaæ pod adresem
48 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
49 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
50 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
51 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
52 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
53 oraz Gadu-Gadu.
54
55 %description -l pt_BR
56 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
57 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
58 características do cliente da AOL, tendo uma interface similiar.
59 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
60 MSN, Jabber e Napster.
61
62 %package ui-gtk
63 Summary:        gtk+ user interface for gaim
64 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
65 Group:          Applications/Communications
66 Provides:       gaim-ui = %{version}-%{release}
67
68 %description ui-gtk
69 gtk+ user interface for gaim.
70
71 %description ui-gtk -l pl
72 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
73
74 %package ui-gnome
75 Summary:        GNOME user interface for gaim (applet)
76 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
77 Group:          Applications/Communications
78 Provides:       gaim-ui = %{version}-%{release}
79
80 %description ui-gnome
81 GNOME user interface for gaim (applet).
82
83 %description ui-gnome -l pl
84 Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
85
86 %prep
87 %setup -qn %{name}-%{version}
88 %patch0 -p1
89 %patch1 -p1
90
91 %build
92 rm -f missing
93 %{__libtoolize}
94 %{__gettextize}
95 aclocal -I m4
96 autoheader
97 %{__autoconf}
98 %{__automake}
99 %configure \
100         --disable-panel \
101         --enable-esd \
102         --disable-nas \
103         --disable-artsc \
104         --disable-gnome \
105         --with-gtk-prefix=/usr/X11R6 \
106         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
107 %{__make} 
108 mv plugins/iconaway{,_standalone}.so
109 mv src/gaim{,_standalone}
110 %{__make} clean
111
112 %configure \
113         --enable-panel \
114         --enable-esd \
115         --disable-nas \
116         --disable-artsc \
117         --enable-gnome \
118         --with-gtk-prefix=/usr/X11R6 \
119         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
120 %{__make}
121         
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 # NOTE: make ignores gaimdesktopdir set below.
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         gaimdesktopdir=%{_applnkdir}/Network/Communications \
129         distribdesktopdir=%{_applnkdir}/Network/Communications
130
131 mv $RPM_BUILD_ROOT{%{_datadir}/gnome/apps/Internet/gaim.desktop,%{_applnkdir}/Network/Communications}
132
133 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
134 install plugins/iconaway_standalone.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
135 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
136
137 gzip -9nf AUTHORS ChangeLog NEWS README* TODO HACKING \
138         doc/{CREDITS,FAQ}
139
140 %find_lang %{name} --with-gnome --all-name
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc {*,doc/*}.gz
148 %dir %{_libdir}/gaim
149 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
150 %{_pixmapsdir}/*
151 %{_mandir}/man?/*
152
153 %files ui-gtk
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/gaim
156 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
157 %{_applnkdir}/Network/Communications/gaim.desktop
158
159 %files ui-gnome
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/gaim_applet
162 %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
163 %{_applnkdir}/Network/Communications/gaim_applet.desktop
164 %{_sysconfdir}/CORBA/servers/*
This page took 0.047929 seconds and 4 git commands to generate.