]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- we don't need -lnsl
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(ko):    AOL ÀνºÅÏÆ® ¸Þ½ÅÀú¿Í È£È¯µÇ´Â Å¬¶óÀ̾ðÆ®
4 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
5 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
6 Name:           gaim
7 Version:        0.64
8 Release:        0.2
9 Epoch:          1
10 License:        GPL
11 Group:          Applications/Communications
12 Source0:        http://dl.sourceforge.net/gaim/%{name}-%{version}.tar.bz2
13 # Source0-md5:  8876251a650a8341ca6969a4f5334082
14 # Patch0:               %{name}-gg_logoff.patch
15 # Patch1:               %{name}-am_ac.patch
16 # Patch2:               %{name}-tw.patch
17 URL:            http://gaim.sourceforge.net/
18 BuildRequires:  ORBit-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gnome-libs-devel >= 1.2.13
22 BuildRequires:  esound-devel
23 BuildRequires:  gtk+2-devel >= 2.1.0
24 BuildRequires:  gettext-devel
25 BuildRequires:  libtool
26 BuildRequires:  perl-devel
27 BuildRequires:  gnome-core-devel
28 BuildRequires:  gdk-pixbuf-devel
29 Requires:       applnk
30 Requires:       gaim-ui = %{version}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/X11/GNOME
34 %define         _prefix /usr/X11R6
35
36 %description
37 Gaim allows you to talk to anyone using AOL's Instant Messenger
38 service (you can sign up at http://www.aim.aol.com). It uses the TOC
39 version of the AOL protocol, so your buddy list is stored on AOL's
40 servers and can be retrieved from anywhere. It contains many of the
41 same features as AOL's IM client while at the same time incorporating
42 many new features. Gaim also contains a multiple connection feature
43 which consists of protocol plugins. These plugins allow you to use
44 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
45 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
46
47 %description -l pl
48 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
49 Messenger (mo¿na siê zarejstrowaæ pod adresem
50 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
51 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
52 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
53 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
54 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
55 oraz Gadu-Gadu.
56
57 %description -l pt_BR
58 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
59 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
60 características do cliente da AOL, tendo uma interface similiar.
61 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
62 MSN, Jabber e Napster.
63
64 %package ui-gtk
65 Summary:        gtk+ user interface for gaim
66 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
67 Group:          Applications/Communications
68 Provides:       gaim-ui = %{version}-%{release}
69
70 %description ui-gtk
71 gtk+ user interface for gaim.
72
73 %description ui-gtk -l pl
74 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
75
76 # %package ui-gnome
77 # Summary:      GNOME user interface for gaim (applet)
78 # Summary(pl):  Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
79 # Group:                Applications/Communications
80 # Provides:     gaim-ui = %{version}-%{release}
81
82 # %description ui-gnome
83 # GNOME user interface for gaim (applet).
84
85 # %description ui-gnome -l pl
86 # Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
87
88 %prep
89 %setup -qn %{name}-%{version}
90 # %patch0 -p1
91 # %patch1 -p1
92 # %patch2 -p1
93
94 %build
95 rm -f missing
96 %{__libtoolize}
97 %{__gettextize}
98 %{__aclocal} 
99 %{__autoheader}
100 %{__autoconf}
101 %{__automake}
102 %configure \
103         --disable-panel \
104         --enable-esd \
105         --disable-nas \
106         --disable-artsc \
107         --disable-gnome \
108         --with-gtk-prefix=/usr/X11R6 \
109         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
110 %{__make} 
111 mv plugins/.libs/iconaway{,_standalone}.so
112 mv src/gaim{,_standalone}
113 %{__make} clean
114
115 %configure \
116         --enable-panel \
117         --enable-esd \
118         --disable-nas \
119         --disable-artsc \
120         --enable-gnome \
121         --with-gtk-prefix=/usr/X11R6 \
122         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
123 %{__make}
124         
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications
128
129 # NOTE: make ignores gaimdesktopdir set below.
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         gaimdesktopdir=%{_applnkdir}/Network/Communications \
133         distribdesktopdir=%{_applnkdir}/Network/Communications
134
135 mv $RPM_BUILD_ROOT{%{_datadir}/applications/gaim.desktop,%{_applnkdir}/Network/Communications}
136
137 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
138 install plugins/.libs/iconaway.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
139 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
140
141 %find_lang %{name} --with-gnome --all-name
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog NEWS README* TODO HACKING doc/{CREDITS,FAQ}
149 %dir %{_libdir}/gaim
150 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
151 %{_pixmapsdir}/*
152 %{_mandir}/man?/*
153 %{_datadir}/sounds/%{name}/*.wav
154
155 %files ui-gtk
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/gaim
158 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
159 %{_applnkdir}/Network/Communications/gaim.desktop
160
161 # %files ui-gnome
162 # %defattr(644,root,root,755)
163 # %attr(755,root,root) %{_bindir}/gaim_applet
164 # %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
165 # %{_applnkdir}/Network/Communications/gaim_applet.desktop
166 # %{_sysconfdir}/CORBA/servers/*
This page took 0.098838 seconds and 3 git commands to generate.