]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- version 2.0.0 release 1.beta6.3: merged from DEVEL
[packages/pidgin.git] / pidgin.spec
1 # TODO
2 # - nas, silc/silcclient?
3 # - kerberos 4 with zephyr support?
4 # - external zephyr?
5 #   http://packages.qa.debian.org/z/zephyr.html
6 #
7 %bcond_without  cap             # without Contact Availability Prediction
8 %bcond_without  dbus            # without dbus (for gaim-remote and others)
9 %bcond_without  doc             # do not generate and include documentation
10 %bcond_without  evolution       # compile without the Gaim-Evolution plugin
11 %bcond_without  gtkspell        # without gtkspell support
12 %bcond_without  meanwhile       # without meanwhile support
13 %bcond_without  text            # don't build text UI
14 #
15 %define         _pre    beta6
16 %include        /usr/lib/rpm/macros.perl
17 Summary:        A client compatible with AOL's 'Instant Messenger'
18 Summary(de.UTF-8):      Gaim ist ein Instant Messenger
19 Summary(ko.UTF-8):      AOL 인스턴트 메신저와 호환되는 클라이언트
20 Summary(pl.UTF-8):      Klient kompatybilny z AOL Instant Messenger
21 Summary(pt_BR.UTF-8):   Um cliente para o AOL Instant Messenger (AIM)
22 Name:           gaim
23 Version:        2.0.0
24 Release:        1.%{_pre}.3
25 Epoch:          1
26 License:        GPL
27 Group:          Applications/Communications
28 Source0:        http://dl.sourceforge.net/gaim/%{name}-%{version}%{_pre}.tar.bz2
29 # Source0-md5:  404dcec261f911bcb56f69e5ea192583
30 #Source0:       http://dl.sourceforge.net/gaim/%{name}-%{version}.tar.bz2
31 Patch0:         %{name}-nolibs.patch
32 Patch2:         %{name}-GG-evo.patch
33 Patch3:         %{name}-dbus-dir.patch
34 Patch4:         %{name}-libgadu.patch
35 URL:            http://gaim.sourceforge.net/
36 BuildRequires:  GConf2-devel >= 2.16.0
37 BuildRequires:  audiofile-devel
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  bind-devel
41 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.71}
42 %{?with_evolution:BuildRequires:        evolution-data-server-devel >= 1.8.1}
43 BuildRequires:  gettext-autopoint
44 BuildRequires:  gettext-devel
45 BuildRequires:  gnutls-devel
46 BuildRequires:  gstreamer-devel >= 0.10.10
47 BuildRequires:  gtk+2-devel >= 2:2.10.6
48 %{?with_gtkspell:BuildRequires: gtkspell-devel >= 2.0.11}
49 BuildRequires:  intltool
50 BuildRequires:  mdns-howl-devel
51 %{?with_meanwhile:BuildRequires:        meanwhile-devel}
52 BuildRequires:  libgadu-devel
53 BuildRequires:  libtool
54 BuildRequires:  libxml2-devel >= 2.6.26
55 BuildRequires:  perl-devel
56 BuildRequires:  pkgconfig
57 BuildRequires:  python-modules
58 BuildRequires:  rpm-perlprov
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  rpmbuild(macros) >= 1.177
61 BuildRequires:  tcl-devel
62 BuildRequires:  tk-devel
63 %{?with_text:BuildRequires:     ncurses-ext-devel}
64 %if %{with cap}
65 BuildRequires:  sqlite3-devel >= 3.3
66 %endif
67 %if %{with doc}
68 BuildRequires:  doxygen
69 BuildRequires:  graphviz
70 %endif
71 Requires(post,preun):   GConf2 >= 2.16.0
72 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
73 # weird: it *should* break after DynaLoader's version change, but it doesn't
74 #Requires:      perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
75 Obsoletes:      gaim-ui
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 Gaim allows you to talk to anyone using AOL's Instant Messenger
80 service (you can sign up at http://www.aim.aol.com). It uses the TOC
81 version of the AOL protocol, so your buddy list is stored on AOL's
82 servers and can be retrieved from anywhere. It contains many of the
83 same features as AOL's IM client while at the same time incorporating
84 many new features. Gaim also contains a multiple connection feature
85 which consists of protocol plugins. These plugins allow you to use
86 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
87 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
88
89 %description -l pl.UTF-8
90 Gaim pozwala na rozmowy z dowolną osobą używającą usługi AOL Instant
91 Messenger (można się zarejestrować pod adresem
92 http://www.aim.aol.com/). Program używa wersji TOC protokołu AOL więc
93 Twoja lista kontaktów jest zapisana na serwerze AOL i może być
94 przesłana gdziekolwiek. Gaim zawiera wiele udogodnień dostępnych w
95 kliencie AOL IM jak również dodaje własne. Gaim umożliwia także dostęp
96 do usług takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
97 oraz Gadu-Gadu.
98
99 %description -l pt_BR.UTF-8
100 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
101 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
102 características do cliente da AOL, tendo uma interface similiar.
103 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
104 MSN, Jabber e Napster.
105
106 %description -l de.UTF-8
107 Gaim ist ein Instant Messenger der von Mark Spencer ursprünglich für
108 unixähnliche Systeme (GNU/Linux, BSD) geschrieben wurde, nun aber auch
109 auf Microsoft Windows und Mac OS X lauffähig ist und mit vielen
110 Plugins stark erweitert werden kann.
111
112 %package libs
113 Summary:        Gaim client library
114 Summary(pl.UTF-8):   Biblioteka klienta Gaim
115 Group:          Libraries
116 Epoch:          1
117
118 %description libs
119 Gaim client library.
120
121 %description libs -l pl.UTF-8
122 Biblioteka klienta Gaim.
123
124 %package devel
125 Summary:        Development files for Gaim client library
126 Summary(pl.UTF-8):   Pliki programistyczne biblioteki klienta Gaim
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
129 Requires:       gtk+2-devel >= 2:2.10.6
130
131 %description devel
132 Development files for gaim.
133
134 %description devel -l pl.UTF-8
135 Pliki programistyczne biblioteki gaim-remote.
136
137 %package perl
138 Summary:        Gaim files for Perl scripts
139 Summary(pl.UTF-8):   Pliki Gaima dla skryptów w Perlu
140 Group:          Libraries
141 Requires:       %{name} = %{epoch}:%{version}-%{release}
142
143 %description perl
144 This package gives you ability to extend Gaim functionality with Perl
145 scripts.
146
147 %description perl -l pl.UTF-8
148 Ten pakiet daje możliwość rozszerzania funkcjonalności Gaima za pomocą
149 skryptów Perla.
150
151 %package tcl
152 Summary:        Gaim files for Tcl scripts
153 Summary(pl.UTF-8):   Pliki Gaima dla skryptów w Tcl-u
154 Group:          Libraries
155 Requires:       %{name} = %{epoch}:%{version}-%{release}
156
157 %description tcl
158 This package gives you ability to extend Gaim functionality with Tcl
159 scripts.
160
161 %description tcl -l pl.UTF-8
162 Ten pakiet daje możliwość rozszerzania funkcjonalności Gaima za pomocą
163 skryptów w Tcl-u.
164
165 %package plugin-evolution
166 Summary:        Plugin for Ximian Evolution integration
167 Summary(pl.UTF-8):   Wtyczka do integracji z Evolution
168 Group:          Libraries
169 Requires:       %{name} = %{epoch}:%{version}-%{release}
170
171 %description plugin-evolution
172 Provides integration with Ximian Evolution.
173
174 %description plugin-evolution -l pl.UTF-8
175 Wtyczka do integracji z Evolution.
176
177 %package plugin-remote
178 Summary:        Gaim Remote Control
179 Summary(pl.UTF-8):   Zdalne sterowanie Gaimem
180 Group:          Libraries
181 Requires:       %{name} = %{epoch}:%{version}-%{release}
182
183 %description plugin-remote
184 This package gives Gaim the ability to be remote-controlled through
185 third-party applications or through the gaim-remote tool.
186
187 %description plugin-remote -l pl.UTF-8
188 Ten pakiet daje możliwość zdalnego sterowania Gaimem przez inne
189 aplikacje albo narzędzie gaim-remote.
190
191 %package doc
192 Summary:        Gaim documentation for developers (HTML format)
193 Summary(pl.UTF-8):   Dokumentacja Gaim dla programistów (format HTML)
194 Group:          Documentation
195
196 %description doc
197 Gaim documentation for developers (HTML format).
198
199 %description doc -l pl.UTF-8
200 Dokumentacja Gaim dla programistów (format HTML).
201
202 %triggerpostun -- %{name} < 1:1.3.1-1.10
203 %banner -e %{name} <<EOF
204 The Ximian Evolution and gaim-remote plugins have been separated to separate packages.
205 If you need then please install %{name}-plugin-evolution and %{name}-plugin-remote
206 EOF
207
208 %prep
209 %setup -qn %{name}-%{version}%{_pre}
210 %patch0 -p1
211 %patch2 -p1
212 %patch3 -p1
213 %patch4 -p1
214
215 %build
216 %{__libtoolize}
217 %{__aclocal} -I m4macros
218 %{__autoheader}
219 %{__autoconf}
220 %{__automake}
221 %configure \
222         --disable-nas \
223         --enable-nss=no \
224         --with-perl-lib=vendor \
225         --%{?with_cap:en}%{!?with_cap:dis}able-cap \
226         %{?with_dbus:--enable-dbus --with-dbus-session-dir=/usr/share/dbus-1/services} \
227         %{!?with_dbus:--disable-dbus} \
228         %{!?with_evolution:--disable-gevolution} \
229         %{!?with_gtkspell:--disable-gtkspell} \
230         --%{?with_text:en}%{!?with_text:dis}able-consoleui
231
232 %{__make}
233 %{?with_doc:%{__make} docs}
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237
238 %{__make} install \
239         DESTDIR=$RPM_BUILD_ROOT
240
241 rm -f $RPM_BUILD_ROOT%{_libdir}/gaim/{,private}/*.la
242 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/{ca@valencia,ca_ES@valencian,my_MM}
243
244 %find_lang %{name} --with-gnome
245 rm -f $RPM_BUILD_ROOT{%{perl_archlib}/perllocal.pod,%{perl_vendorarch}/auto/Gaim/{,GtkUI}/.packlist}
246
247 %if %{with dbus}
248 rm $RPM_BUILD_ROOT{%{_bindir}/gaim-client-example,%{_libdir}/gaim/dbus-example.so}
249 %endif
250
251 %clean
252 rm -rf $RPM_BUILD_ROOT
253
254 %post
255 %gconf_schema_install gaim.schemas
256
257 %preun
258 %gconf_schema_uninstall gaim.schemas
259
260 %post   libs -p /sbin/ldconfig
261 %postun libs -p /sbin/ldconfig
262
263 %files -f %{name}.lang
264 %defattr(644,root,root,755)
265 %doc AUTHORS ChangeLog{,.API} HACKING NEWS PLUGIN_HOWTO PROGRAMMING_NOTES README* doc/FAQ
266 %attr(755,root,root) %{_bindir}/gaim
267 %dir %{_libdir}/gaim
268 %dir %{_libdir}/gaim/private
269 %if %{with cap}
270 %attr(755,root,root) %{_libdir}/gaim/autoaccept.so
271 %attr(755,root,root) %{_libdir}/gaim/autoreply.so
272 %attr(755,root,root) %{_libdir}/gaim/buddynote.so
273 %attr(755,root,root) %{_libdir}/gaim/cap.so
274 %endif
275 %attr(755,root,root) %{_libdir}/gaim/convcolors.so
276 #%attr(755,root,root) %{_libdir}/gaim/docklet.so
277 %attr(755,root,root) %{_libdir}/gaim/extplacement.so
278 %attr(755,root,root) %{_libdir}/gaim/gaimrc.so
279 %attr(755,root,root) %{_libdir}/gaim/gestures.so
280 %if %{with text}
281 %attr(755,root,root) %{_bindir}/gaim-text
282 %attr(755,root,root) %{_libdir}/gaim/gntgf.so
283 %attr(755,root,root) %{_libdir}/gaim/gnthistory.so
284 %attr(755,root,root) %{_libdir}/gaim/gntlastlog.so
285 %attr(755,root,root) %{_libdir}/gaim/s.so
286 %endif
287 %attr(755,root,root) %{_libdir}/gaim/history.so
288 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
289 %attr(755,root,root) %{_libdir}/gaim/idle.so
290 %attr(755,root,root) %{_libdir}/gaim/libaim.so
291 %attr(755,root,root) %{_libdir}/gaim/libbonjour.so
292 %attr(755,root,root) %{_libdir}/gaim/libgg.so
293 %attr(755,root,root) %{_libdir}/gaim/libicq.so
294 %attr(755,root,root) %{_libdir}/gaim/libirc.so
295 %attr(755,root,root) %{_libdir}/gaim/libjabber.so
296 %attr(755,root,root) %{_libdir}/gaim/libmsn.so
297 %attr(755,root,root) %{_libdir}/gaim/libnovell.so
298 %attr(755,root,root) %{_libdir}/gaim/liboscar.so
299 %attr(755,root,root) %{_libdir}/gaim/liboscar.so.*
300 %attr(755,root,root) %{_libdir}/gaim/libqq.so
301 %{?with_meanwhile:%attr(755,root,root) %{_libdir}/gaim/libsametime.so}
302 %attr(755,root,root) %{_libdir}/gaim/libsimple.so
303 %attr(755,root,root) %{_libdir}/gaim/libyahoo.so
304 %attr(755,root,root) %{_libdir}/gaim/libzephyr.so
305 %attr(755,root,root) %{_libdir}/gaim/log_reader.so
306 %attr(755,root,root) %{_libdir}/gaim/markerline.so
307 %attr(755,root,root) %{_libdir}/gaim/newline.so
308 %attr(755,root,root) %{_libdir}/gaim/notify.so
309 %attr(755,root,root) %{_libdir}/gaim/offlinemsg.so
310 %attr(755,root,root) %{_libdir}/gaim/psychic.so
311 %attr(755,root,root) %{_libdir}/gaim/relnot.so
312 %attr(755,root,root) %{_libdir}/gaim/spellchk.so
313 %attr(755,root,root) %{_libdir}/gaim/ssl-gnutls.so
314 %attr(755,root,root) %{_libdir}/gaim/ssl-nss.so
315 %attr(755,root,root) %{_libdir}/gaim/ssl.so
316 %attr(755,root,root) %{_libdir}/gaim/statenotify.so
317 %attr(755,root,root) %{_libdir}/gaim/ticker.so
318 %attr(755,root,root) %{_libdir}/gaim/timestamp.so
319 %attr(755,root,root) %{_libdir}/gaim/timestamp_format.so
320 %attr(755,root,root) %{_libdir}/gaim/xmppconsole.so
321 %if %{with dbus}
322 %attr(755,root,root) %{_bindir}/gaim-url-handler
323 %attr(755,root,root) %{_libdir}/gaim/musicmessaging.so
324 %attr(755,root,root) %{_bindir}/gaim-send
325 %attr(755,root,root) %{_bindir}/gaim-send-async
326 %{_datadir}/dbus-1/services/gaim.service
327 %endif
328 %{_sysconfdir}/gconf/schemas/gaim.schemas
329 %{_datadir}/sounds/%{name}
330 %{_mandir}/man?/*
331
332 %{_desktopdir}/gaim.desktop
333 %{_pixmapsdir}/*
334
335 %files libs
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_libdir}/libgaim.so.*.*.*
338 %if %{with text}
339 %attr(755,root,root) %{_libdir}/libgnt.so.*.*.*
340 %endif
341 %if %{with dbus}
342 %attr(755,root,root) %{_libdir}/libgaim-client.so.*.*.*
343 %endif
344
345 %files devel
346 %defattr(644,root,root,755)
347 %if %{with dbus}
348 %attr(755,root,root) %{_libdir}/libgaim-client.so
349 %attr(755,root,root) %{_libdir}/libgaim.so
350 %{_libdir}/libgaim-client.la
351 %{_libdir}/libgaim.la
352 %endif
353 %{_aclocaldir}/*.m4
354 %dir %{_includedir}/gaim
355 %{_includedir}/gaim/*.h
356 %{_pkgconfigdir}/*
357 %if %{with text}
358 %attr(755,root,root) %{_libdir}/libgnt.so
359 %{_libdir}/libgnt.la
360 %dir %{_includedir}/gaim/gnt
361 %dir %{_includedir}/gnt
362 %{_includedir}/gaim/gnt/*.h
363 %{_includedir}/gnt/*.h
364 %endif
365
366 %files perl
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/gaim/private/libgaimperl.so
369 %attr(755,root,root) %{_libdir}/gaim/perl.so
370 %{perl_vendorarch}/*.pm
371 %dir %{perl_vendorarch}/auto/Gaim
372 %{perl_vendorarch}/auto/Gaim/*.ix
373 %{perl_vendorarch}/auto/Gaim/*.bs
374 %dir %{perl_vendorarch}/auto/Gaim/GtkUI
375 %{perl_vendorarch}/auto/Gaim/GtkUI/*.bs
376 %dir %{perl_vendorarch}/Gaim
377 %{perl_vendorarch}/Gaim/*.pm
378 %attr(755,root,root) %{perl_vendorarch}/auto/Gaim/*.so
379 %attr(755,root,root) %{perl_vendorarch}/auto/Gaim/GtkUI/*.so
380
381 %files tcl
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_libdir}/gaim/tcl.so
384
385 %if %{with evolution}
386 %files plugin-evolution
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_libdir}/gaim/gevolution.so
389 %endif
390
391 %if %{with dbus}
392 %files plugin-remote
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_bindir}/gaim-remote
395 %endif
396
397 %if %{with doc}
398 %files doc
399 %defattr(644,root,root,755)
400 %doc doc/html/*.{html,png,css}
401 %endif
This page took 0.052967 seconds and 3 git commands to generate.